none
Thread was being aborted when deploying in InfoPath

    Question

  • Hi

    I have a fairly complexbrowser based InfoPath form, lots of views and rules, about 500KB in size.

    When I try to deploy the form, 90% of the time I get "An unknown error has occurred. The form template has been publised to the server but it can only be opened in InfoPath filler".

    The strange thing is that sometimes it will deploy and work. I then continue changing rules, after making a backup, try to deploy, and it fails again. Sometimes after a few attempts it deploys, but a lot of the times it refuses, and just gives the same error. Also, very occasionally, it gives the error, but the form was successfully deployed. My problem is that it happens so rarely that I spend the majority of the day trying to get the thing to deploy instead of actually doing the required work.

    In the ULS logs on the WFE server (nothing on App server), I get either this error:

    "ConversionAppDomain is not adding a lease due to a non-cross-domain scenario." but all my data connections are on the same domain, pointing to the same domain, and cross domain connections are allowed.

    Or this error: 

    "A runtime exception was detected. Details follow.  Message: Thread was being aborted.  Technical Details: System.Threading.ThreadAbortException: Thread was being aborted.    

     at MS.Internal.Xml.XPath.CompiledXpathExpr.get_Expression()    
     at Microsoft.Office.InfoPath.Server.SolutionLifetime.XPathManager.CreateXPath(String xPath, XmlNamespaceManager xmlNamespaceManager)    
     at Microsoft.Office.InfoPath.Server.SolutionLifetime.XPathManager.CreateXPath(String xPath, XmlNamespaceManager xmlNamespaceManager, ConverterLogId messageId, ConverterLogLocation logLocation)    
     at Microsoft.Office.InfoPath.Server.Util.SchemaNavigator.ComputeSimpleXPathToRoot(XPathManager xPathManager, Boolean allowGetDom)    
     at Microsoft.Office.InfoPath.Server.Util.ViewPathUtils.LocateXPathInSnippet(SnippetNavigator currentContext, SnippetNavigator snippetContext, ParsedXPath xPath, Solution solution)    
     at Microsoft.Office.InfoPath.Server.Util.ViewPathUtils.LocateXPathInSnippet(SnippetNavigator currentContext, SnippetNavigator snippetContext, ParsedXPath xPath, Solution solution, Boolean addNodesNotInSnippet)    
     at Microsoft.Office.InfoPath.Server.Util.ViewPathUtils.FindSourceInSnippet(ParsedXPath source, SnippetNavigator initialTarget, SnippetNavigator currentContext, Dictionary`2 filterContexts, Solution solution, Boolean& notAllSourcesAreSimplePaths)    
     at Microsoft.Office.InfoPath.Server.Util.ViewPathUtils.FindSourcesInSnippetInternal(View view, SnippetNavigator target, ParsedXPath expression, String& expressionName, AutoAnnotate autoAnnotate, Solution solution, PostbackReason& postbackReason, Boolean isFilterExpression)    
     at Microsoft.Office.InfoPath.Server.Util.ViewPathUtils.FindSourcesInSnippet(View view, SnippetNavigator target, ParsedXPath expression, String& expressionName, AutoAnnotate autoAnnotate, Solution solution, PostbackReason& postbackReason, Boolean isFilterExpression)    
     at Microsoft.Office.InfoPath.Server.SolutionLifetime.RulesAssignmentAction.ProcessAssignmentCalculation(View view, List`1 siteSnippets, Solution solution, PostbackReason& postbackReason)    
     at Microsoft.Office.InfoPath.Server.SolutionLifetime.Rules.AnnotateView(View view)    
     at Microsoft.Office.InfoPath.Server.Converter.SolutionConverter.ConvertView(Solution solution, ConverterDocument converterDocument)    
     at Microsoft.Office.InfoPath.Server.Converter.SolutionConverter.ConvertSolution(Solution solution)    
     at Microsoft.Office.InfoPath.Server.SolutionLifetime.Solution.<>c__DisplayClass2.<ConstructFromXsnFile>b__0()    
     at Microsoft.Office.Server.Diagnostics.FirstChanceHandler.ExceptionFilter(Boolean fRethrowException, TryBlock tryBlock, FilterBlock filter, CatchBlock catchBlock, FinallyBlock finallyBlock)"

    There is one similar post that I can find, but there was no solution. 

    From what I can tell this is a timeout, perhaps in an app pool, but maybe inside Forms Server. I've looked at all the settings that you can change either through Central Admin or Powershell on Forms Server, but I can't find any that helps.

    Any help or advice on whether my hunch is correct and where to increase the timeout would be greatly appreciated.

    Friday, September 21, 2012 9:20 AM

Answers

  • Hi ,

    As far as I know, the default time out for SharePoint 2010 is 120 seconds. In addition to the above mentioned change, here is another place to change in the web.config file.Add the executionTimeout="300" like shown below:

        <httpHandlers>

          <remove verb="*" path="*.asmx" />

        </httpHandlers>

        <customErrors mode="On" />

        <httpRuntime maxRequestLength="51200" executionTimeout="300"/>

        <authentication mode="Windows" />

        <identity impersonate="true" />

    Thanks,

    Entan Ming


    Entan Ming

    TechNet Community Support

    • Marked as answer by MandarbZA Thursday, September 27, 2012 5:36 AM
    Tuesday, September 25, 2012 8:49 AM
    Moderator

All replies

  • Hi,

    I understand that when you try to publish a form to SharePoint, there is an error  ‘Thread was being aborted’. You can try to increase the timeout for the web application.

    Open the C:\inetpub\wwwroot\wss\VirtualDirectories. Open the corresponding porter number and edit the web.config file (Remember to make a copy of this file before editing).Change the time out to 300s:

    <location path="_layouts/UploadEx.aspx">

        <system.web>

          <httpRuntime maxRequestLength="51200" executionTimeout="300" />

        </system.web>

      </location>

    For more information, please refer to this site:

    SOAP error when publishing Infopath form to Sharepoint: http://social.technet.microsoft.com/Forums/en-US/sharepoint2010customization/thread/ea8da113-fe9a-4878-9994-c1f24cc85c37/

    Thanks,

    Entan Ming


    Entan Ming

    TechNet Community Support

    Monday, September 24, 2012 6:53 AM
    Moderator
  • Hi,

    I understand that when you try to publish a form to SharePoint, there is an error  ‘Thread was being aborted’. You can try to increase the timeout for the web application.

    Open the C:\inetpub\wwwroot\wss\VirtualDirectories. Open the corresponding porter number and edit the web.config file (Remember to make a copy of this file before editing).Change the time out to 300s:

    <location path="_layouts/UploadEx.aspx">

        <system.web>

          <httpRuntime maxRequestLength="51200" executionTimeout="300" />

        </system.web>

      </location>

    For more information, please refer to this site:

    SOAP error when publishing Infopath form to Sharepoint: http://social.technet.microsoft.com/Forums/en-US/sharepoint2010customization/thread/ea8da113-fe9a-4878-9994-c1f24cc85c37/

    Thanks,

    Entan Ming


    Entan Ming

    TechNet Community Support

    Thanks for the reply. I tried this, the setting was already at 3600 seconds, I added another 0 to make it 36000, on both servers, did a IIS reset. Tried to publish, but no difference.

    I also did a quick check on how long it takes, from the moment it stops trying to verify the form on the server to the time it gives the error message is 2 minutes, 6 seconds. I'm guessing the specific timeout giving me problems is 2 minutes.

    Tuesday, September 25, 2012 8:10 AM
  • Hi ,

    As far as I know, the default time out for SharePoint 2010 is 120 seconds. In addition to the above mentioned change, here is another place to change in the web.config file.Add the executionTimeout="300" like shown below:

        <httpHandlers>

          <remove verb="*" path="*.asmx" />

        </httpHandlers>

        <customErrors mode="On" />

        <httpRuntime maxRequestLength="51200" executionTimeout="300"/>

        <authentication mode="Windows" />

        <identity impersonate="true" />

    Thanks,

    Entan Ming


    Entan Ming

    TechNet Community Support

    • Marked as answer by MandarbZA Thursday, September 27, 2012 5:36 AM
    Tuesday, September 25, 2012 8:49 AM
    Moderator
  • That seems to have worked. I guess that's a blunt instrument instead of the razor of specifying the page, but good enough for now. I've been publishing for a day and a half now without getting the same error. 

    Thanks a lot Entan.

    Thursday, September 27, 2012 5:36 AM