locked
Outlook 2010 - MAPI Auth Error RRS feed

  • Question

  • Hi team,

    Hopefully someone can help with this. I have just migrated an account from my Exchange 2010 infra to Exchange 2016. Client is running Office 2010 32 bit with the required patches from Jan 2015 and recommended April 2015 patches.

    MAPI/HTTP is enabled globally. After migration I get an error in the Auth section when I check connection status. mail appears to be working fine with no problems. protocol is HTTP (MAPI) as expected and NOT RPC/TCP or RPC/HTTP.

    

    I do not have this issue when running the mailbox with an Outlook 2016 client (64 bit tested). following KBs are installed;

    mso2010-kb2956191-fullfile-x86-glb

    outlookloc2010-kb3114996-fullfile-x86-glb

    outlookloc2010-kb2965295-fullfile-x86-glb

    any help would be appreciated. most articles out there suggest installing above KB's.

    
    Monday, November 13, 2017 9:27 PM

Answers

  • While researching I found the issue referencing the problem in Outlook 2013.  It is basically responding with error because of the initial 401 and the AuthN value, but it should no impact connectivity.  https://support.microsoft.com/en-us/help/3101488/november-10-2015-update-for-outlook-2013-kb3101488

    • Assume that Outlook 2013 connects to an Exchange      server in an intranet by using the MAPI over HTTP transport protocol. If      you open the Connection Status dialog box, the Authn column displays      Error* but not AutoLogon*.

    Since Outlook 2010 is in extended support, MS won’t build any fixes for that version of the client.

    More information:

    If a MapiHttp CONNECT request authenticates using the default autologon level, then the Connection Status Dialog's entry for that connection will have an AuthN column value of "Error*". In this case, the connection is established without us ever receiving a 401, which is how MapiHttp learns the auth scheme of the server. This will happen as follows:

    WinHttp will automatically authenticate to the server as the logged in domain user, and Outlook never sees a 401 returned. Thus, Outlook never learns the auth scheme but successfully authenticate.

    Explain Defect:

    MS say "Error*" in the connection status dialog in the scenario above, even though the connection is established and authenticated.

    • Marked as answer by A R PATEL Monday, December 4, 2017 2:40 PM
    Monday, December 4, 2017 2:40 PM

All replies

  • Hi PATEL,

    As far as I know, Exchange 2016 supports outlook 2010 SP2 and update KB2956191 & KB2965295, please try to update outlook 2010 to SP2 and check again. Details see:

    Supported clients in Exchange 2016

    Service Pack 2 for Microsoft Office 2010 (KB2687455) 32-Bit Edition


    Best Regards,

    Niko Cheng


    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    • Edited by Niko.Cheng Tuesday, November 14, 2017 6:49 AM
    Tuesday, November 14, 2017 6:48 AM
  • I have confirmed that both KBs are installed (both were downloaded again and run and message said they are already installed). alos have confirmed that outlook 2010 is SP2.

    any other suggestions

    Tuesday, November 14, 2017 1:36 PM
  • In addition, when I remove all proxy settings via IE and then launch Outlook, everything is working as expected with no errors. when the proxy is enabled I get the auth error.

    I have the proxy setup to exclude local domains.

    Tuesday, November 14, 2017 4:07 PM
  • Hi PATEL,

    This seems a known issue, for your reference:

    Outlook 2013 cannot connect to Exchange Server 2013 or Exchange Server 2016 using MAPI over HTTP when a proxy is enabled

    MAPI over HTTP - Authn Error

    Hope this helps,


    Best Regards,

    Niko Cheng


    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    • Proposed as answer by Niko.Cheng Tuesday, November 21, 2017 2:07 AM
    Friday, November 17, 2017 9:55 AM
  • Hi PATEL,

    I'm just writing to check how's everything going? If you have any questions or needed further help on this issue, please feel free to post back. If the issue has been resolved, please mark the helpful replies as answers, this will make answer searching in the forum easier and be beneficial to other community members as well.

     

    Thanks for your understanding.


    Best Regards,

    Niko Cheng


    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Monday, December 4, 2017 9:56 AM
  • While researching I found the issue referencing the problem in Outlook 2013.  It is basically responding with error because of the initial 401 and the AuthN value, but it should no impact connectivity.  https://support.microsoft.com/en-us/help/3101488/november-10-2015-update-for-outlook-2013-kb3101488

    • Assume that Outlook 2013 connects to an Exchange      server in an intranet by using the MAPI over HTTP transport protocol. If      you open the Connection Status dialog box, the Authn column displays      Error* but not AutoLogon*.

    Since Outlook 2010 is in extended support, MS won’t build any fixes for that version of the client.

    More information:

    If a MapiHttp CONNECT request authenticates using the default autologon level, then the Connection Status Dialog's entry for that connection will have an AuthN column value of "Error*". In this case, the connection is established without us ever receiving a 401, which is how MapiHttp learns the auth scheme of the server. This will happen as follows:

    WinHttp will automatically authenticate to the server as the logged in domain user, and Outlook never sees a 401 returned. Thus, Outlook never learns the auth scheme but successfully authenticate.

    Explain Defect:

    MS say "Error*" in the connection status dialog in the scenario above, even though the connection is established and authenticated.

    • Marked as answer by A R PATEL Monday, December 4, 2017 2:40 PM
    Monday, December 4, 2017 2:40 PM
  • try to disable cached mode and check proxy settings under IE

    If yes, make a proxy acception for your mail.company.com and autodiscover.company.com


    Chris

    Saturday, December 9, 2017 7:15 PM