Unable to delete items from public folders



    I have a Microsoft Exchange 2003 Server that has a number of items in 2 public folders that I can’t delete. There are about 10 items that I have problems with out of about 2500 items. Here are some things that I noticed:


    When I look at the items with \.\\BackOfficeStorage, two of them show up with the Hidden and System attributes set.


    When I use PFDAVAdmin and look at items, the names show as being blank, and the Item-level Permissions show as “Unknown”. When I try to remove Item Level Permissions, I get “HTTP/1.1 401 Unauthorized” errors.


    If I do a “dir” of the BackOfficeStorage location I get a “The parameter is incorrect” error for each file that is displayed.


    CACLS and XCACLS give “Access is denied” errors.


    XCACLS.VBS {file} produces the error: “Error -2147217406:  occurred setting Win32_LogicalFileSecuritySetting object. (Msg#401)”


    I tried copying the folders and tried to repair the copies by playing with the NT and MAPI file permissions, but no success. The NT owner tab does not show for these documents.


    How can I get rid of these documents?


    I don’t want to create a new folder and copy over only the good documents, because I can’t see all of them with Outlook (PFDAVAdmin shows about 30 extra that don’t show up on outlook even though they have no Item Level  Permissions set on them and I am the owner of the folder). I am worried that these may contain useful information that somebody is using.


    Any solutions/pointers/ideas/help would be greatly appreciated.


    Friday, June 20, 2008 9:55 PM

All replies

  • It is obvious that you have done your homework on this.  I would be VERY VERY careful when messing with the \\.\BackOfficeStorage URL.  It is possible to screw up the ACLs pretty badly that way.   Is your M:\ drive mapped?   This was on by default (bad move by Microsoft) in E2K but it is off in E2K3 (you can enable it in the Registry).  You might be able to delete or set the permissions on the object by navigating the M:\ drive (better known as the Exchange Installable File System.



    Saturday, June 21, 2008 7:54 PM
  • Since we went to E2K3, the M: drive has not been left mapped. Before I started playing with the NT ACLs, I copied the folder and only attempted to change the copy's attributes. The copy was created with ESM, and contains the bad/protected documents. I can also delete the folder with ESM, I just have problems accessing/deleting the individual documents. I tried changing the permissions with Ctrl-[Client Permissions], and when that didnt work with windows explorer and the M: drive, and then with CACLS, XCACLS, and XCACLS.VBS. Nothing I tried has worked.

    Monday, June 23, 2008 1:01 PM