none
Robocopy ERROR 112 (0x00000070) There is not enough space on the disk.

    Question

  • I am trying to migrate data from one server to another server but after copying some folders getting error message and stopped data copy. However on target server has enough free space. I am migrating data from Windows 2003 STD to Windows 2008 R2. The same command used several times and never caused any problem but not sure why getting this error now. Moreover I can't modify folders permission becuase it may disrupt the access. Please suggest how this could be resolved.

    Command : robocopy “\\servername\shares” “\\servername\f$\home” /ZB /E /COPYALL /MIR /R:0 /W:1 /NP /LOG+:users.log /TEE

    Error: 2011/12/23 11:51:19 ERROR 112 (0x00000070) There is not enough space on the disk.

     

    Monday, January 02, 2012 7:39 AM

Answers

  • Hi,

    Thanks for reply, I have figured out the problem. There is folder level Quota enabled and while checking I found that quota settings were wrong. It was set  as "create quota on path" (marked red). Whenever start data copy after sometime it reached to maximum quota limit and start throws error. So i changed it to option " Auto apply template and create quota on existing and new subfolders". This option has resolved the issue becuase it create quota for each folder and its subfolders rather than creating on root folder only.   

     

     


    Saturday, January 07, 2012 2:32 AM

All replies

  • Hi,

     

    I would like to suggest you run the command, chkdsk /f /r on the target machine first.

     

    After that, perform a Clean Boot environment to run the Robocopy commands. For the detailed steps of how to perform a Clean Boot, please refer to the following Microsoft KB article:

     

    How to troubleshoot a problem by performing a clean boot in Windows Vista or in Windows 7

    http://support.microsoft.com/kb/929135

     

    When run the Robocopy commands, please temporarily disable UAC to check the result. For more information of how to disable UAC, please also refer to the following Microsoft KB article:

     

    Disabling User Account Control (UAC) on Windows Server

    http://support.microsoft.com/kb/2526083

     

    For more information, please read the following Microsoft TechNet article and blog:

     

    Robocopy

    http://technet.microsoft.com/en-us/library/cc733145(WS.10).aspx

     

    Robocopy exit codes

    http://blogs.technet.com/b/deploymentguys/archive/2008/06/16/robocopy-exit-codes.aspx

     

    Robocopy /MIR switch – mirroring file permissions

    http://blogs.technet.com/b/filecab/archive/2008/07/31/robocopy-mir-switch-mirroring-file-permissions.aspx

     

    Regards,


    Arthur Li

    TechNet Community Support

    Wednesday, January 04, 2012 5:26 AM
    Moderator
  • There are many reasons could cause this issue.

    Such as:

    1. The format of the target disk is FAT32.

    2. There isn’t enough space on the target disk indeed.

    3. May be the quota management to the target drive is enabled.

     

    Mostly it is issue with Quota. Un check that and try again.


    Gopi Kiran
    Wednesday, January 04, 2012 9:26 PM
  • Hi,

    Thanks for reply, I have figured out the problem. There is folder level Quota enabled and while checking I found that quota settings were wrong. It was set  as "create quota on path" (marked red). Whenever start data copy after sometime it reached to maximum quota limit and start throws error. So i changed it to option " Auto apply template and create quota on existing and new subfolders". This option has resolved the issue becuase it create quota for each folder and its subfolders rather than creating on root folder only.   

     

     


    Saturday, January 07, 2012 2:32 AM
  • I got the same error, my solution:

    I move the file with error (in ROBOCOPY message) with cut/paste to the new location, and ROBOCOPY continue and ends without error.

    Monday, March 11, 2013 11:01 AM