none
Imported workflow activated as feature does not show up in Manage site features page

    Question

  • Hi

    I want to move a workflow (reusable workflow bound to a content type) from one site collection to antoher.

    As a site collection admin, i saved the workflow as a template in SP Designer, saved the .wsp file and uploaded it on the target collection, and activate the solution.

    When I look for it Manage site features page, i can't see the wokflow, in order to activate it.

    I did the same solution importation and activation in Central Administratrion but wihout succes : it  doesn't show up in the Manage site features page. 
    I also run the Enable-SPFeature command in the SP Management Shell and is has sucesfully activated the feature.  Still it dont's show in the Manage site features page, and the workflow does not appear when i try to associate it to a library.

    Thanks.


    Monday, May 14, 2012 7:56 PM

Answers

  • Hi Emir, thanks for the reply.

    I tried to migrate the workflow with Visio and got the follwoing error in SP Designer :

    "This workflow cannot be imported because it was created in SharePoint Designer for a different site, or the original workflow has been moved or deleted. To move a workflow between sites, use Save as Template (.wsp file) instead of a Visio workflow drawing."

    I tried the following workaround but it didn't work (workflow forms and  parameters are not correctly migrated, maybe copying only part of the workflow.xoml.wfconfig.xml file but not all of it may work, i will look into that):

    http://chanakyajayabalan.wordpress.com/2012/01/02/copyingmoving-sharepoint-2010-designer-workflows/

    I am quite sure the problem with exporting/importing the .wsp file is because the original site HAS A DIFFERENT LANGUAGE than the target site.

    To resolve the language issue, in another forum someone suggest to import the .wsp file in Visual Sutido  (Import SharePoint Solution Package NOT Import Reusable Workflow) and remove the resource file. Here are the septs to follow :

    If so you can solve it by importing the .wsp in Visual Studio (Import SharePoint Solution Package NOT Import Reusable Workflow) and remove the resource file.

    To do this:

    • with SharePoint Designer, export the reusable workflow (using Save As Template) as a .wsp and save the file on your development machine
    • create a New Project in Visual Studio, select "Import SharePoint Solution Package"
    • type the name of your new solution
    • in step 2 of the wizard, browse to the .wsp you saved in the first step
    • click finish
    • in the Solution Explorer find the Features node and open Feature1
    • find the resources.XXX.resx file (XXX is the language) and Delete it

    You can make other changes the project while it's open in Visual Studio, you could change the feature name and description for example, and even edit the workflow but there are caveats

    You can use F5 to deploy the workfow and test it. After you confirmed everything still works right-click on the project and select 'Package' to create your new .wsp in the bin directory of the project.

    Thanks.



    Wednesday, May 16, 2012 2:54 PM

All replies

  • Hi Mihnea,

    I am unable to reproduce your issue. When the .wsp file uploaded to Solutions gallery and activated, this feature will be available in site features even in sub site. And we don’t need to go to Central Administration to do further settings.

    I'm not sure why this issue occurs on your environment. But as a workaround, could you please export the workflow to Visio then Import the Visio file back to target site collection?
    http://office.microsoft.com/en-us/sharepoint-designer-help/transfer-workflows-between-sharepoint-designer-and-visio-HA101890958.aspx

    Thanks & Regards,
    Emir


    Emir Liu

    TechNet Community Support

    Wednesday, May 16, 2012 8:59 AM
  • Hi Emir, thanks for the reply.

    I tried to migrate the workflow with Visio and got the follwoing error in SP Designer :

    "This workflow cannot be imported because it was created in SharePoint Designer for a different site, or the original workflow has been moved or deleted. To move a workflow between sites, use Save as Template (.wsp file) instead of a Visio workflow drawing."

    I tried the following workaround but it didn't work (workflow forms and  parameters are not correctly migrated, maybe copying only part of the workflow.xoml.wfconfig.xml file but not all of it may work, i will look into that):

    http://chanakyajayabalan.wordpress.com/2012/01/02/copyingmoving-sharepoint-2010-designer-workflows/

    I am quite sure the problem with exporting/importing the .wsp file is because the original site HAS A DIFFERENT LANGUAGE than the target site.

    To resolve the language issue, in another forum someone suggest to import the .wsp file in Visual Sutido  (Import SharePoint Solution Package NOT Import Reusable Workflow) and remove the resource file. Here are the septs to follow :

    If so you can solve it by importing the .wsp in Visual Studio (Import SharePoint Solution Package NOT Import Reusable Workflow) and remove the resource file.

    To do this:

    • with SharePoint Designer, export the reusable workflow (using Save As Template) as a .wsp and save the file on your development machine
    • create a New Project in Visual Studio, select "Import SharePoint Solution Package"
    • type the name of your new solution
    • in step 2 of the wizard, browse to the .wsp you saved in the first step
    • click finish
    • in the Solution Explorer find the Features node and open Feature1
    • find the resources.XXX.resx file (XXX is the language) and Delete it

    You can make other changes the project while it's open in Visual Studio, you could change the feature name and description for example, and even edit the workflow but there are caveats

    You can use F5 to deploy the workfow and test it. After you confirmed everything still works right-click on the project and select 'Package' to create your new .wsp in the bin directory of the project.

    Thanks.



    Wednesday, May 16, 2012 2:54 PM