locked
Missing Icons and Red x's in my OWA all of a sudden

    Question

  •  

    I was having issues of OWA not working at all and found out it was my permissions.  I set those correctly and now we are able to log into OWA but something else was changed as now when you are viewing mail via OWA - either inside our server or outside the toolbar icons nor the sidebar ones show up - you can hover your mouse over them and read what they are but viewing them they are either just boxes or red x's.  I changed nothing in our firewall etc.  CAn anyone help?

     

    Thanks!

    Wednesday, August 27, 2008 4:40 PM

All replies

  • Hi,

    What version your OWA is?

    What is the Internet Browser,IE6.0 or IE 7.0?

    Did this issue occur to all the OWA user

    Besides, you can try the below steps to check the issue.

    1.    Please check whether try to give the Authenticated Users group access to the Exchsrvr\Exchweb folder to solve the problem.

    2.    Please check Anonymous access option has been enabled for Exchweb virtual directory.

    3.    Please check whether ISUR account there.

    4.    If it is empty there, then please follow the next steps to reset ISUR account.

    Detail troubleshoot steps you can refer to the below article, though it is about “loading”, you can refer it to check your settings.

    Troubleshooting OWA when the contents frame displays “Loading”

    http://support.microsoft.com/kb/280823/en-us

    If that do not help, then please try to follow the below steps to reset IUSR Account password for ExchWeb Virtual.

    1.    Reset ISUR account.

    a. Please open “Computer management” (Note:”Start”-“Control Panel”-“Administrative Tools”-“Computer management”),

    b. Expand to “local users and groups”Right click on IUSR_<computername> and choose set password,

    c. Click proceed (where computername is your computer name),provide a new password and confirm


    2. Please run the below command form a command prompt. It will change the to the required directory

    cd C:\inetpub\adminscripts

    cscript adsutil.vbs set w3svc/anonymoususerpass <new password> (where the new password is the same as what you set in step 1)


    3. Open MMC for IIS, put in the IUSR account and the new password for ExchWeb virtual directory.

    Hope it helps.

    Xiu

     

     
    Friday, August 29, 2008 3:31 AM
  • Xiu - thanks so much for responding.  I went thru the list of things you gave me - all were already done the correct way.  I feel it is either a permissions issue somewhere I am missing or an update conflict?  It is for all users inside our domain and outside when we check our mail via OWA.  It seems to have slowed up loading the pages as well.  It takes a long time to load the OWA when it never used to.  Boy, any help you could give me would be greatly appreciated.  It is Exchange 2003 on a 2003 server.  THANKS!

     

     

     

    Tuesday, September 02, 2008 2:45 PM
  • Hi,

    1.    Please try to recreate the IUSR Account and use this account for the Anonymous access

    2.    Please right click on “/exchweb” directory in IIS manager.
    1). Go to “Virtual Directory” tab “Application Settings”, click on “Create”.
    2). Then click on “Configuration” under “wildcard application maps”.
    3). Select “Davex.dll” and click on remove

    3.    Please go to “/exchweb” Virtual Directory tab, check whether it use local path. You can use the “Browse” button to re-write the Local Path to point to the correct Exchweb folder on the local hard drive. (It should like: c:\program files\Exchsrvr\ExchWeb)

    (this solution assumes the “A directory located on this computer” selection is appropriate for the user’s deployment, and selected, and further that the local path may have been truncated or incorrect)

    4.    Please check whether any GPO setting has affect this issue.If you do not has any special GPO, then please running the “GPOFix /target:both” command to reset the default GPO's.

    More related information share with you:

    DHTML Editing Control in IE7+

    http://blogs.msdn.com/ie/archive/2006/06/27/648850.aspx

    Missing or corrupted files cause the body of an e-mail message to be a gray box that has a red X in the upper-left corner in Exchange Server 2003

    http://support.microsoft.com/kb/922249/en-us

    Hope it helps.

    Xiu

     
    Wednesday, September 03, 2008 6:01 AM
  • Thanks for your reply but I guess I'm not making myself clear - the red x's are NOT in the body of the email.  It is just the icons in the menu bars on top of OWA and on the side where say like Calendar, Inbox etc all are.  We can see the pics in the body of the messages just fine - it is the icons in the menu bars or side bars that do not show up - just red x's.  Does this make sense? 

     

    Thanks,

    Tina

     

    Monday, September 08, 2008 4:37 PM
  • Hi,

    I understand that the red x’s appear on the toolbar but not the mail body.

    Please go through the troubleshoot steps in my previous post.

    Then please try to browse the /exchange virtual directory in IIS manager to see whether it can display sidebar. (Note: Right click on “Exchange” and “Browse”).

    Please try to disable Anti-virus scan on IIS Server.

    BTW, please try to use other Internet Brower to check the issue, such as Firefox etc.

    After that if all the steps do not help, then please follow the below article to reset all the virtual directory.

    How to reset the default virtual directories that are required to provide Outlook Web Access, Exchange ActiveSync, and Outlook Mobile Access services in Exchange Server 2003

    http://support.microsoft.com/kb/883380

    The various steps needed to reset OWA folder and Internet Information Services (IIS) security permissions.

    http://www.msexchange.org/tutorials/Resetting-OWA-Folder-IIS-security-permissions-Exchange-2003.html

    Hope it helps.

    Xiu

     

    Tuesday, September 09, 2008 2:24 AM
  • Ok - I will do all of this - thanks so much for the help!  I'll let you know.  This is driving me and my users crazy.  I use Trend Micro virus protection but never had any of these issues until recently.  We also now get an error when you try to delete an email via OWA that the message has either been moved, deleted or we are denied access to this acct - you can send, reply etc but cannot delete in OWA - however you can delete the same messages if you are in Outlook - this is new since I've been messing around with all the permissions and settings.  OWA also seems very very slow to load and move around in now as well.  Just weird stuff.

     

    Thanks again....

    Tuesday, September 09, 2008 11:57 PM
  • OK - I deleted my virtual directories, recreated them, reset permissions per that site you gave me.  I can now delete emails again via OWA but I still get red x's or dots for icons and it is still very very slow loading.  I DId unload my virus protection as well.  ANy other suggestions?  I have not installed the newst exchg service pack - would that help?

     

    Wednesday, September 10, 2008 1:24 AM
  • Hi,
     
    Then have you try to access owa use other Internet Browser?
     
    Try to access owa out of your network and then use IE like Firefox or IE without any add-ons installed to check the issue.
     
    Regards,
    Xiu
    Wednesday, September 10, 2008 6:54 AM
  • None of this has helped or worked.  It is outside the server as well - using another browser - same issue.  I am just certain its a permissions thing but i can't find it.  I've looked at everything.  Still unresolved.  But thanks!

     

    Friday, September 26, 2008 4:14 PM
  • I am having the exact same issue.  I have tried all of the above w/ no success.  If I find anything new, I'll be certain to share.
    Thursday, October 02, 2008 3:15 PM
  • Do you have a BE-FE scenario, if yes then try to browse OWA, by entering http://<servername>/exchange

    And it would be name of the BE.

    If it works then check the installed updates on the FE and BE. Make sure that they are equally updated

    Do you have any certificates installed?

    Is FBA(Form-Based Authentication) enabled?

    Tuesday, October 07, 2008 12:17 AM
  • I too have the exact same issue. It is a fresh install of Exchange 2003 Enterprise SP2 on Windows R2 SP2. I am attempting to access exchange from the BE /exchange directory. I am able to log in but I get the "loading..." with red x boxes throughout the page. The account I'm using to access the page is the exchange service account. Upon checking the internet, it was suggested to install exchange patch KB911829 which has been installed. Still getting the red X.
    Tuesday, January 06, 2009 1:59 PM
  • Enable Basic Authentication. Which is the third check box and enable the first check box under authentication under Exchweb in IIS. 
    Friday, October 09, 2009 2:32 AM
  • Hi,

    Hello, Dear Sir,

     

    I hope you will be best in your health, I am sending to you one Issue \Error which I am facing in my (OWA) when my company users are going to access emails by means of OWA the page does not load completely.

     

    Note: when I am accessing OWA through local IP: it’s working fine.

     

    OWA does not load correctly, or just says loading.

     

    When I try log into OWA it either does not load correctly or it loads the column in the left hand side but does not load the actual messages, contacts etc...

     

    Pleas see screen shots.

    After the browsing URL: http:\\ tec …

     

     

    Then assigned user name & password I found the below OWA status:

     

     

    When I use Firefox and Google, the page will load a little bit better but you can see that the graphics do not fully load. I followed the "Troubleshooting OWA when the contents frame displays “Loading”" article from Microsoft attempting to resolve the issue but I did not have success. I also followed a couple of the articles on different web sites to fix problem but I did not success

    I have installed GFI Network monitoring software, each & everything working fine, I am not sure what where the problem exists. Any ideas?

     

     

    Thank you

    Warm Regards,
    Amjad Sindhi

    Tuesday, December 08, 2009 2:35 PM
  • Any other ideas on this?  Also now on a Win 7, IE 8 machine in my domain on Exchg 2003, in OWA, it cannot reply or respond to any control buttons.  I get the message on the page "exchweb/6.5.7651.60/controls/util_view.js"  Any ideas on this??  Thank you so much!!

    Friday, March 05, 2010 9:22 PM
  • I have the same problem, Exchange 2003 SP2 all updates on Server 2003. I have tried the above, no dice either and OWA is unusable in this state.
    Sunday, July 04, 2010 8:29 PM
  • The above "Enable Basic Authentication. Which is the third check box and enable the first check box under authentication under Exchweb in IIS. "

     

    Worked for me, however this is not a safe way to leave OWA. I have since disabled that. With that info does that give anyone an idea as to what might be causing the problem? Obviously permission based but what exactly?

     

    Thanks!

    Friday, July 30, 2010 5:08 AM
  • Try this...

    Manually remove the "Exchange OWA Cookie Authentication ISAPI Filter"
    (owaauth.dll) under the Default Web Site. IISRESET Test OWA

    open gpedit.msc on the CAS server and browse to the following
    location:

    Computer Config > Windows Settings > Security Settings > Local Policies > User
    Rights Assignment > "Deny access to this computer from the network"

    ==> Do you see Anonymous and Guests listed as "denied" which is sometimes
    added via Security Configuration Tool.
    ==> IF so, remove these two entires from the policy and run gpupdate /force then
    IISReset.

    ==> ASP.net can also cause failed uploads of gifs and images. Install the latest and if you have the latest, reinstall it.

    HTH

    Jeff
     

    Saturday, July 31, 2010 2:52 AM
  • I just enabled the Digest authentication and another one, unchecking the clear text option. Works fine now and as far as I know is secure and safe.

     

    But your steps may work as well.

     

    Thanks for the reply!

    • Proposed as answer by venom66 Sunday, August 08, 2010 7:28 PM
    Monday, August 02, 2010 10:50 PM
  • Check to make sure all of the subfolders are listed under Exchweb.  I had the same issue and was missing the theme folder as well as a number of the .gif files listed in the img folder.  I was able to copy them from a working exchange server and this fixed the missing (red x) icon issue. 
    Thursday, February 03, 2011 9:19 PM
  • my computer antivirus told me to uninstall red x it was a virus
    Wednesday, December 26, 2012 1:47 PM