none
Lync 2013 database installation error RRS feed

  • Question

  • I've installing Lync 2013 Server EE, and having SQL Server 2012 as my BEnd server for it. When I goes to publish the Topology, it is giving me the error:

    ****Creating DbSetupInstance for 'Microsoft.Rtc.Common.Data.XdsDatabase'****
    Initializing DbSetupBase
    Parsing parameters...
    Found Parameter: SqlServer Value SQLSrv01.LyncNET2.com\RTC.
    Found Parameter: SqlFilePath Value C:\Program Files\Common Files\Microsoft Lync Server 2013\DbSetup.
    Found Parameter: Publisheracct Value LyncNET2\RTCUniversalServerAdmins.
    Found Parameter: Replicatoracct Value LyncNET2\RTCUniversalConfigReplicator.
    Found Parameter: Consumeracct Value LyncNET2\RTCUniversalReadOnlyAdmins.
    Found Parameter: Role Value master.
    Trying to connect to Sql Server SQLSrv01.LyncNET2.com\RTC. using windows authentication...
    Exception Stack:
    Type: System.InvalidOperationException, Message: Cannot open Service Control Manager on computer 'SQLSrv01.LyncNET2.com'. This operation might require other privileges.
    Type: System.ComponentModel.Win32Exception, Message: The RPC server is unavailable

    1. Admin01 has all the permission in the world which is required for installing. He is the member of CsAdministrators, RTCUniversalServerAdmins, RTCCUniversalComponentService, RTCHSUniversalServices, local Admin rights on Lync 2013 and SQL server 2012.

    2. SQLDba is member of RTCUniversalReadOnlyAdmins.

    3. LyncShare has required perms for RTCUniversalServerAdmins, RTCCUniversalComponentService, RTCUniversalConfigReplicator, RTCUniversalServices.

    Any suggestion is highly appreciated.


    Rajneesh Kumar MCSE - Server Infra, MCITP - SA, CNA

    Monday, March 28, 2016 9:50 PM

All replies

  • SQLDba must be added as a sysadmin in SQL. Check if the account have permission.

    http://thamaraw.com

    Tuesday, March 29, 2016 12:20 AM
  • Hi,

    Yes, as I said, all the accounts has necessary perms. assigned to them. SQLDba has local Admin perms. on SQL server, and SysAdmin perms. already assigned to it.

    when I tried to Publish the Topology, earlier I got above error, now I'm receiving "An error occurred: "Microsoft.Rtc.Management.Deployment.DeploymentException" "Cannot determine where to install database files because Windows Management Instrumentation on the database server is unavailable from your computer or user account. To continue, you can resolve this issue, or you can specify where you want to install the files."

    I'm using different pool name to my Lync server name, and DNS A record already is in place for the pool name.

    When I tried to install database from Lync shell by  using Install-csdatabse -SQLServername <xxxxxname..com> -path, I received another error

    Do I missing something more?

    Any suggestion?


    Rajneesh Kumar MCSE - Server Infra, MCITP - SA, CNA

    Tuesday, March 29, 2016 8:11 AM
  • try

    Install-CsDatabase -ConfiguredDatabases -SqlServerFqdn atl-sql-001.litwareinc.com -SqlInstanceName <name of the instance> -DatabasePaths "E:\CSLog","F:\CSLog","G:\CSDB"


    http://thamaraw.com

    Wednesday, March 30, 2016 12:52 AM
  • Thanks for the suggestion, as I did try this but couldn't, actually what that the root directory was missing as you can see (Logs, Database. & Reports). Even after running the cmd, I got the same error as network path was not found, then I share those folders, and it worked successfully.

    Now, I've DB created, will try to publish the topology when gets time. Will update how it goes ahead. Hopefully, this time I wouldn't have any errors.

    Install-CsDatabase -ConfiguredManageDatabases -SqlServerFqdn atl-sql-001.litwareinc.com -SqlInstanceName <name of the instance> -DatabasePaths "E:\Logs\CSLog","E:\Reports\CSLog","E:\Database\CSDB"





    Rajneesh Kumar MCSE - Server Infra, MCITP - SA, CNA

    • Proposed as answer by PaulB_NZMVP Thursday, April 14, 2016 2:42 AM
    Wednesday, March 30, 2016 10:15 AM