none
ecp allows login but 500 internal server error afterwards

    Question

  • Fresh install of Exchange 2016

    Installed on Server 2016 Essentials

    Exchange was working alongside my wordpress site. My wordpress site is in wwwroot and is the default site. 

    I added Certify the web app for Let's Encrypt for my wordpress site. Sometime after this the ecp quit working. I'm not certain if it's related or not. Honestly I don't know where to begin here. 

    Wordpress works perfectly with ssl working. 

    OWA works perfectly with ssl working.

    ECP will pull up the login page but after logging in I get a 500 error.

    So to try to fix this I restored a temporary VM from backup that only had exchange on it in a fully working state. I then installed wordpress and the same thing happened again. OWA works but ECP doesn't. Same error. This time when I installed wordpress I created a new site instead of dumping the wordpress site into the wwwroot folder. So now it's wwwroot\wordpress. I haven't reinstalled the SSL yet or touched anything with bindings, etc. 


    Wednesday, May 22, 2019 5:00 AM

All replies

  • Hi

    Honestly, i would split wordpress and exchange. you going to run into issues most likely all the time.

    You restored the VM from backup, i hope this was not a snapshot as those are not supported. Reverting it would mean loss of data. Are you running AD on this server as well?


    Hope this helps. Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Wednesday, May 22, 2019 5:57 PM
    Moderator
  • Thank you for your reply. I did restore from a snapshot but this wasn't a live system so it didn't matter at this point. I just ended up restoring the Essentials server without Exchange and spun up another member server for Exchange. The only thing now is I'm going to have to figure out a reverse proxy to put in front of both Essentials and Exchange to get port 443 on both servers working correctly. I run my Wordpress sites on IIS with TLS using host headers. That works perfectly but I'm unaware of any other way to get Exchange owa and ecp functioning another way with only single public ip address. Do you have any suggestions for that configuration? 
    Friday, May 24, 2019 4:14 AM
  • Hi,

    Is your ECP virtual directory configured properly? Please run the following command to check the VD configuration. 

    Get-EcpVirtualDirectory | fl server, Name, ExternalURL, InternalURL, *auth*

    I met a similar issue which is related to the incomplete installation of .NET Framework. It is solved by running the following command in elevated command line.

    %windir%\Microsoft.NET\Framework\v4.0.30319\aspnet_regiis.exe -i

    For your reference:

    Exchange 2013 OWA/ECP HTTP 500 Internal Server Error

    Besides, a new installed Exchange server would not have the issue. You can also try to reinstall Exchange and see if it helps.

    Regards,

    Dawn Zhou


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Wednesday, May 29, 2019 2:05 AM
    Moderator