none
2012 Server R2 shuts down instead of restart RRS feed

  • Question

  • From routine online searching, I see that this problem has hit various people over the years:  suddenly a 2012 R2 system will not restart, and instead shuts down when a restart is tried from within Windows.

    In my case, the problem hit today after the system was automatically restarted by Windows Update, though the update history does not show anything installed with today's date.  The last batch of updates installed have a date of August 14, though perhaps today's automatic (failed) restart was a result of Update losing patience waiting for a manual restart, and restarting to complete installation of the August 14 batch.

    One of the items installed was "2019-08 Security Monthly Quality Rollup for Windows Server 2012 R2 for x64-based Systems (KB4512488)"

    As an experiment, I tried installing an additional recommended update, Microsoft .NET Framework 4.8 for Windows Server 2012 R2 for x64 (KB4486105).  It seemed to install OK, and requested a restart to complete.  I restarted, but noticed that the dialog did not say "Update and restart" the way it usually would if there was an update partly installed.  It just said restart.  I selected that, and again the server shut down rather than restarting.  The event log through the failed restart and later manual reboot is very clean, no errors or warnings to provide any hints.

    After the server was manually booted up, the Windows Update history indicated that KB4486105 installation was successful, though strangely the Windows Update log had the following entries at the moment of the restart that was really a shutdown:

    2019-08-20    22:01:03:474     844    12c0    AU    Initiating Install-at-shutdown
    2019-08-20    22:01:03:474     844    12c0    Shutdwn    Checking to see whether install at shutdown is appropriate
    2019-08-20    22:01:03:474     844    12c0    Shutdwn    user declined update at shutdown
    2019-08-20    22:01:03:474     844    12c0    AU    AU initiates service shutdown
    2019-08-20    22:01:03:474     844    12c0    AU    ###########  AU: Uninitializing Automatic Updates  ###########
    2019-08-20    22:01:03:474     844    12c0    WuTask    Uninit WU Task Manager
    2019-08-20    22:01:04:724     844    1230    Agent      * WARNING: Exit code = 0x8024000B
    2019-08-20    22:01:04:724     844    1230    Agent    *********
    2019-08-20    22:01:04:724     844    1230    Agent    **  END  **  Agent: Finding updates [CallerId = AutomaticUpdates  Id = 4]
    2019-08-20    22:01:04:724     844    1230    Agent    *************
    2019-08-20    22:01:04:724     844    1230    Agent    WARNING: WU client failed Searching for update with error 0x8024000b
    2019-08-20    22:01:04:724     844    1230    IdleTmr    WU operation (CSearchCall::Init ID 4, operation # 42820) stopped; does not use network; is at background priority
    2019-08-20    22:01:04:740     844    12c0    Report    CWERReporter finished handling 1 events. (00000000)
    2019-08-20    22:01:04:740     844    12c0    AU    Found invalid timer to remove:
    2019-08-20    22:01:04:740     844    12c0    AU        Timer: 31DA7559-FE27-4810-8FF6-987195B1FD98, Expires 2019-08-21 01:59:20, not idle-only, not network-only
    2019-08-20    22:01:04:757     844    12c0    AU    Earliest future timer found:
    2019-08-20    22:01:04:757     844    12c0    AU        Timer: 7971F918-A847-4430-9279-4A52D1EFE18D, Expires 2019-08-21 03:09:51, not idle-only, network-only
    2019-08-20    22:01:04:866     844    12c0    AU    Earliest future timer found:
    2019-08-20    22:01:04:866     844    12c0    AU        Timer: 29A863E7-8609-4D1E-B7CD-5668F857F1DB, Expires 2019-08-22 00:18:23, not idle-only, not network-only
    2019-08-20    22:01:05:179     844    12c0    Service    *********
    2019-08-20    22:01:05:179     844    12c0    Service    **  END  **  Service: Service exit [Exit code = 0x240001]
    2019-08-20    22:01:05:179     844    12c0    Service    *************

    And now the power dialog says "Update and restart" though it's not clear what updates might be pending.

    The machine is a Dell PowerEdge R420.  Any insights would be appreciated.


    • Edited by CBHCMC Wednesday, August 21, 2019 5:43 AM
    Wednesday, August 21, 2019 5:25 AM

All replies

  • Check Group Policy settings on your server and try to resolve this by changing below settings,

    1. Press Windows Key+R to open the run prompt.
    2. Type "gpedit.msc" and press enter.
    3. In the "Local Group Policy Editor", navigate to Computer Configuration > Administrative Templates > Windows Components > Windows Update.
    4. Check the Enable the "Configure Automatic Updates" policy 
    5. and Enable the "No auto-restart with logged on users for scheduled automatic updates installations" policy.

    If you can't configure them correctly, please refer these,

    https://blogs.technet.microsoft.com/wsus/2013/10/08/enabling-a-more-predictable-windows-update-experience-for-windows-8-and-windows-server-2012-kb-2885694/

    https://support.microsoft.com/en-us/help/3138615/windows-update-client-for-windows-8-1-and-windows-server-2012-r2-march

     

    Wednesday, August 21, 2019 6:41 AM
  • My problem is not the timing of restarts related to Windows Update.  My problem is the computer won't restart at all.  It shuts down instead, whether or not the attempted restart is related to updates.  Sooner or later it will need to restart for updates, and because it sits in a remote data center, it will be offline for hours until someone manually boots it.
    Wednesday, August 21, 2019 8:22 AM
  • Publish your WSUS related GP settings here to find root cause
    Wednesday, August 21, 2019 11:13 AM
  • No GP settings are configured for WSUS; everything is default.  Nor were any settings changed ever.  Note that this problem is not specific to WSUS.  The system also fails to restart after a user-initiated restart from within Windows.  The settings you mention seem to be related to preventing automatic restarts at inconvenient times, and that is not my problem.

    People have been reporting failed-restart problems with 2012 server since 2013 at least.  Sometimes it's blamed on BIOS or firmware being incompatible with the latest Windows updates, or some Windows update causing some device to fail that causes the shutdown-restart sequence to fail.  The exact cause seems to vary over time.  I posted my problem in case it will hit others with the same hardware or due to the same recent updates.  I am in a tough position to figure it out because my server is remote and I can't easily try lots of random things to see if anything helps.

    Wednesday, August 21, 2019 9:27 PM
  • Hi,

    You can run DISM /Image:C:\ /Get-Packages command to check the pending updates (if any).

    If there is one, you can un-install it by running the following commands:

     Dism /Image:C:\ /Cleanup-Image /revertpendingactions

    Then reboot the machine and check the issue.

    Best Regards,

     


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, August 22, 2019 4:30 PM
    Moderator