none
Unable to register workflow service in SharePoint 2013 RRS feed

  • Question

  • I am trying to enable Workflow 2013 feature in SharePoint Designer 2013 and for that I installed Workflow Manager.

    I am at the last step where you register workflow service using the following command but I am getting error.

    COMMAND

    Register-SPWorkflowService -SPSite "http://myserver:1267" -WorkflowHostUri "https://myserver:12291/" -AllowOAuthHttp

    ERROR

    Register-SPWorkflowService : The root of the certificate chain is not a trusted root authority.

    Then I changed the HTTPS to HTTP in command as well as port number from 12291 to 12290 but again error.

    COMMAND

    Register-SPWorkflowService -SPSite "http://myserver:1267" -WorkflowHostUri "http://myserver:12290/" -AllowOAuthHttp

    ERROR

    Register-SPWorkflowService : The underlying connection was closed: An unexpected error occurred on a receive.

    What do I do now?

    Monday, October 7, 2013 7:53 AM

Answers

  • Could you check if your workflow proxy service is showing up as "Started" in service application list?

    Could you try by specifying the full FQDN of your server like http://myserver.domain.com:12290 rather than http://myserver:12290?

    If those doesn't work, could you try issuing the Register-SPWorkflowService command with the "-Force" parameter?


    These postings are provided "AS IS" with no warranties, and confers no rights.

    Monday, October 7, 2013 8:08 AM

All replies

  • Could you check if your workflow proxy service is showing up as "Started" in service application list?

    Could you try by specifying the full FQDN of your server like http://myserver.domain.com:12290 rather than http://myserver:12290?

    If those doesn't work, could you try issuing the Register-SPWorkflowService command with the "-Force" parameter?


    These postings are provided "AS IS" with no warranties, and confers no rights.

    Monday, October 7, 2013 8:08 AM
  • Could you check if your workflow proxy service is showing up as "Started" in service application list?

    Could you try by specifying the full FQDN of your server like http://myserver.domain.com:12290 rather than http://myserver:12290?

    If those doesn't work, could you try issuing the Register-SPWorkflowService command with the "-Force" parameter?


    These postings are provided "AS IS" with no warranties, and confers no rights.

    Workflow proxy service is showing as "Started" in service application. I even restarted it but no luck.

    I used FQDN but same problem.

    I ran the command using "-Force" and now it seems to be working because it is throwing database access error. I think I gave the incorrect DB user at the time of configuring workflow manager who do not have access to database.

    Monday, October 7, 2013 8:26 AM
  • You mixed up the https / http and portnumbers.

    Defaults are:

    https => 12290
    http => 12291

    So your PS commands should be:
    Register-SPWorkflowService -SPSite "http://myserver:1267" -WorkflowHostUri "https://myserver:12290/" -AllowOAuthHttp
    or
    Register-SPWorkflowService -SPSite "http://myserver:1267" -WorkflowHostUri "http://myserver:12291/" -AllowOAuthHttp

    Tuesday, July 8, 2014 7:28 AM
  • Hi Sridhar,

    I have tried Register-SPWorkflowService command(below) with the "-Force" parameter but now i am getting below error. I have installed Workflow manager on same server on which Sharepoint has been installed.

    Command-Register-SPWorkflowService -SPSite "Site_URL" -WorkflowHostUri "https://"FQDN URL af"/" -AllowOAuthHttp -force

    Register-SPWorkflowService : The underlying connection was closed: An

    unexpected error occurred on a send. Client ActivityId :

    8fce287d-0f6b-483e-b985-fedb36ab82b8.
    At line:1 char:1
    + Register-SPWorkflowService -SPSite "http://comv-cp-ggn:1002/"
    -WorkflowHostUri " ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    ~~~
        + CategoryInfo          : InvalidData: (Microsoft.Share...WorkflowService:
       RegisterSPWorkflowService) [Register-SPWorkflowService], WorkflowCommunica
      tionException
        + FullyQualifiedErrorId : Microsoft.SharePoint.WorkflowServices.PowerShell
       .RegisterSPWorkflowService

    Is this needed to install Workflow manager on the separate server?




    Vishal Goyal

    Wednesday, February 18, 2015 9:20 AM
  • I am also facing the same issue,i don't think any different server also needed for the same.

    i am using SP2013 on 1 server and DB on different server,i dnt think so any other different Workflow server needed for the same.

    if i am wrong somewhere kindly let me know.

    looking for the solution.

    Thanx in Advance.

    Regards

    Yatharth

    Thursday, February 19, 2015 10:25 AM