none
SharePoint 2013 List Permissions RRS feed

  • Question

  • Hi, I have a workflow that is set to a document. I click the ellipses for the document in SharePoint and select Workflows. Click the workflow under "start a new workflow". I am then taken to a form were I assign it to users and set the due date. I then start the workflow. The users receive an email with a link. When they click the link the Word document opens. At the top is a button "Open this task". The user clicks on the button and is taken to the SharePoint site where they are presented with another form. Once they click the "submit" button they are taken to the Workflow tasks list.

    Previously users, regardless of their access were able to see other users' items in the list. In the advanced screen of the workflow tasks list the Item-level permissions was set to "Read items that were created by the user". It was changed to "Read all items".

    Now, users can only see only their list items. However, Site Owners can see all. Is there a way to have Site Owners see only their own items?

    I've inherited this site so am unsure if there is anything customized on this site.

    Monday, May 8, 2017 3:26 PM

Answers

  • Sorry, but I disagree.  I just tested a user in a list set to "Create and edit items created by the user" and a user with Contribute permissions can only see what they created.  Users with Full Control can see all the items.  Users with Contribute do not.  By default anyone in the Owners group gets Full Control.  That's why Owners can see everything.

    Paul Stork SharePoint Server MVP
    Principal Architect: Blue Chip Consulting Group
    Blog: http://dontpapanic.com/blog
    Twitter: Follow @pstork
    Please remember to mark your question as "answered" if this solves your problem.

    • Marked as answer by rsford31 Wednesday, May 10, 2017 9:09 PM
    Wednesday, May 10, 2017 11:55 AM

All replies

  • Site Owners by default have Full Control permission.  This is what allows them the right to see all items.  To have them participate in the "only see my own items" you need to reduce their permission in the library to the equivalent of Contribute or Edit.  

    Paul Stork SharePoint Server MVP
    Principal Architect: Blue Chip Consulting Group
    Blog: http://dontpapanic.com/blog
    Twitter: Follow @pstork
    Please remember to mark your question as "answered" if this solves your problem.

    Monday, May 8, 2017 6:56 PM
  • Hi, I set the permissions for Owner from full control to contribute. They were still able to see the items in the list even though they were not theirs. Other users in the Contribute group only see theirs.
    Tuesday, May 9, 2017 9:01 PM
  • Did you change the permissions on the Owners group or just give the user who is the owner contribute permissions?  I suspect you will need to actually remove everyone from the Owners group and give them permissions a different way to get this to work.

    Paul Stork SharePoint Server MVP
    Principal Architect: Blue Chip Consulting Group
    Blog: http://dontpapanic.com/blog
    Twitter: Follow @pstork
    Please remember to mark your question as "answered" if this solves your problem.

    Wednesday, May 10, 2017 1:03 AM
  • Contribute permission level always override the advanced settings "only see my own items". Please use Edit permissions instead of Contribute permission.

    SharePoint School | Blog- http://www.sharepoint-journey.com

    Wednesday, May 10, 2017 6:33 AM
    Moderator
  • Sorry, but I disagree.  I just tested a user in a list set to "Create and edit items created by the user" and a user with Contribute permissions can only see what they created.  Users with Full Control can see all the items.  Users with Contribute do not.  By default anyone in the Owners group gets Full Control.  That's why Owners can see everything.

    Paul Stork SharePoint Server MVP
    Principal Architect: Blue Chip Consulting Group
    Blog: http://dontpapanic.com/blog
    Twitter: Follow @pstork
    Please remember to mark your question as "answered" if this solves your problem.

    • Marked as answer by rsford31 Wednesday, May 10, 2017 9:09 PM
    Wednesday, May 10, 2017 11:55 AM
  • Thanks Paul for correcting me here, I tested the same scenario and you'r statement is correct.

    SharePoint School | Blog- http://www.sharepoint-journey.com

    Wednesday, May 10, 2017 2:56 PM
    Moderator
  • The users were in the Members SP group already through a security group. I remove the Owners group permissions from the list. After that only users could only see their own items in the list. 
    Wednesday, May 10, 2017 9:12 PM