none
Disable automatic screen turn off when closing Lid RRS feed

  • Question

  • I am running Vista Business on a Acer TavelMate C200.  When you fold down the screen to turn the machine into tablet mode it turns off the display.  I have changed the settings to tell Vista to "Do nothing" when closing the lid, but the screen still shuts off.  Please help!!

    Thanks,

    Jeremy Cox

    Tuesday, February 6, 2007 4:39 PM

Answers

  • Have tried a number of things to fix the display disabled when lid closed option, including "lidbehavior" and "LidCloseSetPower" registry settings, none of which worked.

    Have found a "temprorary hack" that at least makes teh C200 usable in tablet mode with vista. That is:

    - Disable the 'ACPI Lid' Device

    installing drivers over this device for volume manager seems to work.

    Nasty but effective.

    http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=1175893&SiteID=1&PageID=1


    still woudl appreciate anyone with "proper" fix.

    Sunday, February 25, 2007 8:26 PM

All replies

  • This is normal on all laptop monitors.  By setting it do "do nothing" you correctally told it to not shutdown or hibernate.  Also you will notice that external monitors should remain unaffected by closing the lid (depending on your multi-monitor settings).

    Why, might i ask, do you want the screen to remain on if the lid is closed?

    Wednesday, February 7, 2007 5:05 PM
  • When the OS detects a "lid close" it is actualy just folded down into tablet mode.  The screen is still visable and usable (if it was not turned off).  The Acer tavelmate C204's screen does not close, it folds down with the screen facing up.  Because of this issue, tablet mode is useless!
    Friday, February 9, 2007 4:29 PM
  • Did you find a solution to this. Am having identical problems.

     

     

    Monday, February 19, 2007 10:33 PM
  • Have tried a number of things to fix the display disabled when lid closed option, including "lidbehavior" and "LidCloseSetPower" registry settings, none of which worked.

    Have found a "temprorary hack" that at least makes teh C200 usable in tablet mode with vista. That is:

    - Disable the 'ACPI Lid' Device

    installing drivers over this device for volume manager seems to work.

    Nasty but effective.

    http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=1175893&SiteID=1&PageID=1


    still woudl appreciate anyone with "proper" fix.

    Sunday, February 25, 2007 8:26 PM
  • Ugly, but it works!!! Thanks!
    Monday, February 26, 2007 7:38 PM
  • I have a Packrad Bell laptop, and by closing (not the lid) I always get the hibernation. I changed it to End, but it stays on Hibernate.

    Does anyone know how to change it really?

     

    Quizzz

     

    Sunday, September 21, 2008 10:59 PM
  • This worked for an entirely different purpose--graphics chips would stop working when the lid was closed regardless of lid closing settings. Now it thinks the primary monitor is still on hence keeps the other monitors running. However, when I go back to find the ACIP.LID (just in case I can fix the actual graphics chips issue) It's gone?? Nothing to reinstall the correct drive to?

    What to do?

    Thanks

    Jeff

    • Proposed as answer by vasya1965 Friday, July 24, 2015 1:03 PM
    • Unproposed as answer by vasya1965 Friday, July 24, 2015 1:03 PM
    Wednesday, August 13, 2014 8:52 PM
  • Jeff, In case you are still looking for an answer to your question, you 'll now find the device under System Devices->Volume Manager.

    1. Control Panel->Device Manager->"System devices" -> "Volume Manager".
    2.  "Volume Manager" properties-> "Driver" tab-> "Update driver".
    3. "Browse my computer for driver software"-> "Let me pick from a list.."
    4. Make sure that "Show compatible hardware" is checked and the device is listed as "ACPI lid"
    5. Click next. 
    6. Restart when prompted.


    • Edited by vasya1965 Friday, July 24, 2015 1:15 PM
    Friday, July 24, 2015 1:15 PM