none
No refinement available in SharePoint 2010 Fast Search RRS feed

  • Question

  • You cannot vote on your own post 
    Hi All,

    I am using FAST Search in SharePoint 2010. In the result core page; I am getting result. But in the refinements section I am getting "No refinements available".

    But I am getting the refinements for Enterprise Search.

    I have the refinement webpart and checked the refinement category definition xml as well.

    any one can help this.

    Thanks in advance.

    Jay


    Jay
    Friday, July 8, 2011 8:41 AM

All replies

  • May be in the FAST scenario, you did not get enough results to warrant refinement. Each refinement category has a threshold of results after which refinements are activated.
    AK
    Friday, July 8, 2011 9:27 AM
  • Hi AK,

    I am getting 1 result and more than 100 results as well. What is the minimum results to get refinement. Can you please let me know which area should be checked.

    Is there any configuration need to check for getting refinement in FAST Search.

    FYI: But for the same output; I am getting refinement for normal SharePoint 2010 search and SharePoint Enterprise Search.

    Thanks

    Jay


    Jay
    Saturday, July 9, 2011 2:02 AM
  • What is the content you are indexing with FAST? If it is SharePoint content you should have refinements like author or result type. If its a file share or some other external content , the content may not have any managed properties to refine with.
    Blog | SharePoint Field Notes Dev Tool | ClassMaster
    Sunday, July 10, 2011 2:20 AM
  • Hi AK,

    It is SharePoint content. As I told you earlier I am getting refinement for normal SharePoint 2010 search for the same content. FAST Search and SharePoint server are intalled in separate system.

     Here i am giving the category definition xml detail.

    <?xml version="1.0" encoding="utf-8"?>
    <FilterCategories>
     <Category Title="Result Type" Description="The file extension of the item" Type="Microsoft.Office.Server.Search.WebControls.ManagedPropertyFilterGenerator" MetadataThreshold="1" NumberOfFiltersToDisplay="4" MaxNumberOfFilters="20" ShowMoreLink="True" MappedProperty="format" MoreLinkText="show more" LessLinkText="show fewer" ShowCounts="Count" />
     <Category Title="Site" Description="Which site this document is from" Type="Microsoft.Office.Server.Search.WebControls.ManagedPropertyFilterGenerator" MetadataThreshold="1" NumberOfFiltersToDisplay="4" MaxNumberOfFilters="20" ShowMoreLink="True" MappedProperty="sitename" MoreLinkText="show more" LessLinkText="show fewer" ShowCounts="Count" />
     <Category Title="Author" Description="Use this filter to restrict results authored by a specific author" Type="Microsoft.Office.Server.Search.WebControls.ManagedPropertyFilterGenerator" MetadataThreshold="1" NumberOfFiltersToDisplay="4" MaxNumberOfFilters="20" ShowMoreLink="True" MappedProperty="author" MoreLinkText="show more" LessLinkText="show fewer" ShowCounts="Count" />
     <Category Title="Modified Date" Description="When the item was last updated" Type="Microsoft.Office.Server.Search.WebControls.ManagedPropertyFilterGenerator" MetadataThreshold="1" NumberOfFiltersToDisplay="6" SortBy="Custom" ShowMoreLink="False" MappedProperty="write" ShowCounts="Count" >
     <CustomFilters MappingType="RangeMapping" DataType="Date" ValueReference="Relative" ShowAllInMore="False">
      <CustomFilter CustomValue="Past 24 Hours">
      <OriginalValue>-1..</OriginalValue>
      </CustomFilter>
      <CustomFilter CustomValue="Past Week">
      <OriginalValue>-7..</OriginalValue>
      </CustomFilter>
      <CustomFilter CustomValue="Past Month">
      <OriginalValue>-30..</OriginalValue>
      </CustomFilter>
      <CustomFilter CustomValue="Past Six Months">
      <OriginalValue>-183..</OriginalValue>
      </CustomFilter>
      <CustomFilter CustomValue="Past Year">
      <OriginalValue>-365..</OriginalValue>
      </CustomFilter>
      <CustomFilter CustomValue="Earlier">
      <OriginalValue>..-365</OriginalValue>
      </CustomFilter>
     </CustomFilters>
     </Category>
     <Category Title="Company" Description="Use this filter to restrict results by company" Type="Microsoft.Office.Server.Search.WebControls.ManagedPropertyFilterGenerator" MetadataThreshold="1" NumberOfFiltersToDisplay="4" MaxNumberOfFilters="20" ShowMoreLink="True" MappedProperty="companies" MoreLinkText="show more" LessLinkText="show fewer" ShowCounts="Count" />
     <Category Title="Managed Metadata Columns" Description="Managed metadata of the documents" Type="Microsoft.Office.Server.Search.WebControls.TaxonomyFilterGenerator" MetadataThreshold="3" NumberOfFiltersToDisplay="3" MaxNumberOfFilters="20" ShowMoreLink="True" MappedProperty="owsmetadatafacetinfo" MoreLinkText="show more" LessLinkText="show fewer" />
     <Category Title="Tags" Description="All managed metadata of the documents and social tags" Type="Microsoft.Office.Server.Search.WebControls.TaxonomyFilterGenerator" MetadataThreshold="3" NumberOfFiltersToDisplay="3" MaxNumberOfFilters="20" ShowMoreLink="True" MappedProperty="owsmetadatafacetinfo" MoreLinkText="show more" LessLinkText="show fewer" ShowCounts="Count" />
    </FilterCategories>
    I have one farm and one web application. having couple of subsites. If I browse using some keyword e.g test. I am getting more than 100 records from differect list / documents library.
    Regards,
    Jay

    Jay
    Sunday, July 10, 2011 3:46 AM
  • The relevant documentation is at http://msdn.microsoft.com/en-us/library/gg685426.aspx and I assume you cleared the "use default configuration" from the refinement section of the web part tool. The relevant count here is not the total results, but number of results per filter type.
    AK
    Sunday, July 10, 2011 5:34 AM
  • HI AK,

    I have tried the steps mentioned in the above link and I cleared the "use default configuration"but i am not getting refinements. Also the above link is for adding new finements. but my case i am not getting default refinements.

    thanks 


    Jay
    Monday, July 11, 2011 2:54 AM
  • This thread: http://social.technet.microsoft.com/Forums/en-US/sharepoint2010setup/thread/8a81ba8f-c8e3-434e-8946-f5bcc91ce680
    is for people search but may be helpful in terms of query service used or the visualization setting.
    AK
    Monday, July 11, 2011 6:46 AM
  • OK let me check this thread and try it out tomm, because I am not in server location now . If you find any solution / suggestion about my query please let me know.
    Jay
    Monday, July 11, 2011 8:50 AM
  • Hi AK,

    I have chekced the thread http://social.technet.microsoft.com/Forums/en-US/sharepoint2010setup/thread/8a81ba8f-c8e3-434e-8946-f5bcc91ce680. But still i can not get refinements.

    Is there any settings we need to do for displaying refinements in FAST Search search? Because by default refinements is working for normal SharePoint search.

    kinldy help to solve this issue. I m strucking more than 1 month to solve this issue.

    thanks


    Jay
    Tuesday, July 12, 2011 3:10 AM
  • I don't have a FAST environment to test, but seems you are missing some simple step. try http://msdn.microsoft.com/en-us/library/ff464344.aspx to make sure you configured it correctly.
    AK
    Tuesday, July 12, 2011 6:39 AM
  • ok let me check it. If you find anything please let me know.

    thanks for your support

    thanks


    Jay
    Tuesday, July 12, 2011 8:23 AM
  • Hi Ak,

     

    I tried the link provided by you but still i cant get refinements. IS there any settings we have to do it FAST Search Server and SharePoint Server?

    thanks


    Jay
    Thursday, July 21, 2011 2:26 AM
  • Hi Jay,

     

    I am stuck with exact issue. Did you find an answer for this.

     

    Thanks in advance

     

    Guru


    KG
    Friday, September 16, 2011 12:48 PM
  • Hi Guru,

    Still I havent get any solution for this and I stoped to get the solution for this. I will start work from end of next week for this issue. If I found any solution will let you know.

    Meanwhile if you find the solution for this issue please share with me.

    thanks,

    Jay


    Jay
    Friday, October 7, 2011 2:57 AM
  • Make sure the managed properties you are using in your refinement web part are enabled to be refiners. Please look at number 12 in the link below.

    http://office.microsoft.com/en-us/fast-search-server-help/property-management-HA010382016.aspx

    After you set the refiner option make sure to do another full crawl.


    Blog | SharePoint Field Notes Dev Tool | ClassMaster
    Friday, October 7, 2011 3:16 AM
  • Hi Steve,

    Thanks for your suggesstion. I had enabled the refiners. but still it is not coming.

     


    Jay
    Monday, October 10, 2011 8:18 AM