locked
Error code is 2150858882 RRS feed

  • Question

  • hi,

    Windows Server 2008 R2 SP1, configure the event forward, the event collector is domain member server, the source computer is non-domain computer (workgroup).

    It configure using HTTPS in event forward configuration in both server, the the source computer getting error below.

    The forwarder is having a problem communicating with subscription manager at address HTTPS://cas-ops-1.xxx.xxx.com:5986/wsman/SubscriptionManager/WEC.  Error code is 2150858882 and Error Message is .

    I search the error code 2150858882 in microsoft web site, but have no solution.

    Thanks...KEN

    Wednesday, November 27, 2013 9:06 AM

Answers

All replies

  • Ken,

    To better understand your query, please post event ID details or error snap-shot.


    Regards, Ravikumar P

    Wednesday, November 27, 2013 1:36 PM
  • hi,

    this one on the event source computer.

    Thanks...KEN

    Wednesday, November 27, 2013 2:13 PM
  • Ken,

    Please check this hotfix http://support.microsoft.com/kb/2884172/en-us and apply it on your server to fix event ID 105.


    Regards, Ravikumar P

    Wednesday, November 27, 2013 2:32 PM
  • hi Ravikumar,
    I applied the KB both source and event collector server, but still get the same error.
    How can further troubleshoot to find out what wrong in my environment?

    Thanks...KEN
    Thursday, November 28, 2013 3:37 AM
  • hi,

    Really no solution for that? do you know what is the error code 215085882 talking about, no further error description in event log, google the error code is no help.

    Thanks...KEN

    Friday, November 29, 2013 4:41 AM
  • Hi,

    Apart from that, here I can suggest to try to add the system with domain and let’s see; whether you occur same issue.

    Thanks.

    Monday, December 2, 2013 8:36 AM
  • Hi,

    Do you need any other assistance? If there is anything we can do for you, please let us know.

    Thanks.
    Friday, December 6, 2013 1:43 AM
  • hi,

    struggle this with long time, but still can't fix, tried may method, but still not work on non-trusted domain server.

    Have you configured like this?

    Thanks...KEN

    Wednesday, December 11, 2013 1:35 PM
  • Did you ever find an answer to this. I can't find a single example where they have gotten client certificate working for event forwarding. But plenty like this where they haven't.

    Randall F Smith

    Sunday, December 29, 2013 12:05 AM
  • hi,

    No, still no solution for that error, and that error can't be found error description, don't know what happen.

    Thanks...KEN

    Monday, January 6, 2014 2:19 AM
  • Hi  everybody,

    I'm encountering an identical issue in these days. Have you finally figured out how to solve the issue or at least have more info about the meaning of the error message?

    Thanks,

    Jeremy

    Friday, June 5, 2015 3:52 PM
  • Hello everybody.

    I had the same problem and today I solved it by removing Refresh=60,IssuerCA=<Thumb print of the client authentication certificate> from event forwarding policy.

    Tested on Windows Server 2012 R2.

    Thursday, November 12, 2015 8:49 AM
  • Hi all.
    I have faced the same issue.
    the line in documentation:
    IssuerCA=<Thumb print of the client authentication certificate>
    Must be
    IssuerCA=<Thumb print of the Certification Authority certificate>

    So, when you set as IssuerCA a Thumbprint for the client certificate the error occurs.
    But if you set as IssuerCA a Thumprint of Certification Authority for the client certificate - it will works.

    Also, if you remove "IssuerCA=<Thumb print of the client authentication certificate>" it will works with Kerberos, not with HTTPS.
    Monday, March 7, 2016 8:47 AM
  • Hi guys!

    I had similar error while testing subscriptions, many hours was spent for troubleshooting and finally I solve it.

    In my case issue was in wrong copy/paste thumbprint of IssuerCA certificate.

    To understand what I mean try to do this:

    • View IssuerCA certificate and find "Thumbprint" field in Details tab
    • Select value (smth like "9b d3 73 1b ed 18 03 63 f4 76 33 c4 3b 80 f2 02 38 12 3d 74")
    • Copy value by CTRL+C
    • Paste value to notepad, for example. Everything seems right, really?
    • Now open Powershell and paste this value to it.

    You can see that value was copy with one extra symbol in the start of the line:

    Just delete this symbol and copy/paste to notepad new value.

    After I changed in my GPO IssuerCA string to this new value, everything start working perfectly.

    Hope this helps somebody.

    Wednesday, December 7, 2016 8:37 PM
  • Article from MS, that explains this issue - https://support.microsoft.com/en-us/kb/2023835
    Wednesday, December 7, 2016 8:44 PM
  • Hi,

    just wanted to add another possible source for this error:

    My client computer was using a client authentication certificate that was issued by an intermediate CA. Although the certification path was correctly displayed when viewing the certificate (containing both the intermediate as well as the root CA), the intermediate CA cert was missing from the correct certstore ("Intermediate Certification Authorities"). After adding the intermediate CA cert the error was gone.

    There also were errors showing up in the CAPI2 Operational Log (Applications and Service Logs > Microsoft > Windows > CAPI2). Although those were stating that the system wasn't able to check the revocation status and not something about the certificate trust chain, I still think they're related because those errors also disapperead after correcting the intermediate CA cert.

    Wednesday, December 28, 2016 11:03 AM