none
Outlook 2010 slow when configured using PRF RRS feed

  • Question

  • Hi

    I am trying to automate Outlook configuration by using Outlook generated PRF and via cmd line, getting Outlook to recognize and configure Outlook 2010 for use.
    I imported the PRF file by using this cmd line: outlook.exe /importprf "user.prf"
    My OS platform is Windows 7 Enterprise, and I configure it for Outlook Anywhere.

    It is able to work, but I find that by configuring Outlook in this way make Outlook very slow. It takes 3-5 secs to open up an email (approx 30KB), regardless PST or OST. Outlook will enter a stage where it reflects itself as "Not Responding" before the email opens up to show the contents.

    However, if I run the configuration by the series of steps, I do not have this slowness problems. Outlook does not experience the 3-5 secs void before it opens. Neither does it enter a stage of "Not Responding".
    - Choose Microsoft Exchange
    - Configure for Outlook Anywhere
    - Enter Exchange server name & user

    I have also noticed that when configured using PRF file, Outlook displays its status as "Online with Microsoft Exchange" as compared to "Connected to Microsoft Exchange" when manually configured.

    I have also checked in the Account Options of the former configuration, both configurations are identical.
    Anyone can help in this? or is there any problems with the PRF file (appended below).

     

    ; **************************************************************
    ; Section 1 - Profile Defaults
    ; **************************************************************
    
    [General]
    Custom=1
    ProfileName=Outlook User
    DefaultProfile=Yes
    OverwriteProfile=Yes
    ModifyDefaultProfileIfPresent=false
    DefaultStore=Service2
    BackupProfile=No
    
    ; **************************************************************
    ; Section 2 - Services in Profile
    ; **************************************************************
    
    [Service List]
    ;ServiceX=Microsoft Outlook Client
    ServiceEGS1=Exchange Global Section
    Service1=Microsoft Exchange Server
    ServiceEGS=Exchange Global Section
    Service2=Unicode Personal Folders
    
    ;***************************************************************
    ; Section 3 - List of internet accounts
    ;***************************************************************
    
    [Internet Account List]
    
    ;***************************************************************
    ; Section 4 - Default values for each service.
    ;***************************************************************
    
    ;[ServiceX]
    ;FormDirectoryPage=
    ;-- The URL of Exchange Web Services Form Directory page used to create Web forms.
    ;WebServicesLocation=
    ;-- The URL of Exchange Web Services page used to display unknown forms.
    ;ComposeWithWebServices=
    ;-- Set to true to use Exchange Web Services to compose forms.
    ;PromptWhenUsingWebServices=
    ;-- Set to true to use Exchange Web Services to display unknown forms.
    ;OpenWithWebServices=
    ;-- Set to true to prompt user before opening unknown forms when using Exchange Web Services.
    
    
    [ServiceEGS1]
    MailboxName=
    HomeServer=mailExchange.domain.com
    AccountName=Outlook User
    ConfigFlags=0x00000000
    RPCoverHTTPflags=0x0023
    RPCProxyServer=mailExchangeName.domain.com
    RPCProxyPrincipalName=
    RPCProxyAuthScheme=0x0002
    
    [Service1]
    OverwriteExistingService=No
    UniqueService=Yes
    MailboxName=
    HomeServer= mailExchange.domain.com 
    PathAndFilenameToPersonalFolders=C:\outlookmail.pst
    
    [Service2]
    UniqueService=No
    Name=mailbox
    PathAndFilenameToPersonalFolders= C:\outlookmail.pst
    EncryptionType=0x50000000
    

    Thank you

     


    • Edited by yukijocelyn Friday, July 1, 2011 1:50 AM Add additional information
    Friday, July 1, 2011 1:44 AM

Answers

  • I have also noticed that when configured using PRF file, Outlook displays its status as "Online with Microsoft Exchange" as compared to "Connected to Microsoft Exchange" when manually configured.
    Your prf-file configured Exchange in on-line mode and not with Cached Exchange Mode enabled. This adds an additional boot-lag since Outlook cannot open without first retrieving your email list and the first message from the server instead of retrieving this locally.
    Aside from this issue, you really shouldn't create additional pst-files directly in the C-root either. Assing the user a local folder to store these in and set appropriate permissions. If it contains company data, you should include it in your backups as well or drop the use of pst-files entirely and use Online archives (Exchange 2010), archive mailboxes/public folders (any version of Exchange), or 3rd party Exchange level archiving software.


    Robert Sparnaaij [MVP-Outlook]
    Outlook guides and more: HowTo-Outlook.com
    Outlook Quick Tips: MSOutlook.info
    Tuesday, July 5, 2011 2:42 PM

All replies

  • Hi

     

    Thank you for using Microsoft Office for IT Professionals Forums.

     

    From your description, have you install Microsoft Office 2010 Service Pack 1 (SP1).

    If not, you can refer to this link to download & install

    http://support.microsoft.com/kb/2460049

     

    More additional method, we can try to create a new profile to test this issue.

     

    Please take your time to try the suggestions and let me know the results at your earliest convenience. If anything is unclear or if there is anything I can do for you, please feel free to let me know.

     

    Hope that helps.

     

    Sincerely

    William Zhou CHN

    --------------------------------------------------------------------------------

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Tuesday, July 5, 2011 9:00 AM
    Moderator
  • I have also noticed that when configured using PRF file, Outlook displays its status as "Online with Microsoft Exchange" as compared to "Connected to Microsoft Exchange" when manually configured.
    Your prf-file configured Exchange in on-line mode and not with Cached Exchange Mode enabled. This adds an additional boot-lag since Outlook cannot open without first retrieving your email list and the first message from the server instead of retrieving this locally.
    Aside from this issue, you really shouldn't create additional pst-files directly in the C-root either. Assing the user a local folder to store these in and set appropriate permissions. If it contains company data, you should include it in your backups as well or drop the use of pst-files entirely and use Online archives (Exchange 2010), archive mailboxes/public folders (any version of Exchange), or 3rd party Exchange level archiving software.


    Robert Sparnaaij [MVP-Outlook]
    Outlook guides and more: HowTo-Outlook.com
    Outlook Quick Tips: MSOutlook.info
    Tuesday, July 5, 2011 2:42 PM
    1. If youre using Outlok Anywhere with Exch (I assume youre using 2010) you shouldn't have to use prf files. Outlook 2007 & 2010 will should use Autodiscover to configure the mail profile for you. PRF files are really legacy for clients like Outlook 2003.
    2. Ask your Exch admin to setup Autodiscover correctly if not already done on the Public DNS servers so that your profile is automatically configured for you, by you providing you email address and apassword only.
    3. PST file again are quite historical, they are prone to corruption and you could lose your data.  Put your mail/items/contacts etc... in Exch/mailbox.

    Sukh
    Tuesday, July 5, 2011 9:34 PM