none
WinHlp32.exe and Windows 7 x64 gives cannot display this help file.

    Question

  • Have a Classic VB6 app that uses .hlp files. Knew that to open these on Windows 7 x64 need the Winhlp32.exe. So downloaded the x64 version of Winhlp32.exe from the Microsoft Support website http://support.microsoft.com/kb/917607

    Now can open .hlp files that are stored on the local PC disk (C: drive). Still cannot open any .hlp files that are on a shared folder (intranet). Get the message "Cannot display this help file. Try opening the help file again, and if you still get this message, copy the help file to a different drive, and try again."

    As per the same article it has two fixes to overcome this issue (1. Check Policy settings and 2. Add regkeys AllowIntranetAccess and AllowProgrammaticAccess to the HKEY_LOCAL_MACHINE\Software\Wow6432Node\Microsoft\). So I have added both these keys but still does not work.

    Have tried this both on a Windows 7 64-bit and Windows 2008 which is 64-bit.

    Anybody can help me with this?

    Wednesday, March 24, 2010 3:45 PM

All replies

  • Did you get any joy with this query. I have the same problem running Windows 7 Home Premium 64bit. I can't edit group Policies but have inserted a registry key as given in kb917607 with no luck. It's very frustrating!
    Friday, July 02, 2010 12:48 PM
  • Same problem here.  I've moved the file and inserted the registry keys.  Anyone have any ideas?
    Monday, July 05, 2010 7:39 PM
  • Have the same problem with 32 bit version of Windows 7. Installed WinHlp32.exe & added Registry keys. Still getting error.
    Tuesday, August 03, 2010 10:15 PM
  • This is the solution that fixed me up.

    It is possible to receive help error messages if the Local Intranet Zone Settings are too restrictive.
    To change the Local Intranet Zone Settings
    1. Open Internet Options (Start | Control Panel | Internet Options). If you do not see it then type Internet Options in the
    search box at the top left.
    2. Select the Security tab.
    3. Select Local Intranet. Click the Sites button.
    4. Clear the Automatically detect intranet network check box.
    5. Select (Check) all three checkboxes
    Include all local (intranet) sites not listed in other zones, Include all sites that bypass the proxy server and Include all
    network paths (UNCs) check boxes.
    6. Click OK

     

    • Proposed as answer by Anup Mistry Monday, August 16, 2010 2:50 PM
    Friday, August 13, 2010 7:16 PM
  • Did as suggested above and still no success.  Any other suggestions?
    Wednesday, November 02, 2011 3:49 AM
  • If the above didn't work, the do the following. If you are running 64-bit then also do this in HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\HTMLHelp\1.x

    1. Click Start, click Run, type regedit, and then click OK.
    2. Locate and then click the following subkey:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\HTMLHelp\1.x\ItssRestrictions
    If this registry subkey does not exist, create it.
    3. Right-click the ItssRestrictions subkey, point to New, and then click DWORD Value.
    4. Type MaxAllowedZone, and then press Enter.
    5. Right-click the MaxAllowedZone value, and then click Modify.
    6. In the Value data box, type 1, and then click OK.
    7. Quit Registry Editor.

    Tuesday, February 25, 2014 6:51 PM
  • De-select "always ask when opening this file" and you will be able to open the file.
    • Proposed as answer by surrealist14 Wednesday, September 23, 2015 5:10 PM
    Thursday, July 23, 2015 5:28 AM
  • Wow, that was exactly what I needed!  Not sure how you stumbled across it, but it worked.  Thanks @AlastairMcDowell!
    Wednesday, September 23, 2015 5:10 PM
  • Hi, this description help me to resolve my problem, according to be able to view hlp files in my Windows 7 32 bit sytem. Thank You very much!
    Thursday, April 07, 2016 8:44 AM