none
Windows Media Player prompts for "Enter Network Password" When Opening From SharePoint 2010 RRS feed

  • Question

  • I am having a problem when trying to play a video file from an asset library in SharePoint 2010.  Here's what's happening:

    In the asset library, when I click on the title of the file to play, it prompts me to "Enter Network Password".  If I hover over that same file and wait for the pop up to display and then click Play from there, the file plays via silverlight just fine.  If I put in my credentials, the video will play.  If I chose to cancel, the video does not play.

    Our systems are all Windows 7, WMP version 12.  We do have an SSL certificate on our SharePoint site (https://site.company.org).  If using FireFox, I am not prompted to authenticate.

    My SharePoint site is a trusted Intranet site in IE, the security settings for the Local Intranet Zone for User Auth is set to Automatically Logon only to Intranet Zone, I have the AuthForwardServerList key in placc.  No other prompts for authentication for anything else in SharePoint, just for videos that need WMP to open.  Also, this is an internal site only.  No external access.  User authentication is via AD.  When a user logs into their system, there is no need to reauthenticate when launching SharePoint.  Only when opening videos.

    Has anyone discovered how to allow videos to play in WMP without authenticating?  Thanks for any help.


    WG


    • Edited by MyGSD Wednesday, February 15, 2012 6:52 PM
    Wednesday, February 15, 2012 4:59 PM

Answers

All replies

  • Hey WG!

    I am sure when you read your own post you get the idea where the problem is..

    "My SharePoint site is a trusted Intranet site in IE, the security settings for the Local Intranet Zone for User Auth is set toAutomatically Logon only to Intranet Zone(...)"

    If you care to change IE settings for Trusted sites to Automatic Logon with current user name and password you will notice that the prompt is gone.

    I hope this helps.

    Amanda

    Wednesday, February 15, 2012 6:54 PM
  • Hi Amanda, thanks for the reply.  I actually have tried that (and did it again just to be sure) but it has no effect on my issue.  I'm still getting prompted for credentials.  The screenshot shows what I am getting when clicking on the name of the video to play.

    Thanks again.


    WG

    Wednesday, February 15, 2012 8:03 PM
  • OK. Well,

    I tried to replicate this, so I did remove my site from "Intranet" and put that site in Trusted Sites with default security settings, my logon settings are set to Log on with current user and password to intranet only and it works - I mean, I get the same prompt you do. BUT when I changed the logon settings to Automatic Logon with current user name and password (Go to Trusted Sites in IE security and hit custom button and change only that one setting) the prompt was gone. I have checked this on two client machines, both for http and https, we have pretty much OOtB IE9 deployed with full user configuration allowed. I am sorry, it didn't work for you. I find it that clearing caache of IE and resetting IE after the change works magic many times. Perhaps you would care to check that. You may also want to check the behaviour when you add staff.xyz.org site to your Intranet zone see if that changes. Its hard for me to say as it works fine and I had to reconfigure to get this "problem". Give it a try please.

    Make sure you set Automatic Logon with current user name and password for the right zone (i.e. Trusted Sites)


    • Edited by AmaHeart Thursday, February 16, 2012 5:00 AM
    Thursday, February 16, 2012 4:57 AM
  • Hi guys,

    The good news is that Amanda is 100% right, the bad news, though is so is WG. Adding a site and changing security works fine, but only if the user logged on the computer is the same as the user who accesses this site. So, your site, WG is in a XYZ.org domain, only XYZ authenticated user will go through staff site and WMP back and forth with pass through authentication. Simply if you are in the domain you will go through just fine or will have to use Amanda's tip, but if your client machine is outside of domain (which seems to be the case), you need to remember your site credentials in Windows 7 Credential Manager applet.

    So logo on to the staff.xyz.org site (prompts you for credentials here, does it?) remember those (select check box) and go to this asset library of yours. Click movie title to open in WMP and if prompted again, select the check box to remember credentials and you are fine - obviously do not if your security policy denies this, but this is how it works. You could make the library anonymously available but I would not recommend that anyway.


    LW

    Thursday, February 16, 2012 6:40 AM
  • Thank you so much for responding guys!  I would like to clarify some things since I even confused myself with my original post.  This site is not listed in Trusted Sites but rather Local Intranet as this is an internal site only.  In my
    domain, IE is being managed by GPO.  Part of what we are managing is the Local Intranet zone on the Security tab.  I have inserted our SharePoint site, https://staff.xyz.org into the Sites tab.  Now, in that same zone, if I click on Custom Level and scroll all the way down to User Authentication I have “Automatic Logon with Current User Name and Password” checked. 

    After logging into a computer on our domain with valid domain credentials, launching SharePoint does not require authentication.  It is a seamless pass through.  Only when attempting to open a video that requires WMP to play do our users get “Enter Network Password” prompts.  Gierasimov, all SharePoint activity is done within the domain on domain computers being logged in as valid AD accounts.  There is no SharePoint access for anybody outside our domain, completely internal.  Ama, I have reset IE, cleared cache, etc with no luck.  I have even taken a newly
    reimaged computer and not managed IE on that device to see if it was a GPO setting.  The same thing is happening.  I keep feeling that it has something to do with the https://. 

    Thanks for your help with this!


    WG

    Thursday, February 16, 2012 1:50 PM
  • Right, I got you now.

    Try - Using WMP; Tools, Options, Network, Protocols, HTTP, set to “None” - see if that helps, that's derived from this article, just my thought on the matter.

    Anyway, I am visiting customer site this evening and they have similar setting so I will double check if this behaviour can be replicated.

    Update soon.. in the meantime try this WMP setting...


    LW

    Thursday, February 16, 2012 2:05 PM
  • I changed the WMP setting as noted in your post, but that didn't help any.

    WG

    Thursday, February 16, 2012 2:51 PM
  • Hi

    I have tried to replicate this issue on two seperate farms and domains:

    All using https, Active Directory, one winXP with IE 7, other with Win 7 IE9, both have https://sharepointFQDN addresses in Local Intranet with security set to Automatic with current user name and password. Both environments behave the same, when I wait, click play it plays in silverlight, when I click the title WMP opens and plays the file. For testing I used default freshly created Asset Library and sample file from Windows (Wildlife) found on Win7 machine.

    Must be your IE config imposed by GPO, talk it through with your admins. One more thing, you don't go through ISA/TMG to this site, do you? 

    • Proposed as answer by Gierasimov Friday, June 22, 2012 8:28 AM
    Thursday, February 16, 2012 9:46 PM
  • Just to update you on the situation, I have conducted some tests to match your setup and try to replicate the issue, my client was actually very happy to assist. So here it is - GPO governed zones and zone security settings, team site, new asset library, https. Works as advertised.  I am sorry WG, looks like you have some nasty mf setting that is causing this.

    OR have a look at this article, perhaps this applies to you. I dont know about Amanda but I was testing on WinXP (which this setting does not apply and on Win7SP1 on which it is fixed. Article: http://www.quantumofgeek.com/2010/02/windows-7-prompting-for-authentication-when-accessing-sharepoint-documents/

    Here are another ideas:

    Just to have a full picture, is this happening for any library or any site?

    I doubt this is anything to do with SP but worth looking just to eliminate it, setup oob team site upload same vid file to shared documents library, create asset library, upload. Test both of course. Try another video as well. One more thing would it be possible that this video is trying to fetch some data from the Intenet web site other than your SP like codec, DRM or anything? when you fill in the prompt (provide user credentials) does the video play then?

    Have you tried with sample video file from Win7 Sample (Wildlife.wmv)?

    Sorry for all those extra questions, just trying to help here...


    LW


    • Edited by Gierasimov Friday, February 17, 2012 6:39 AM
    Friday, February 17, 2012 6:03 AM
  • Wow, thanks for all the feedback guys.  Ok so here's what I've done to rule out issues with GPOs:

    1. I have a newly reimaged computer that I had prepopulated in an OU that is not tied to any GPO's. 

    2. User account is in that same Test OU with no GPOs linked to it.

    3.  Joined domain, logged in as a test user (no policies linked to it), launched SP (had to authenticate as myself since test user has no rights to SP), navigated to newly created Doc Lib (all users have read rights) where I uploaded the Wildlife.wmv

    4. clicked on title of file - - - - same result.  Getting prompted for auth.

    I am going to check the behavior on an XP machine next, just have to reimage one.  Also, the article you pointed me to has already been addressed with the AuthForwardServerList, but thanks for the thought.  Also, I am the admin for our AD so any issues with GPOs can be addressed directly by me. 

    I'll keep you posted....


    WG

    Friday, February 17, 2012 2:28 PM
  • ALL,

    Just had a customer call me with same issue.  Media file used to play just fine from within SP (at least about a month ago), now getting prompted for Network Password.

    WG,

    Have you found a resolution?

    Thanks

    Schwick

    Tuesday, March 27, 2012 1:42 PM
  • Hi Schwick,

    I'm glad to hear I'm not the only guy who is seeing this.  Unfortunately, I have yet to find a real solution to this problem.  It is not a domain policy as I had started to suspect.  I had a reimaged computer, in an OU with no policies applied, that I joined to the domain.  Even with this fresh computer, that *$%^@ prompt was there.  At this point, I've all but given up.  Short of calling MS, I don't know what other steps to take.  Everyone on this forum has been very helpful to me, but we're just unable to pinpoint the cause of this behavior.

    If I do happen to come across anything, I'll surely post here for everyone to view.

    Good luck and please post back if you make any progress with this issue.


    WG

    Tuesday, March 27, 2012 2:28 PM
  • WG,

    Thanks for the prompt reply! If successful, I will definitely post again.

    Good Luck to you as well,

    Schwick

    Tuesday, March 27, 2012 4:23 PM
  • Here, same configuration of WDG and same results. The embedded Silverlight player works, but if I click on the video file, WM Player opens and asks for username and password, for every single video.
    • Edited by MaxNJI Tuesday, May 8, 2012 3:09 PM
    Tuesday, May 8, 2012 2:53 PM
  • We ran into the exact same situation and we found out it has everything to do with the operation system.  Our standard imagine machine are all XP with IE7 and WMP 11.  All of them have no login prompt once we added the FQDN into the trusted sites and set "Automatic Logon with current user name and password" as AmaHeart above has suggested.  We also tested it out with a Windows 2003 server with IE8 and WMP10.  

    However, all Vista/Win7 base computer will not work by using that same setting, or adding it into the local intranet zone.  The only work around for it is either install a different media player or with some luck, install the hotfix from Microsoft.

    http://support.microsoft.com/kb/943280/en-us


    • Proposed as answer by Gierasimov Friday, June 22, 2012 8:28 AM
    Tuesday, May 22, 2012 12:09 AM
  • Same problem being experienced here. The hot fix listed above in aauxta's post unfortunatley does not apply to Windows 7, which is what we're in the middle of rolling out at our location.

    Don't suppose anyone has found a solution yet, with it being late July now and all?

    Friday, July 20, 2012 3:03 PM
  • We have the same issue with windows 7, Windows Media and SharePoint 2010. Can Anyone help us please?

    Lot of thanks...

    Tuesday, September 4, 2012 3:50 PM
  • I posted the fix in a separate thread, since it appears to be a bug in WMP.

    http://social.technet.microsoft.com/Forums/en-US/w7itpromedia/thread/2094432c-6370-4928-98cd-d9a20b293be7

    The fix is to add the URL to the Local Intranet zone without HTTPS.  For some reason, WMP will still obey it when utilizing HTTPS and not prompt you for additional authentication.

    In MyGSDs case, you would have both http://site.company.org and https://site.company.org added to the Local Intranet Zone list.

    EDIT:  You can also just add "site.company.org" without any HTTP or HTTPS prefixes.


    Sunday, February 10, 2013 1:48 PM