none
WARNING: The object has been corrupted or isn't compatible with Microsoft support requirements, and it's in an inconsistent state. RRS feed

  • Question

  • has anyone seen this before: 

    WARNING: The object "location to object" has been corrupted or isn't compatible with Microsoft support requirements, and it's in an inconsistent state.
    The following validation errors happened:
    WARNING: The property value "Object name" is invalid. The value can contain only 'a', 'b', 'c', 'd', 'e', 'f', 'g', 'h', 'i', 'j', 'k', 'l', 'm', 'n', 'o', 'p', 'q', 'r',
    's', 't', 'u', 'v', 'w', 'x', 'y', 'z', 'A', 'B', 'C', 'D', 'E', 'F', 'G', 'H', 'I', 'J', 'K', 'L', 'M', 'N', 'O', 'P', 'Q', 'R', 'S', 'T', 'U', 'V', 'W', 'X', 'Y', 'Z', '0',
     '1', '2', '3', '4', '5', '6', '7', '8', '9', '"', ''', '(', ')', '+', ',', '-', '.', '/', ':', '?', ' '.

    it shows under EAC in Exchange as well as the Exchange shell 

    Thank you 


    Martin Strasser Carpe Diem


    Thursday, September 6, 2018 3:58 PM

All replies

  • I have not seen this specific error, however please provide more context i.e.

    1. What action are you taken when this error is thrown?

    2. What changed recently, i.e. updates, new server additions, mailbox moves, hardware changes, AD related issues

    3. Filter the Application & System Event logs to ONLY shown critical and errors events as they will more then likely lead you towards the issue at hand


    Search, Recover, Export Mailboxes, Contacts, Calendars, Tasks from ALL versions of Exchange Offline EDB's, On-Premises Exchange Databases & Office 365. Export, Migrate/Recover into On-Premises Exchange Server, Office 365 with Lucid8's DigiScope

    Thursday, September 6, 2018 5:04 PM
  • we are in the midst of an migration from notes to exchange and new objects are created and or migrated  

    those errors show if I run a get-group on the shell for the object  or if I want to make a change to one of those objects via EAC or the shell 

     I am with you , I have never seen this error before , also I cant seem to find it in the error log, but I will keep digging.

    Just thought someone has seen this before besides me


    Martin Strasser Carpe Diem

    Thursday, September 6, 2018 5:16 PM
    1. How are you doing the migration, i.e. 3rd party solution, scripting??
    2. is that the entire command your running i.e. get-group
    3. Has get-group  ever worked for you and if so when?   More importantly what steps did you take since that time?

    Search, Recover, Export Mailboxes, Contacts, Calendars, Tasks from ALL versions of Exchange Offline EDB's, On-Premises Exchange Databases & Office 365. Export, Migrate/Recover into On-Premises Exchange Server, Office 365 with Lucid8's DigiScope

    Thursday, September 6, 2018 5:21 PM
  • it is not only on get-group that was just an example when i look at the "  Get-group "ObjectName" | fl  "   i get the properties and the error message below , when I go to EAC to make a change on that object and hit save I cant as I get that error message as well. We are using binarytree for migration.

    it does  not happen on all objects , just some 


    Martin Strasser Carpe Diem

    Thursday, September 6, 2018 7:28 PM
    1. if you have specific objects its occurring on I would examine those object first
    2. I would also contact binary tree to see if they have run across this before.  Based upon the error I suspect they may have used an illegal character when migrating certain objects from Notes to Exchange

    Search, Recover, Export Mailboxes, Contacts, Calendars, Tasks from ALL versions of Exchange Offline EDB's, On-Premises Exchange Databases & Office 365. Export, Migrate/Recover into On-Premises Exchange Server, Office 365 with Lucid8's DigiScope

    Thursday, September 6, 2018 7:32 PM
  • Thank you 

    I did compare that object against others which don't have that issue , i cant find a difference , , i asked Binary they do not know I looked for illegal characters and cant find any , took all listed attributes apart with no luck 



    Martin Strasser Carpe Diem


    Thursday, September 6, 2018 8:12 PM
  • Have you tried manually renaming one of the objects and then testing against that?

    Search, Recover, Export Mailboxes, Contacts, Calendars, Tasks from ALL versions of Exchange Offline EDB's, On-Premises Exchange Databases & Office 365. Export, Migrate/Recover into On-Premises Exchange Server, Office 365 with Lucid8's DigiScope

    Thursday, September 6, 2018 8:29 PM
  • see that is the thing I can go in AD UandC   and can edit the object without an issue, then going back to EAC it gives me that error again. but it reflects the changes 

    not sure yet if exchange accepts it all the way , have to wait my 24 hours to see,   however that would be a bandage and not a solution if it works , just bugs me. 


    Martin Strasser Carpe Diem


    Thursday, September 6, 2018 8:58 PM
  • I would force replication and ensure your AD is solid without issues

    Search, Recover, Export Mailboxes, Contacts, Calendars, Tasks from ALL versions of Exchange Offline EDB's, On-Premises Exchange Databases & Office 365. Export, Migrate/Recover into On-Premises Exchange Server, Office 365 with Lucid8's DigiScope

    Thursday, September 6, 2018 9:11 PM
  • You can check this script;

    https://gallery.technet.microsoft.com/scriptcenter/Active-Directory-Health-709336cd

    and also these commands&tool;

    ad replication tool ; https://www.microsoft.com/en-us/download/details.aspx?id=30005

    What does DCDIAG actually… do?  http://blogs.technet.com/b/askds/archive/2011/03/22/what-does-dcdiag-actually-do.aspx

    Active Directory Health Checks for Domain Controllers  http://msmvps.com/blogs/ad/archive/2008/06/03/active-directory-health-checks-for-domain-controllers.aspx


    Search, Recover, Export Mailboxes, Contacts, Calendars, Tasks from ALL versions of Exchange Offline EDB's, On-Premises Exchange Databases & Office 365. Export, Migrate/Recover into On-Premises Exchange Server, Office 365 with Lucid8's DigiScope

    Thursday, September 6, 2018 9:15 PM
  • all seems normal   :-( 

    Martin Strasser Carpe Diem

    Thursday, September 6, 2018 11:10 PM
  • Hi Martin,

    Please refer to the following steps and check if there is any difference compare with another normal group:

    ADUC -> View -> select advance features->Double click the group -> attribute editor 

     


    Best Regards,
    Niko Cheng


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Friday, September 7, 2018 8:40 AM
    Moderator
  • yes that is one of the first things I did , I cant find anything different , no trailing spaces no white spaces 

    It might be something the migration tool did , Still cant figure out what it is. 


    Martin Strasser Carpe Diem

    Friday, September 7, 2018 1:21 PM
  • It might be something the migration tool did , Still cant figure out what it is. 

    Hi Martin, 

    Agree, it might be caused by the migration tool, as a workaround, you can delete this problematic group and recreate it in Exchange.


    Best Regards,
    Niko Cheng


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Monday, September 10, 2018 8:14 AM
    Moderator
  • Hi ,

    I'm just writing to check how's everything going? If you have any questions or needed further help on this issue, please feel free to post back. If the issue has been resolved, please mark the helpful replies as answers, this will make answer searching in the forum easier and be beneficial to other community members as well. Thanks for your understanding.


    Best Regards,
    Niko Cheng


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Friday, September 21, 2018 1:29 AM
    Moderator
  • Hello,

    I'm experiencing a similar error.  I have inserted the image here.  This occurs when I am in EAC.  I navigate to the user.  The error occurs when I click on 'Mailbox Delegation'.



    • Edited by Krafcky Inc Tuesday, October 9, 2018 12:26 PM
    Tuesday, October 9, 2018 12:24 PM
  • how did you fix this

    Thanks & Regards Ramandeep Singh

    Saturday, July 6, 2019 4:51 AM
  • Apparently it just needed restart of Exchange server as my new DC was introduced (win 2016). no issues now

    Thanks & Regards Ramandeep Singh

    Sunday, July 21, 2019 6:01 AM