none
Cannot open *.xls files from Windows Explorer. RRS feed

  • Question

  • Cannot open *.xls files from Windows Explorer.  Laptop, Windows 7 64bit, Microsoft Office Professional 2010.  Open with defaults to Excelcnc.exe,  will open from within Excel program but that is not satisfactory.
    Tuesday, August 21, 2012 6:09 PM

Answers

  • Hi,

    It is caused by the incorrect association between the .xls file type and program. You will need to re-associate the file type. Try the following steps:

    1. Go to Start -> Control Panel -> Default Programs -> Associate a file type or protocol with a program.
    2. Locate the file .xls. Highlight it and click the Change Program button. Choose Microsoft Excel from the list. If you are unable to see Microsoft Word from the list, click the Browse button. Browse to the folder: C:\Program Files (x86)\Microsoft Office\Office14, and choose Excel.exe.
    3. Click OK to save the settings. You can reboot your computer after settings.

    If it not work ,you can repair Office 2010 follow this article steps:
    http://office.microsoft.com/en-us/excel-help/repair-or-remove-office-2010-HA010357402.aspx

    Sincerely
    Rex Zhang


    Rex Zhang

    TechNet Community Support

    Wednesday, August 22, 2012 7:58 AM
    Moderator