none
Lync 2013 mobile client not working RRS feed

  • Question

  • Dear All,

    I am facing a strange issue.

    I deployed Lync 2013 mobility with standard edition and IIS ARR as reverse proxy.

    When I am trying to login with LYNC 2013 mobile client it gives me an error We cant connect to the server. if your are using wifi, Open your wifi to see if you have a connection. other wise disabel any hotspot..."

    When I use lync 2010 mobile client to log in it connects successfully and I could communicate.

    Please help me to solve the issue.

    Regards,

    Anish Sebastian


    Anish Sebastian

    Monday, August 10, 2015 6:10 PM

Answers

  • Hi Anish.

    If issue only is happening with Lync Mobile 2013 version, I suggest you firts making double check on the DNS records for mobility:

    Ensure that DNS record: lyncdiscoverinternal is poiting to Front End Ip for Standard environment,
    Ensure that DNS record: lyncdiscover is poiting to Private IP of Reverse Proxy
    Ensure that DNS record for: External Web Services is poiting to Private IP of Reverse Proxy

    If after that is not working, remove and rebuild the IIS ARR rules as per the following URL: http://blogs.technet.com/b/uclobby/archive/2013/08/02/configuring-arr-for-lync-server.aspx

    Note: If you updated to the lastest CU for the Lync Environment, make sure that Back End was correctly updated.

    Please let us know the results.


    PLEASE REMEMBER, if you see a post that helped you please click "Vote As Helpful" and if it answered your question please click "Mark As Answered"

    Wednesday, August 12, 2015 6:18 PM

All replies

  • The Lync 2013 mobility client requires the user to be homed on a Lync Server 2013 and at least CU1 installed.

    Please mark posts as answers/helpful if it answers your question.
    Blog
    Lync Validator - Used to assist in the validation and documentation of Lync Server 2013.


    Monday, August 10, 2015 6:13 PM

  • You could use a not so well known yet very useful tool to help in your Lync Mobile App troubleshooting from internal and external networks:

    Microsoft Lync Connectivity Analyzer (32 Bit)
    http://www.microsoft.com/en-us/download/details.aspx?id=36536


    Please share with us if this helps.

    Thanks / rgds,


    TechNet/MSDN Forum Moderator - http://www.leedesmond.com

    Monday, August 10, 2015 6:28 PM
    Moderator
  • Hi Anish Sebastian,

    Lync 2010 mobile client is programmed to use Mcx Web Service , but the Lync 2013 mobile client is programmed to use the new web service “Unified Communication Web API (UCWA)”, and no do not utilize the previous Mcx web service.

    Lync 2013 Mobile will be able to use a Lync Server 2013 deployment with the Cumulative Updates for Lync Server 2013: February 2013 applied. The Cumulative Updates for Lync Server 2013: February 2013 install Unified Communications Web API, or UCWA. UCWA is the component used for Lync 2013 Mobile clients.

    If this is not the case, you may also check the IIS application status, ensure the application is running.


    Best regards,

    Eric


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.



    Tuesday, August 11, 2015 1:55 AM
    Moderator
  • I am using Lync 2013 standard edition server. 

    Lync connectivity analyzer tell me my deployment meets the requirements.

    UCWA in IIS Application Pool is running.

    I updated the server with the latest cumulative updates.


    Anish Sebastian

    Tuesday, August 11, 2015 4:27 AM
  • Hi Anish.

    If issue only is happening with Lync Mobile 2013 version, I suggest you firts making double check on the DNS records for mobility:

    Ensure that DNS record: lyncdiscoverinternal is poiting to Front End Ip for Standard environment,
    Ensure that DNS record: lyncdiscover is poiting to Private IP of Reverse Proxy
    Ensure that DNS record for: External Web Services is poiting to Private IP of Reverse Proxy

    If after that is not working, remove and rebuild the IIS ARR rules as per the following URL: http://blogs.technet.com/b/uclobby/archive/2013/08/02/configuring-arr-for-lync-server.aspx

    Note: If you updated to the lastest CU for the Lync Environment, make sure that Back End was correctly updated.

    Please let us know the results.


    PLEASE REMEMBER, if you see a post that helped you please click "Vote As Helpful" and if it answered your question please click "Mark As Answered"

    Wednesday, August 12, 2015 6:18 PM
  • do you know if an older version of the Lync 2013 Mobile App works or not? Which platform is affected - iOS, Android or Windows platform?

    Wednesday, August 12, 2015 7:52 PM
    Moderator
  • Enable UCWA/SIP stack /S4 tracing in SE. Repro the issue from mobile client and check the following ;

    • Does the Lync 2013 mobile client traffic reach SE ?
    • Did we complete TLS handshake ? (SE to RP internal leg)
    • Web ticket provisioned ?

    Logs might help you narrow down the issue.

    Thanks,

    Saleesh


    If answer is helpful, please hit the green arrow on the left, or mark as answer. Technet Blog

    Wednesday, August 12, 2015 10:37 PM
  • Hi Anish,

    I’m writing to follow up on this thread. Do you have any updates on this issue? Please post back at your convenience.

     

    Best regards,

    Eric


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Saturday, August 22, 2015 2:54 PM
    Moderator
  • Hi Anish, 

    I'm marking the reply as answer as there has been no update for a couple of days.

    If you come back to find it doesn't work for you, please reply to us and unmark the answer.

     

    Best regards,

    Eric


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Monday, August 24, 2015 2:36 AM
    Moderator