Sharepoint 2010 Development environment setup error - Stand-alone provisioning has failed because an error occurred while enumerating the SharePoint Server products installed on this server


  • I have the same problem as this (hence the same title)

    Definitely not a license key issue. The only other thing I can think of is that I have Office 2003 installed on my machine?

    For information what I'm trying to do is this:

    - Install Sharepoint Server 2010 on my local Windows 7 (64 bit) machine
    - Already have the pre-reqs installed
    - Have followed these instructions - to the letter
    - Am connecting to the internet via a proxy but have run Fiddler alongside installation / configuration and no errors (407s)

    Any help would be greatly appreciated!!

    Thanks, Rob

    Full error: 


    Exception has been thrown by the target of an invocation. --->

    System.InvalidOperationException: Stand-alone provisioning has failed because an error occurred while enumerating the SharePoint Server

    products installed on this server.       

    at Microsoft.Office.Server.EvaluatorModeProvisioning.OfficeServerProducts.get_OfficeProductList()       

    at Microsoft.Office.Server.EvaluatorModeProvisioning.OfficeServerProducts.IsInstalled(OfficeServerProductToProvision product)       

    at Microsoft.Office.Server.EvaluatorModeProvisioning.SharedEvaluatorModeProvisioning.GetProvisioner()       

    at Microsoft.Office.Server.EvaluatorModeProvisioning.SharedEvaluatorModeProvisioning..ctor(TraceListener listener)       

    --- End of inner exception stack trace ---       

    at System.RuntimeMethodHandle._InvokeConstructor(Object[] args, SignatureStruct& signature, IntPtr declaringType)       

    at System.Reflection.RuntimeConstructorInfo.Invoke(BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)       

    at Microsoft.SharePoint.PostSetupConfiguration.ReflectionHelper.InvokeConstructor(String assemblyQualifiedName, Type[] constructorSignature,

    Object[] constructorParameters)       

    at Microsoft.SharePoint.PostSetupConfiguration.TaskCommon.ReflectionHelperInvokeConstructor(String assemblyQualifiedName, Type[]

    constructorSignature, Object[] constructorParameters, TaskBase task)       

    3at Microsoft.SharePoint.PostSetupConfiguration.EvalModeProvisionTask.LoadProvisioner()       

    at Microsoft.SharePoint.PostSetupConfiguration.WelcomeForm.ShowNextFormForServerRoleSingleServer()       

    at Microsoft.SharePoint.PostSetupConfiguration.WelcomeForm.PsconfigBaseFormNextButtonClickedEventHandler(Object sender, EventArgs e)       

    at System.Windows.Forms.Control.OnClick(EventArgs e)       at System.Windows.Forms.Button.WndProc(Message& m)       

    at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)       

    at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

    Tuesday, April 24, 2012 10:49 AM


All replies

  • Hi,

    According to .net reflector analysis at Microsoft.Office.Server.EvaluatorModeProvisioning.OfficeServerProducts.get_OfficeProductList(), if the return of NativeMethods.MsiEnumProducts(productIndex, returnedProductCode) is not equal to zero, it will result tracelogerror in the log file and threw InvalidOperationException.

    To find the log file, open a Command Prompt window, and then type the following commands at the command prompt. The log file is displayed at the end of the directory listing.

    cd %temp%

    dir /od *.log

    Based on my experience, the MsiEnumProducts function should return 1610, which means ERROR_BAD_CONFIGURATION.

    Finally, please check if you have enable UAC, if so, please disable UAC, then try again.

    For more information about MsiEnumProducts function, check out the following articles:


    Rock Wang

    Rock Wang TechNet Community Support

    Wednesday, April 25, 2012 8:01 AM
  • Hi Rock,

    Thanks for taking the time to reply. Unfortunately this doesn't help me diagnose the actual problem. 

    For information, I've now managed to get Sharepoint Server 2010 to install on my Windows 7 machine in a "Farm" configuration. So I presumed I'd fixed the problem. Everything installed fine, I can access central configuration, and create web applications / site collections.

    However, when I first tried to access the first top-level site, I got an error. I checked the log, and it's exactly the same error!

    The only thing I can think of is, back to one of my original points, is that I've got Microsoft Office 2003 installed?? Can there be anything else??

    Thursday, April 26, 2012 3:19 PM
  • Hi,

    You can download a tool whose name is EnumProducts from the following link, then locate Bin\debug\ directory, run EnumProducts.exe, it will tell you the GUID of the problematic products.!203&parid=B695F2653D3D142C!174


    Rock Wang 

    Rock Wang TechNet Community Support

    • Marked as answer by RJ-Liverpool Thursday, May 10, 2012 4:01 PM
    Friday, May 04, 2012 9:37 AM
  • Thanks so much Rock. It was SQL SERVER COMPACT EDITION 3.5 SP2 that was erroring (slightly odd that it brings down almost the whole of sharepoint, but anyway.)Had to manually remove it / reg keys and now it all works!!
    Thursday, May 10, 2012 4:02 PM
  • Hi Rock,

    Do you still have this file EnumProducts available for download?  The link is no longer working.



    Monday, February 29, 2016 10:30 PM