How do I get my emails to show up in the "Search Inbox (Ctrl+E)" search function? RRS feed

  • Question

  • Last week, my email worked fine. I use Microsoft Outlook 2010 for work.


    Say "Tom" sent me an email on 9/25 (Wed), 9/28 (Sat) and 9/30 ( If I scroll through my emails (sorted by "Received") I can see all of my emails including the most current.

    If I go to the "Search Inbox" function and search "Tom," the only email that shows up in my Search results is the one from 9/25. For some reason, my inbox search will not show any recent emails from within the last 5 days.


    How do I fix this so that, when I do search ALL relevant emails (even those from today) will show up in my Search?

    Also, I am not getting any "Errors" show up or anything of the like.

    Thank you!

    Monday, September 30, 2013 11:56 PM


  • Hi,

    a. Please follow the steps below to verify that indexing is complete:

    1. In Outlook, click in the Search box.

    2. Click the Search tab, click Search Tools, and then click Indexing Status.

    3. When the Indexing Status dialog appears, you should see the following:

    Outlook has finished indexing all of your items.

    0 items remaining to be indexed.

    If Outlook has not finished indexing all of your items, note the items remaining to be indexed, wait 5 minutes, and then check again. If the number of items did not decrease, continue to troubleshoot by using the steps in the following sections.

    b. If indexing seems to be stuck and is incomplete, rebuild the search catalog. To rebuild the catalog, follow these steps:

    1. Exit Outlook.

    2. Click Start, type Indexing Options in the Start Search box, and then press Enter.

    3. In the Indexing Options dialog box, click Modify, click to clear the check box next to Outlook, and then click OK.

    4. In the Indexing Options dialog box, click Advanced.

    5. In the Advanced Options dialog box, click Rebuild.

    6. Click OK.

    7. Click Close.


    Steve Fan
    TechNet Community Support

    Tuesday, October 1, 2013 4:00 PM