none
remote desktop protocol error RRS feed

  • Question

  • When connecting to my windows server 2008 machine as the adminstrator, I often get the error message " because of a protocol error, the remote session will be disconnected ... "

    This always happens especially when I open a browser in the server machine, as the webpage is being loaded. After the the loading finish, connection will be safe.

    When I search for the event log in the server machine, I always find a warning administrator event:
    "Microsoft-Windows-TerminalServices-PnPDevices: Redirection of additional supported devices is disabled by policy."

    But following this event ID 36 and its solution http://technet.microsoft.com/en-us/library/cc775202%28WS.10%29.aspx, I cannot work around. I also change the remote desktop settings to cross out any PnP device (to exactly all devices will not be brought to the remote session) but problem still remains.

    For other possible solutions, I have update both client machine and server machine. I have tried different client machines, with OS being windows XP pro or windows server 2003. I have tried different versions of RD applications MSTSC.exe. I also patched a hotfix for windows 2008. In short, I have tried many official and non-official workarounds for this issue but no one works actually.

    I hope someone could give a real answer. Thanks!
    Saturday, February 20, 2010 1:41 AM

All replies

  • Same problem here... :(

    Does anyone have a solution to end with this error?

    Monday, March 1, 2010 2:44 PM
  • How that link helps to solve this error?
    Monday, March 1, 2010 11:15 PM
  • Anyone?
    Tuesday, March 2, 2010 7:37 PM
  • Hello, any clues in the house?
    Thursday, March 4, 2010 11:04 AM
  • Hi, sorry for not looking at this thread these days. One reason is I was totally frustrated about this issue.

    I have tried this patch before but only the error frequency is arguably lowered. It doesn't fully resolve the problem, though the remote server becomes approachable now.

    Better way to tune the compression setting is directly modify the .rdp file of remote connection profile, usually located in your "my documents". Just simply set the compression switch to 0.

    Friday, March 5, 2010 4:28 AM
  • Unfortunately Setting up the compression switch to 0 didn’t solved the problem.

    Any clues ?

    Saturday, March 6, 2010 10:20 PM
  • any clues in the house?
    Monday, March 8, 2010 4:57 PM
  • I'm having the identical issue.  I have a Windows 2008 R2 server running the Hyper-V role and the Remote Desktop option enabled.  Whenever I reboot I get the Event ID 36 error:
         Redirection of additional supported devices is disabled by policy.

    I verified that no such policy exists using RSOP.MSC.  I looked at the following location:
        Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Device and Resource Redirection\Do not allow supported Plug and Play device redirection
             
    This is set to "Not Configured".
                   For fun, I've tried both enabling and disabling this setting (rebooting after each change), and it had no effect on the problem.

     

    Additionally, I verified that the setting was disabled within the Remote Desktop Session Host Configuration utility:
         RDP-Tcp -> Right-Click -> Properties -> Client Settings
              Redirection
                   Supported Plug and Play Devices
    For fun, I tried this setting both enabled and disabled, rebooting after each change, but this had no effect on the error.

     

    I want to make clear that this Event ID 36 is not occurring when I connect with a Remote Desktop Connection.  It's occurring during the boot process of the server, and the user for the Event ID 36 is listed as "SYSTEM".

     

    If anyone has any further suggestions, I'm all ears.

     

    See Ya!
    Van


    Venice, FL, USA
    Sunday, March 13, 2011 12:19 AM
  • I realize this is an old thread so it is probably too little too late, but for anyone else that stumbles across this with an RDP protocol error I have seen this happen a few times.  When I look at the remote desktop server the user with the problem usually has an "Active" session, although they are not actually actively connected.  If I log the user off through task manager they are always able to reconnect without a protocol error message.  Not sure the root cause of this but it is a pretty quick fix.
    Thursday, July 25, 2013 5:38 PM