none
Microsoft ODBC Administrator: The setup routines for the Microsoft Excel Driver (*.xls, *.xlsx,*.xlsm,*.xlsb) ODBC driver could not be found. Please reinstall the driver.

Answers

All replies

  • Check name of driver in ADO string.

    you can use "open file for" method with split() function. 


    Oskar Shon, Office System MVP

    Press if Helpful; Answer when a problem solved


    Wednesday, July 25, 2012 4:49 PM
  • Hi,

    Based on my research, I want to confirm that whether you have a 64 bit OS so trying to use a 64 bit ODBC Data Source Admin with a 32 bit application.

    If it is, then the resolutionis that use a 32bit ODBC Data Source Admin.


    Jaynet Zhang

    TechNet Community Support

    Thursday, July 26, 2012 7:25 AM
    Moderator
  • Hi,

    it took me a while to understand the issue - but here is the solution:

    32-Bit Excel needs 32-Bit ODBC-Adminstrator odbcad32.exe which lives in C:\Windows\SysWOW64

    64-Bit Excel needs 64-Bit ODBC-Adminstrator odbcad32.exe which lives in C:\Windows\System32

    We should not discuss neither the identical names of different files nor the misleading naming of a directory named something32 but contains 64-Bit-software.


    • Proposed as answer by Jetboy2k Wednesday, July 03, 2013 7:55 PM
    Monday, April 15, 2013 1:11 PM
  • John, thanks very much. I went to a number of different pages (most of them official MS sites) that had the "answer," none of which worked. This resolved my issue in 30 seconds.

    Thanks again, someone should DEFINITELY mark this as answered.

    Wednesday, July 03, 2013 7:56 PM
  • Hopefully someone is still monitoring this. I'm having an issue I believe can be traced to what you're discussing here. You say 64-bit needs 64-Bit ODBC-Adminstrator odbcad32.exe which lives in C:\Windows\System32 

    That's fine, but how I make my 64-bit excel use that Administrator? 

    Thanks!

    Here is a more thorough explanation of my issue:

    I'm usually pretty good at troubleshooting excel - often with help from this forum - but I can't seem to crack this one.

    I have a few excel docs where I create a web query and pull data 'From Web'. The data is in XML tables in my docs. When neccesary, I hit refresh on the XML table and get the new, updated data.

    I've done this for years without issue, but a few months ago I hit a snag and I can't resolve it. The big mistake I made was using CCCleaner, which "repaired" my registry, but I failed to backup said registry. Since that point, I get errors when I try to refresh these query XML tables. The error is as follows: "XML Import Error - Data Source not found - Import Status Failed". No further details.

    Oddly enough, if I close the file and open it on my laptop, I can refresh without issue. In fact, sometimes when I close excel and open it back up, I can refresh the tables fine. A few hours later, however, it fails again.

    I tried system restore. I've tried repairing excel. I've tried completely rebuilding this file. In Admin Tools-ODBC Data Source Admin, there was an error that I fixed. Still...No dice.

    Any help here would be massively appreciated. Thank you.

    Details: PC - Windows 7 Prof - Office H&S 2013 - 64 bit

    Wednesday, March 29, 2017 8:20 PM