none
Open Documents in Client Applications by Default RRS feed

  • Question

  • Hi,

    I've enabled OWA in SharePoint 2013 environment and for certain Site collections I enabled feature "Open Documents in Client Applications by Default".

    But there is an issue that only Internet Explorer works correctly according this settings: IE uses client application correctly, Edge offers to a download of file, Chrome uses OWA regardless, Firefox uses OWA regardless.

    Is this a known issue? Can it be resolved on SharePoint level or is this browser related issue and needs to be fixed within each browser?

    BR / Jan

    Friday, September 21, 2018 11:24 AM

All replies

  • Hi lan26,

    Please go to the library which you store files, then go to Library settings->Advanced Settings, in "Open in Documents in Browser" section, select "Open in client application".

    After that, test again.

    Thanks,

    Wendy


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Monday, September 24, 2018 6:09 AM
    Moderator
  • Hi, unfortunately changing from "Use the server default (Open in client application)" to "Open in client application" does not make any difference in Chrome and Firefox. It still uses OWA :-(
    Thursday, September 27, 2018 12:40 PM
  • Hi lan26,

    You can try to use IE Tab in Chrome to test it.

    Also you can also use IE tab add-on for Firefox.

    A thread for your reference:

    https://stackoverflow.com/questions/14455212/how-to-open-sharepoint-files-in-chrome-firefox

    Thanks,

    Wendy


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Wednesday, October 3, 2018 8:51 AM
    Moderator
  • Hi lan26,

    I am checking to see how things are going there on this issue.

    Thanks,

    Wendy


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Monday, October 8, 2018 9:59 AM
    Moderator