none
Problems with Lync 2010 and Exchange 2010 Integration RRS feed

  • Question

  • Has anyone a detailed description for the Exchange UM Intergation for Lync 2010? I am not able to make voice mail work with Lync 2010 RC (engl) and Exchange 2010 SP1 (german version)!

    Installation of Lync 2010 Standard Edition (colocated onone server)worked like a charm, Enterprise Voice with Ferrari Gateway was not a problem either.
    I went through the steps within the 'Planning for Enterprise Voice Lync 2010 Server (RC)', created a SIP Dial Plan, added and installed certificates from the internal root-ca, ran exchucutil.ps1 to create UMIP Gatewy, hunt group etc.
    I have only one global dial plan within Lync so I started the
    ocsumutil.exe to map the Dial plans...

    Nonetheless voice mail cannot be called by the users. If I check the log File in case of voice mail call, i can see that the lync server ist transferring the call to the exchange server, but the exchange server drops the call immediatley. There's no error within the exchange sever's event log just an info message that Exchange Server disconnected the call.

    Lync Server Event Log shows the following error:

    Attempts to route to servers in an Exchange UM Dialplan failed

    No server in the dialplan [Global.XXX.at] accepted the call with id [829b76339bc2485ca0a61350325ee0a7].
    Cause: Dialplan is not configured properly.
    Resolution:
    Check the configuration of the dialplan on Exchange UM Servers.

    I checked the dial plan on the exchange um server and cannot figure out what's wrong (SIP-Secured, URI-Typ SIP-URI, added a Exchange UM Server, UM Gateway, UM Hunt group and UM Policy look good). Ran the Test-UMConnectivity on the Exchange...no problem..

    When calling the vocie mail from the lync client the following error message apperars within event log:

    Response Data:

     

    183  Session Progress

     

     

    101  Progress Report

    ms-diagnostics:  13007;reason="Request was proxied to an application.";source="LYNC-RC.XXXX.at";targetApp="voicemail";appName="InboundRouting"

     

     

    101  Diagnostics

    ms-diagnostics:  15008;reason="Routing to UM for Subscriber Access";source="LYNC-RC.XXXX.at";dialplan="Global.weiz.at";umserver="EXCHANGE-SERVER.XXXX.at";appName="ExumRouting"

     

     

    101  Diagnostics

    ms-diagnostics:  15032;reason="Re-directing request to the destination in 302";source="LYNC-RC.weiz.at";dialplan="Global.XXXX.at";umserver="EXCHANGE-SERVER.XXXX.at";nexttarget="EXCHANGE-SERVER.XXXX.at";routingtype="Routing to UM for Subscriber Access";appName="ExumRouting"

     

     

    180  Ringing

     

     

    101  Diagnostics

    ms-diagnostics:  15034;reason="Failed to route to Exchange Unified Messaging Server";source="LYNC-RC.XXXX.at";dialplan="Global.XXXX.at";umserver="EXCHANGE-SERVER.XXXX.at";responsecode="488";appName="ExumRouting"

     

     

    199  Early Dialog Terminated

     

     

    480  Temporarily Unavailable

    ms-diagnostics:  15030;reason="Failed to route to Exchange Server";source="LYNC-RC.XXXX.at";dialplan="Global.XXX.at";appName="ExumRouting";OriginalPresenceState="0";CurrentPresenceState="0";MeInsideUser="Yes";ConversationInitiatedBy="0";SourceNetwork="0";RemotePartyCanDoIM="No"

     

    Anybody out there with the same problem?

     

     


     

    • Moved by Ben-Shun Zhu Wednesday, October 20, 2010 8:11 AM incorrect queue (From:Planning and Deployment)
    Tuesday, October 19, 2010 12:00 PM

Answers

  • By the way I resolved the issue.  On the property of the dial plan within the Exchange management console set the VOIP security value to "Secured" and not "SIP Secured" and it will be all fine.  Thanks.
    Thursday, November 4, 2010 1:49 AM

All replies

  • here's the detailed Log from the Exchange UM

    role:

    TL_INFO(TF_COMPONENT) [0]0B5C.12B0::10/13/2010-16:05:17.544.000002a5 (ExumRouting,ExumRouting.OnExumRequest:exumrouting.cs(426))[598005319]OnExumRequest() for an INVITE request
    TL_INFO(TF_COMPONENT) [2]0B5C.12B0::10/13/2010-16:05:17.546.000002a6 (ExumRouting,ExumRouting.OnExumRequest:exumrouting.cs(512))[598005319]Routing to voicemail.
    TL_INFO(TF_COMPONENT) [2]0B5C.12B0::10/13/2010-16:05:17.546.000002a7 (ExumRouting,ExumRoutingApplication.Start:exumroutingapplication.cs(278))[598005319]Dialplan: 'Global.XXXX.at'
    TL_INFO(TF_COMPONENT) [2]0B5C.12B0::10/13/2010-16:05:17.547.000002a8 (ExumRouting,ExumRoutingApplication.RouteBasedOnDialPlan:exumroutingapplication.cs(989))[598005319]RouteBasedOnDialPlan() dialplan=Global.XXXX.at appid=<null>
    TL_INFO(TF_COMPONENT) [1]0B5C.12B0::10/13/2010-16:05:17.549.000002a9 (ExumRouting,RoutingApplication.SendResponse:routingapplication.cs(47))[598005319]Response Code 101 on Server Transaction.
    TL_INFO(TF_COMPONENT) [1]0B5C.12B0::10/13/2010-16:05:17.549.000002aa (ExumRouting,ExumRoutingApplication.SendRequest:exumroutingapplication.cs(1522))[598005319]Sending request to sip:Global@EXCHANGE-SERVER.XXXX.at:5061;transport=tls;maddr=EXCHANGE-SERVER.XXXX.at
    TL_INFO(TF_COMPONENT) [2]0B5C.1370::10/13/2010-16:05:17.554.000002d8 (ExumRouting,ExumRoutingApplication.ct_ResponseReceived:exumroutingapplication.cs(2025))[598005319]ResponseReceived 100 uri=sip:testuser@XXXX.at;opaque=app:voicemail
    TL_INFO(TF_COMPONENT) [2]0B5C.1370::10/13/2010-16:05:17.554.000002d9 (ExumRouting,RoutingApplication.SendResponse:routingapplication.cs(132))[598005319]Proxying Response Code 100 on Server Transaction.
    TL_INFO(TF_COMPONENT) [0]0B5C.1368::10/13/2010-16:05:17.762.000002e8 (ExumRouting,ExumRoutingApplication.ct_ResponseReceived:exumroutingapplication.cs(2025))[598005319]ResponseReceived 302 uri=sip:testuser@XXXX.at;opaque=app:voicemail
    TL_INFO(TF_COMPONENT) [0]0B5C.1368::10/13/2010-16:05:17.762.000002e9 (ExumRouting,ExumRoutingApplication.ct_ResponseReceived:exumroutingapplication.cs(2044))[598005319]Disbaling pstn re-routing for resiliency as we received valid response
    TL_INFO(TF_COMPONENT) [0]0B5C.1368::10/13/2010-16:05:17.762.000002ea (ExumRouting,ExumRoutingApplication.Process302Response:exumroutingapplication.cs(1787))[598005319]Current Host ='EXCHANGE-SERVER.XXXX.at', Contact Host='EXCHANGE-SERVER.XXXX.at'
    TL_INFO(TF_COMPONENT) [0]0B5C.1368::10/13/2010-16:05:17.762.000002eb (ExumRouting,RoutingApplication.SendResponse:routingapplication.cs(47))[598005319]Response Code 101 on Server Transaction.
    TL_INFO(TF_COMPONENT) [0]0B5C.1368::10/13/2010-16:05:17.762.000002ec (ExumRouting,ExumRoutingApplication.SendRequest:exumroutingapplication.cs(1522))[598005319]Sending request to sip:Global@EXCHANGE-SERVER.XXXX.at:5065;transport=Tls;maddr=EXCHANGE-SERVER.XXXX.at
    TL_INFO(TF_COMPONENT) [0]0B5C.1370::10/13/2010-16:05:17.767.00000309 (ExumRouting,ExumRoutingApplication.ct_ResponseReceived:exumroutingapplication.cs(2025))[598005319]ResponseReceived 100 uri=sip:testuser@XXXX.at;opaque=app:voicemail
    TL_INFO(TF_COMPONENT) [0]0B5C.1370::10/13/2010-16:05:17.767.0000030a (ExumRouting,RoutingApplication.SendResponse:routingapplication.cs(132))[598005319]Proxying Response Code 100 on Server Transaction.
    TL_INFO(TF_COMPONENT) [0]0B5C.1368::10/13/2010-16:05:17.973.00000319 (ExumRouting,ExumRoutingApplication.ct_ResponseReceived:exumroutingapplication.cs(2025))[598005319]ResponseReceived 180 uri=sip:testuser@XXXX.at;opaque=app:voicemail
    TL_INFO(TF_COMPONENT) [0]0B5C.1368::10/13/2010-16:05:17.973.0000031a (ExumRouting,RoutingApplication.SendResponse:routingapplication.cs(132))[598005319]Proxying Response Code 180 on Server Transaction.
    TL_INFO(TF_COMPONENT) [0]0B5C.1370::10/13/2010-16:05:18.175.00000341 (ExumRouting,ExumRoutingApplication.ct_ResponseReceived:exumroutingapplication.cs(2025))[598005319]ResponseReceived 488 uri=sip:testuser@XXXX.at;opaque=app:voicemail
    TL_WARN(TF_COMPONENT) [0]0B5C.1370::10/13/2010-16:05:18.176.00000342 (ExumRouting,ExumRoutingApplication.MakeAttempt:exumroutingapplication.cs(1124))[598005319]Selected dial plan does not have any more servers.
    TL_INFO(TF_COMPONENT) [0]0B5C.1370::10/13/2010-16:05:18.176.00000343 (ExumRouting,RoutingApplication.SendResponse:routingapplication.cs(47))[598005319]Response Code 101 on Server Transaction.
    TL_INFO(TF_COMPONENT) [0]0B5C.1370::10/13/2010-16:05:18.176.00000346 (ExumRouting,RoutingApplication.SendResponse:routingapplication.cs(47))[598005319]Response Code 480 on Server Transaction.

    uhh... could someone move my post to the UM Integration thread..

     

    Tuesday, October 19, 2010 12:02 PM
  • I have the exact same problem.  This never happened in the build before 7400.   Did you ever figure out how to fix this?  I followed the UM integration steps in the Lync_ITPro.chm excatly.
    Tuesday, October 26, 2010 9:55 PM
  • No...can't make it work. Worst case scenario is to wait for Release version and see if the problem still exists...
    Friday, October 29, 2010 11:28 AM
  • We reached RTM this week so I would respectfully ask that you do seek to test with the RTM bits to see if it is something fixed and if not we can investigate further.


    Tom Laciano Microsoft Program Manager UC Customer and Partner Deployment Readiness
    Friday, October 29, 2010 2:27 PM
  • I have the exact same problem.  I have an SA Enterprise agreement with Microsoft.  How do I get the RTM version of the software?  Thanks.
    Thursday, November 4, 2010 1:12 AM
  • By the way I resolved the issue.  On the property of the dial plan within the Exchange management console set the VOIP security value to "Secured" and not "SIP Secured" and it will be all fine.  Thanks.
    Thursday, November 4, 2010 1:49 AM
  • I have the exact same problem.  I have an SA Enterprise agreement with Microsoft.  How do I get the RTM version of the software?  Thanks.


    According to the UC Team Blog, it will be "downloadable" from your Microsoft licensing site on Dec. 1.  See:

    http://blogs.technet.com/b/uc/archive/2010/11/02/lync-rtm-blog-post-for-november-2-2010.aspx

    "The final milestone, known as GA or general availability, is December 1st, when existing customers who have maintained their SA (Software Assurance license), as well as new Lync customers, will be able to download Lync Server 2010 from the Microsoft Volume Licensing Service Center (VLSC). "


    Tim Harrington - Catapult Systems - http://HowDoUC.blogspot.com
    Thursday, November 4, 2010 4:10 AM
  • Muhilaire you saved my day!!

    :)

    After setting the value to SECURED it worked for the customer Lync 2010 test deployment as well as for our internal upgrade...

    This is very interesting because, i upgraded our iternal system from OCS 2007 R2 to Lync 2010 and the original (and working) UM Dial Plan was  also set to "SIP Secured". So after moving all users and changing Target Server for the legacy UM Dial plan UM integration did not work until I changed the setting to SECURED....

    Within Microsoft's Lync Help file, section "Deployment Process for Integrating On-Premises Unified Messaging and Lync Server 2010 " it says:

    "To encrypt Enterprise Voice traffic, configure the security settings on the Exchange UM SIP dial plan as SIP Secured or Secured"

    ==> would be interesting if somebody uses SIP Secured

    Tuesday, November 16, 2010 1:14 PM
  • For reference I have a complete walk-through here for UM integration setup:
    http://blog.schertz.name/2010/11/lync-and-exchange-um-integration/

    And the most likely reason that 'SIP Secured' caused the integration to fail in your case is because that setting uses TLS for SIP communications but TCP (5060) for media communications, and following the MS directions you would have configured the UM service for TLS only.  A setting of 'Secured' uses TLS for both SIP and media.


    Jeff Schertz, Microsoft Solutions Architect - Polycom | MVP | MCITP: Enterprise Messaging | MCTS: OCS
    Tuesday, November 16, 2010 1:39 PM
    Moderator