How to really Allowing Provisioned Active Sync Mobile Devices to Connect to Exchange 2007?


  • Dear Experts,


    Based on the above link if enable the provisioning even the enabled device also not working (Means not able to configure on the enabled device also)

    I tried on my Sony Xperia Android device by running below command

    Set-CASMailbox -Identity:"Manjunatha Gowda" -ActiveSyncAllowedDeviceIDs:"androidc12345664"

    This means i could be able to connect only with abvoe device but if i tr configure on the same above device it says "User Name or password incorrect"

    Also i am not able configure on any other device also. Please let me know what I am missing here.

    Before Running the Above Command:

    I was able to configure AS on the above device as well as other devices



    Thursday, March 29, 2012 1:13 PM

All replies

  • Hi,

    Please try to remove that settings and then setup partnerships between Exchange and mobiles.

    Please get the device ID via Get-ActivesyncDevice

    After that, please try to use cmdlet with activesyncallowedDeviceIDs to allow certain mobiles for that mailbox.

    More related information to share with you:

    Controlling Exchange ActiveSync device access using the Allow/Block/Quarantine list


    Xiu Zhang

    TechNet Community Support

    Monday, April 02, 2012 7:21 AM
  • Dear Xiu,

    Thank you for the reply!

    I will explain the problem little broader way

    1. We have Nokia, Iphone and Android devices in our organisations.

    2. I am associating the Device with exchange first to get device IDs...In OWA or Using Web Tool.

    3. For Nokia I am getting Device IDs something like IMIE123456789........and Iphone ABCGDJDJD1313183129348294.......and for SAMSUNG android SAMSUNG1345458454054565.... like this

    4. Nokia device IDs are getting provisioned if I run Set-CASMailbox -Identity:"Manjunatha Gowda" -ActiveSyncAllowedDeviceIDs:"IMIE123456789"

    like this and it allows only the perticular Nokia Device to connect to exchange.

    5. But if I take the Device ID of Android devices as explained in above post.....Set-CASMailbox -Identity:"Manjunatha Gowda" -ActiveSyncAllowedDeviceIDs:"androidc12345664" (This is Sony Xperia Mobile) I am not able to allow....I mean the Device ID is not getting provisioned due to soem issue

    6. So my query is how to get the device ID of Android devices ( Iphone is also working fine)


    Monday, April 02, 2012 11:36 AM
  • Hi,

    I understand that you have set the device id first, and then allow particular device to connect on cetain user, is that ture?

    Then for Sansung Android device, you have set SAMSUNG1345458454054565, for Sony Xperia Mobile?

    What is the device ID for Sony Xperia Mobile?

    By the way, have you tried to contact to the support from Sony?

    Xiu Zhang

    TechNet Community Support

    Wednesday, April 04, 2012 5:05 AM
  • Dear Xiu,

    As mentioned in my above reply the android device ID for Sony is androidc12345664

    For Samsung is SAMSUNG1345458454054565

    But if I try to provision the Devcie using the above device ID format of Android devices, it is not working.

    In the same manner the device ID for Nokia and Iphone, Ipad are working after provisioning the same.


    Monday, April 09, 2012 1:52 PM
  • Hi,

    Please try to check IIS log and active log to see more error information for further troubleshooting.

    Xiu Zhang

    TechNet Community Support

    Tuesday, April 10, 2012 2:43 AM