none
Ommit Sharepoint login RRS feed

  • Question

  • Hi,

    We are alsways requested to login username and password in login dialog popup everytime entering our intranet and while opening files eventhough we are in the local network. We are using AD as our login. This situation discourage user to use intranet and lots..lots.. of complaints regarding this matter since it hassles users. Kind of bad impression for sharepoint 2007.

    Currently, I just can advice them to set the browser as "bypass proxy server for local addresses" to make it intranet.

    Is there any other way to avoid the login when we are in the local network?.

    TQ
    Thursday, December 10, 2009 3:15 PM

Answers

  • Set IE login in security to automatic Login using current name and password.

    That gets access to the Intranet without loin being needed.

    Then add the site to Trusted Sites or Intranet (depending on environment) and then Office files should open right away too.

    FAQ sites: (SP 2010) http://wssv4faq.mindsharp.com; (v3) http://wssv3faq.mindsharp.com and (WSS 2.0) http://wssv2faq.mindsharp.com
    Complete Book Lists (incl. foreign language) on each site.
    • Marked as answer by ciklynn Friday, December 11, 2009 12:15 PM
    Thursday, December 10, 2009 3:21 PM
  •  Adding to mikes answer >

    In Internet Explorer - Tools - Internet Option - Advanced - Make sure that the option - Enable Integrated windows authentication is Checked.

    The above step will help in integrating the windows authentication and password prompt on opening the files from sharepoint site.

    Also you can advise the users to make sure that the Office suit installed on their machines have proper 'Sharepoint support' feature enabled.


    Regards, Aj (http://www.ajittgeorge.blogspot.com) MCTS
    • Marked as answer by ciklynn Friday, December 11, 2009 12:15 PM
    Thursday, December 10, 2009 3:27 PM

All replies

  • Set IE login in security to automatic Login using current name and password.

    That gets access to the Intranet without loin being needed.

    Then add the site to Trusted Sites or Intranet (depending on environment) and then Office files should open right away too.

    FAQ sites: (SP 2010) http://wssv4faq.mindsharp.com; (v3) http://wssv3faq.mindsharp.com and (WSS 2.0) http://wssv2faq.mindsharp.com
    Complete Book Lists (incl. foreign language) on each site.
    • Marked as answer by ciklynn Friday, December 11, 2009 12:15 PM
    Thursday, December 10, 2009 3:21 PM
  •  Adding to mikes answer >

    In Internet Explorer - Tools - Internet Option - Advanced - Make sure that the option - Enable Integrated windows authentication is Checked.

    The above step will help in integrating the windows authentication and password prompt on opening the files from sharepoint site.

    Also you can advise the users to make sure that the Office suit installed on their machines have proper 'Sharepoint support' feature enabled.


    Regards, Aj (http://www.ajittgeorge.blogspot.com) MCTS
    • Marked as answer by ciklynn Friday, December 11, 2009 12:15 PM
    Thursday, December 10, 2009 3:27 PM
  • Thanks mike.

    Does that mean.. still everybody need to do their own IE setting or is it suppose to be done at server level?

    Perhaps i need to increase the awareness since most of our staff is not IT savy. :)
    Thursday, December 10, 2009 3:31 PM
  • Odd though, if you're on the same network, SharePoint shouldn't prompt you for a login. Are you using an internal DNS URL or an external FQDN to access SharePoint?
    David Lozzi
    Delphi Technology Solutions
    SharePoint Blog  |  LinkedIn | Twitter

    ** SharePoint users be aware! The command "stsadm -o uninstall" works, and it doesn't warn you, it simply uninstalls SharePoint! It happened to me!
    Thursday, December 10, 2009 3:32 PM
  • You have to make/ change the settings on the user machines where you are finding the issue.

     
    Regards, Aj (http://www.ajittgeorge.blogspot.com) MCTS
    Thursday, December 10, 2009 3:42 PM
  • I used to have this problem but I implemented Mike´s solution trough Group Policy...  on server level..
    Thursday, December 10, 2009 8:51 PM
  • Thanks guys... I'll try the solution on the server level. although we are in the same network but we use different domain.
    :)
    Friday, December 11, 2009 12:15 PM