locked
iscsi initiator "target error" when connecting to local target RRS feed

  • Question

  • Running 2 Windows Server 2008 R2 Servers and Microsoft iSCSi target software on one of the servers (Server A). Setup a target and Virtual Storage on Server A. Using Microsoft iSCSi initiator on both servers (Servers A and B). I can connect to target created on Server A with initiator on Server B. But I can't connect to target on Server A with the initiator on Server A. If I use the IQN for the target on Server A with the initiator on Server A I get an error message that says "address cannot resolve to an ip address). If I use the IP address or FQDN for the target on Server A with the initiator on Server A I get a "target error message". The error log shows event ID 41 (WinTarget error, "The iSCSi target rejected a connection request from local computer"). Thought it might be the initiator so I downloaded the Starwind initiator client, but getting connection requests denied as well. All firewall settings and port 3260 seem fine. Any ideas on what's stopping the iscsi initator on server A from connecting to the target on Server A?
    Sunday, June 3, 2012 12:45 AM

Answers

  • Running 2 Windows Server 2008 R2 Servers and Microsoft iSCSi target software on one of the servers (Server A). Setup a target and Virtual Storage on Server A. Using Microsoft iSCSi initiator on both servers (Servers A and B). I can connect to target created on Server A with initiator on Server B. But I can't connect to target on Server A with the initiator on Server A. If I use the IQN for the target on Server A with the initiator on Server A I get an error message that says "address cannot resolve to an ip address). If I use the IP address or FQDN for the target on Server A with the initiator on Server A I get a "target error message". The error log shows event ID 41 (WinTarget error, "The iSCSi target rejected a connection request from local computer"). Thought it might be the initiator so I downloaded the Starwind initiator client, but getting connection requests denied as well. All firewall settings and port 3260 seem fine. Any ideas on what's stopping the iscsi initator on server A from connecting to the target on Server A?

    Microsoft iSCSI target does not support "loopback" connections. Upgrade to Windows Server 2012 (revision coming with it DOES support loopback) or use free StarWind iSCSI target as it does support loopback on any OS.

    -nismo

    • Proposed as answer by VR38DETTMVP Sunday, June 10, 2012 5:36 PM
    • Marked as answer by dmcgill Monday, June 11, 2012 11:21 AM
    Sunday, June 3, 2012 7:23 PM

All replies

  • Running 2 Windows Server 2008 R2 Servers and Microsoft iSCSi target software on one of the servers (Server A). Setup a target and Virtual Storage on Server A. Using Microsoft iSCSi initiator on both servers (Servers A and B). I can connect to target created on Server A with initiator on Server B. But I can't connect to target on Server A with the initiator on Server A. If I use the IQN for the target on Server A with the initiator on Server A I get an error message that says "address cannot resolve to an ip address). If I use the IP address or FQDN for the target on Server A with the initiator on Server A I get a "target error message". The error log shows event ID 41 (WinTarget error, "The iSCSi target rejected a connection request from local computer"). Thought it might be the initiator so I downloaded the Starwind initiator client, but getting connection requests denied as well. All firewall settings and port 3260 seem fine. Any ideas on what's stopping the iscsi initator on server A from connecting to the target on Server A?

    Microsoft iSCSI target does not support "loopback" connections. Upgrade to Windows Server 2012 (revision coming with it DOES support loopback) or use free StarWind iSCSI target as it does support loopback on any OS.

    -nismo

    • Proposed as answer by VR38DETTMVP Sunday, June 10, 2012 5:36 PM
    • Marked as answer by dmcgill Monday, June 11, 2012 11:21 AM
    Sunday, June 3, 2012 7:23 PM
  • Dear V38DETT,

    Thanks for your answer but , for sure , with 2012 DOES - NOT - WORK

    I can't explain why but for sure this about the iSCSI initialator is a big problem. I'm going to prepare a Lab for DPM 2010 and this problem is stopping me! I've already tested this technology in the past with windows 2008r2 server as Host... now i'm using VMware but I'm not sure this is the cause...

    If someone has some idea... ( not to migrate to 2012 )

    Davide

    Thursday, September 13, 2012 3:29 PM
  • What about solution?

    Have same problem.

    Free StarWind is an option, but it's limited in 128Gb in size.

    Wednesday, November 28, 2012 8:32 AM
  • Dear V38DETT,

    Thanks for your answer but , for sure , with 2012 DOES - NOT - WORK

    I can't explain why but for sure this about the iSCSI initialator is a big problem. I'm going to prepare a Lab for DPM 2010 and this problem is stopping me! I've already tested this technology in the past with windows 2008r2 server as Host... now i'm using VMware but I'm not sure this is the cause...

    If someone has some idea... ( not to migrate to 2012 )

    Davide

    Sorry to hear you cannot upgrade to Windows Server 2012... Well, try using some other initiator for Windows. Like this one:

    http://www.starwindsoftware.com/iscsi-initiator

    ...or use other iSCSI target. Like this one:

    http://www.starwindsoftware.com/starwind-free

    Replacing just one MS component is enough (I'd go with another target). All of the listed one are free and do support a loopback connections on any version of Windows.

    Hope this helped... At least to isolate your issue.


    StarWind iSCSI SAN & NAS

    Wednesday, November 28, 2012 3:30 PM
  • What about solution?

    Have same problem.

    Free StarWind is an option, but it's limited in 128Gb in size.

    It's not limited to 128GB in size unless you do mirroring between many hosts (MS target does not do it any case). Single node can do *any* capacity.

    StarWind iSCSI SAN & NAS

    Wednesday, November 28, 2012 3:33 PM