locked
Instantly delete arriving Email Message from notification, Windows 10 RRS feed

  • Question

  • Hello, with Win7 and Outlook 2013 or 2016 (Outlook Version does not matter), I was able to instantly delete an incomming message right from the lower right corner notification area, as it arrived. I used this a low with all messages I am not interested in. Now, after Upgrade to Win10, I have this fancy Notification Area, which is nice indeed, but I only see, and can open, an email message, but I do not see any way how to delete it anymore right away.

    I am not interested into advices how to enable or disable notification, I want to have these notificatoins, but I would be happy if I still could delete messages on arrival with one single click.

    Or may I need to disable Windows notification for Outlook, but keep some Outlook notifiacation on?

    kind regards,

    Dieter Tontsch

    mobileX AG

    Thursday, March 3, 2016 5:09 PM

Answers

  • This works!

    If you do not see a compatibility tab when you right click the outlook.exe file; follow these steps:

    1: Right Click the .exe file

    2: select troubleshoot compatibility

    3: Select troubleshoot program

    4: check off: "The program worked in earlier versions of Windows..."

    5: Select the latest version of windows this worked on (Windows 7, in my case)

    6:Select Test the program

    7: Click Next

    8: Restart Outlook

    9: You should be able to delete all incoming emails through the notification!

    Wednesday, October 26, 2016 5:43 PM
  • Go to Outlook.exe which is typically in the C:\Program Files\Microsoft Office\Office16 folder.

    Right-click on the file, choose Properties, click on the Compatibility tab. Under Compatibiity Mode check the box to run the program in compatibility mode and choose Windows 7 from the dropdown. Apply. 

    (mic drop)
    Friday, September 2, 2016 8:59 PM
  • Hi,

    The new email notification feature is based on the Windows you are using. Since Windows 8, the mail alert becomes a standard Windows 8 notification. The Delete, Flag and other options are gone, possibly because such things aren’t supported in Windows 8 notifications, the same goes for Windows 10.

    Regards,

    Steve Fan
    TechNet Community Support


    Please mark the reply as an answer if you find it is helpful.

    If you have feedback for TechNet Support, contact tnmff@microsoft.com.
    Friday, March 4, 2016 2:11 AM
  • Hi Steve,

    you might be right with your pessimistic assumption :-). I was hoping that by turning of app notification for Outlook 2016 from the OS, but keeping my Outlook-based new message alert pop-up, I could manage to return back to my old-fashioned alert handling. But unfortunately, for any reason, doing so, int results into the fact that I neither get Windows 10 app alerts, nor I get my Outlook pop-up anymore. But what I still see is the new message icon in the task-bar, which is an Outlook setting too.

    Well, it's not a tragedy, but in my opinion this instant deletion hability was a handy feature.

    Cheers,

    Dieter

    Friday, March 4, 2016 5:57 AM
  • I had to set compatibility mode by following these instructions https://www.reddit.com/r/Windows10/comments/3lo4y9/compatibility_tab_missing_in_properties/

    Quite complicated, but it works if compatibility tab is not set.

    Thanks a lot jabrone

    Dieter

    Tuesday, September 13, 2016 5:46 AM
  • Hi, it is correct that when operating Oultook.exe in compatibility mode, this delete menu is working. but running Outlook in compatibility mode can cause some other issues.

    If it also always starts as administrator, which is the default, search service is disabled, slowly the search index will get useless. 

    And second, I could not setup a new Outlook profile, respectively I could set it up, but my Outlook could not connect to the information store afterwards... Disabling compatibility mode solved this issue.

    So, compatibitlity mode with Outlook should be used carefully.

    kind regards,

    Dieter Tontsch

    mobileX AG

    Monday, September 19, 2016 6:09 AM

All replies

  • Hi,

    The new email notification feature is based on the Windows you are using. Since Windows 8, the mail alert becomes a standard Windows 8 notification. The Delete, Flag and other options are gone, possibly because such things aren’t supported in Windows 8 notifications, the same goes for Windows 10.

    Regards,

    Steve Fan
    TechNet Community Support


    Please mark the reply as an answer if you find it is helpful.

    If you have feedback for TechNet Support, contact tnmff@microsoft.com.
    Friday, March 4, 2016 2:11 AM
  • Hi Steve,

    you might be right with your pessimistic assumption :-). I was hoping that by turning of app notification for Outlook 2016 from the OS, but keeping my Outlook-based new message alert pop-up, I could manage to return back to my old-fashioned alert handling. But unfortunately, for any reason, doing so, int results into the fact that I neither get Windows 10 app alerts, nor I get my Outlook pop-up anymore. But what I still see is the new message icon in the task-bar, which is an Outlook setting too.

    Well, it's not a tragedy, but in my opinion this instant deletion hability was a handy feature.

    Cheers,

    Dieter

    Friday, March 4, 2016 5:57 AM
  • Go to Outlook.exe which is typically in the C:\Program Files\Microsoft Office\Office16 folder.

    Right-click on the file, choose Properties, click on the Compatibility tab. Under Compatibiity Mode check the box to run the program in compatibility mode and choose Windows 7 from the dropdown. Apply. 

    (mic drop)
    Friday, September 2, 2016 8:59 PM
  • Brilliant!

    -Peter

    Friday, September 2, 2016 9:46 PM
  • Sounds nice, but unfortunatelly I do not have the compatibility tab for my outlook.exe. I call my Outlook from C:\Program Files (x86)\Microsoft Office\root\Office16\OUTLOOK.EXE (probably becasue I have installed 32bit version, but why root???)

    However, I have the tab for some other executables there like PPTICO.exe, or protocolhandler.exe, but it is missing for outlook.exe, powerpnt.ext, winword.exe... Any idea why?

    It it the ClickToRun install version

    kind regards,

    Dieter Tontsch

    mobileX AG

    Monday, September 12, 2016 4:18 PM
  • I had to set compatibility mode by following these instructions https://www.reddit.com/r/Windows10/comments/3lo4y9/compatibility_tab_missing_in_properties/

    Quite complicated, but it works if compatibility tab is not set.

    Thanks a lot jabrone

    Dieter

    Tuesday, September 13, 2016 5:46 AM
  • Hi, it is correct that when operating Oultook.exe in compatibility mode, this delete menu is working. but running Outlook in compatibility mode can cause some other issues.

    If it also always starts as administrator, which is the default, search service is disabled, slowly the search index will get useless. 

    And second, I could not setup a new Outlook profile, respectively I could set it up, but my Outlook could not connect to the information store afterwards... Disabling compatibility mode solved this issue.

    So, compatibitlity mode with Outlook should be used carefully.

    kind regards,

    Dieter Tontsch

    mobileX AG

    Monday, September 19, 2016 6:09 AM
  • This works!

    If you do not see a compatibility tab when you right click the outlook.exe file; follow these steps:

    1: Right Click the .exe file

    2: select troubleshoot compatibility

    3: Select troubleshoot program

    4: check off: "The program worked in earlier versions of Windows..."

    5: Select the latest version of windows this worked on (Windows 7, in my case)

    6:Select Test the program

    7: Click Next

    8: Restart Outlook

    9: You should be able to delete all incoming emails through the notification!

    Wednesday, October 26, 2016 5:43 PM
  • Yes it works, I had it working the same way. But overall I have to say, it causes more trouble than it helps. this deleting thing works that way, but becaus eof compatibility ode several other things cause troubles. Cannot remember exactely what anymore, but finally I ended up, removing the compatibility mode again

    Dieter

    Thursday, October 27, 2016 11:29 AM
  • Check this one out: https://answers.microsoft.com/en-us/windows/forum/apps_windows_10-outlook_mail/mail-notification-change/f8b6c126-419b-40fd-a131-0e38374f120a?auth=1 
    Wednesday, November 15, 2017 9:21 AM
  • Okay, I hope this answers your question as I was going through the same thing. I think what you want is for a delete icon to show up instead of the "set flag" icon, correct?

    Well if that is the case here is your answer:

    Open "Mail" on Win10

    Click the "settings" icon in the lower <g class="gr_ gr_230 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling multiReplace" data-gr-id="230" id="230">left hand</g> corner, by the <g class="gr_ gr_249 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del multiReplace" data-gr-id="249" id="249">calander</g> and people icons.

    Go to "quick actions"

    From that menu select the profile you want this to apply to (you will have to do it separately for each profile)

    Chance "swipe left/hover" to "delete"

    Now when a new e-mail comes in you will be able to delete it via the notification.

    Wednesday, December 13, 2017 11:21 PM
  • Hi,

    what you are explaining sounds nice, but I guess it does not apply on Outlook as a mail client. You refer to Mail, the new integrated Email-Program with Win10. This is not relevant for me, and was not the question, since we work with Outlook. But good to know.

    kind regards,

    Dieter Tontsch

    mobileX AG

    Thursday, December 14, 2017 9:52 AM
  • i want the delete button in the notification unfortunately no delete button. why windows don't provide a delete instead we need to open mail to delete an email. i don't understand whose idea not to add a delete button. 
    Thursday, March 28, 2019 9:50 PM
  • This works and it also addressed several other issues (like huge gaps for a touch interface), but unfortunately the licensing gets screwed up with it now.

    https://docs.microsoft.com/en-us/office/troubleshoot/activation/license-issue-when-start-office-application

    Forced back to non-compatibility mode.

    (Really disliking Windows 10.)

    Friday, January 10, 2020 12:53 AM
  • Thanks a lot Christopher. This worked for me.
    Wednesday, April 8, 2020 8:27 PM
  • For me, in French, with the bundled Windows 10's Mail/Outlook:

    - Go to Settings of Mail application (Paramètres)

    - Go to Messages list (liste des messages)

    - For the option "Swipe left/hover" or "Swipe right/hover", select "Delete" (Supprimer pour l'option "Balayage vers la droite/survol" ou "Balayage vers la gauche/survol").

    Misleading option's name for a desktop application...

    • Proposed as answer by ouechTonton Saturday, August 1, 2020 1:45 PM
    Saturday, August 1, 2020 1:45 PM