none
Display as "System Account", when regular users login RRS feed

  • Question

  • Hi,

    Sample: I'm login as "John Doe", but the profile on the top right show as "System Account". In the same page, i go to Site Settings and profile on the top right show as "John Doe" like the first step login, then back to Home and it worked. Users can't do this all the time when they login to SharePoint.

    Issue: I've this issue on SharePoint 2016, when user login with their own credential and it display as "System Account". On managed account /_admin/ManagedAccounts.aspx, i have registered 3 accounts with name SPFarm, SPService and Administrator

    Current Web Appplication Pool - Main Site - 80 managed by Administrator on /_admin/FarmCredentialManagement.aspx, i've tried to chaged every accounts on three of them but still when user login with their own credential, users reported always display as "System Account" or "SPService".

    Any solutions?

    Regards,
    Alu Ozy

    • Edited by Alu Ozy Monday, November 18, 2019 11:43 PM
    Monday, November 18, 2019 11:31 PM

Answers

  • Hi Grace,

    I've tried last step from this article link.

    And below step what i do:

    Go to IIS > right-click on Main Site > Manage Website > Advanced Settings > on Physical Path Credentials field changed from Specific User to Application User (pass-through authentication) and do IISRESET /NOFORCE.

    Current status is worked for me, thank you for your assistance Grace.

    Regards,
    Alu Ozy

    Friday, November 22, 2019 5:00 PM
  • Hi Alu,

    Thanks for providing your solution with us. Here I will provide a brief summary of this post for your information.

    [Display as "System Account", when regular users login]

    Environment

    ====================

    SharePoint 2016

    Question

    ====================

    when user login with their own credential but profile on the top right show as "System Account".

    Analysis (Solution)

    ====================

    Troubleshooting:

    Alu has tried change the application pool account but it issue still exits when user login with their own credential.

    Go to Central Administration->Manage web applications->select current web application->click User Policy in the ribbon, check all the accounts is not checked for “Account operates as System”.

    Check the web.config file <authentication> tag in the <system.web> node without setting other user account.

    Solution:

    Go to IIS > right-click on Main Site > Manage Website > Advanced Settings > on Physical Path Credentials field changed from Specific User to Application User (pass-through authentication) and do IISRESET /NOFORCE.

    Reference: All users are logged in as System Account

    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Best regards,

    Grace Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    • Marked as answer by Alu Ozy Wednesday, November 27, 2019 3:46 PM
    Wednesday, November 27, 2019 2:39 AM
    Moderator

All replies

  • Hi Alu,

    Go to Central Administration->Manage web applications->select current web application->click User Policy in the ribbon->find and click your account->Make sure the checkbox for “Account operates as System” is unticked.

    Best regards,

    Grace Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Tuesday, November 19, 2019 8:57 AM
    Moderator
  • Hi Grace,

    I've tried this TechPerspect Blog: All users are logged in as System Account but still not fixed.

    Administrator is not in the list, should i to add it?

    Above users is already unchecked for "Account operates as System".

    Regards,
    Alu Ozy

    • Edited by Alu Ozy Wednesday, November 20, 2019 3:35 AM updated
    Tuesday, November 19, 2019 9:07 AM
  • Hi Alu,

    It’s not necessary to add Administrator to User Policy.

    For your issue, check if your web.config looks like this in the <system.web> node:

    <authentication mode="Windows" />

        <identity impersonate="true" />

        <authorization>

          <allow users="*" />

    </authorization>

    Best regards,

    Grace Wang

    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Wednesday, November 20, 2019 8:22 AM
    Moderator
  • Hi Grace,

    Here is the details from web.config and CA.

    Regards,
    Alu Ozy

    • Edited by Alu Ozy Wednesday, November 20, 2019 9:10 AM
    Wednesday, November 20, 2019 9:03 AM
  • Hi Alu,

    From web.config file, it seems you have configured Forms-based authentication, but it’s not in the CA.

    Try to change to <authentication mode="Windows" /> and check if the issue exists.

    Best regards,

    Grace Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Thursday, November 21, 2019 9:52 AM
    Moderator
  • Hi Grace,

    I've tried last step from this article link.

    And below step what i do:

    Go to IIS > right-click on Main Site > Manage Website > Advanced Settings > on Physical Path Credentials field changed from Specific User to Application User (pass-through authentication) and do IISRESET /NOFORCE.

    Current status is worked for me, thank you for your assistance Grace.

    Regards,
    Alu Ozy

    Friday, November 22, 2019 5:00 PM
  • Hi Alu,

    I'm glad you have resolved your issue. And thanks for your sharing.

    You can mark your post as answer to help other community members to find the information quickly.

    Best regards,

    Grace Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Monday, November 25, 2019 1:22 AM
    Moderator
  • Hi Alu,

    Thanks for providing your solution with us. Here I will provide a brief summary of this post for your information.

    [Display as "System Account", when regular users login]

    Environment

    ====================

    SharePoint 2016

    Question

    ====================

    when user login with their own credential but profile on the top right show as "System Account".

    Analysis (Solution)

    ====================

    Troubleshooting:

    Alu has tried change the application pool account but it issue still exits when user login with their own credential.

    Go to Central Administration->Manage web applications->select current web application->click User Policy in the ribbon, check all the accounts is not checked for “Account operates as System”.

    Check the web.config file <authentication> tag in the <system.web> node without setting other user account.

    Solution:

    Go to IIS > right-click on Main Site > Manage Website > Advanced Settings > on Physical Path Credentials field changed from Specific User to Application User (pass-through authentication) and do IISRESET /NOFORCE.

    Reference: All users are logged in as System Account

    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Best regards,

    Grace Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    • Marked as answer by Alu Ozy Wednesday, November 27, 2019 3:46 PM
    Wednesday, November 27, 2019 2:39 AM
    Moderator