Unable to send Word document as attachment to an email


  • I have recently installed Microsoft Office Standard on my new laptap which runs Windows 7 Professional.  When i am in Word and trying to send the document as an email attachment, I received an error dialogue box with the message "Word couldn't send email because of MAPI failure: "Unspecified error"."  I clicked on the help button and have tried all the steps but no avail.

    The work around is to open Outlook and create an email with an attachment.  This works BUT I would like to be able to use Word as it was designed.  Anyone have a similar issue and suggested correction?


    Wednesday, February 15, 2012 8:41 PM


All replies

  • hi,

    I was able to repair the probelm by locating ‘fixmapi.exe’ in the C:\winnt\system32 or C:\windows\system32. Simply double-click Fixmapi.exe to repair.

    Alternatively, Open Control Panel, Add-Remove programs, locate Microsoft Office version X, Click on Change and initiate a repair of the installation.

    in addition these link will help you,

    hope this helps,


    • Marked as answer by Trish Thompson Sunday, February 19, 2012 7:45 PM
    Thursday, February 16, 2012 3:47 AM
  • Thank you so much.  With a little searching I was able to find the fixmapi.exe file.  When I clicked it nothing happened.  When I opened Word and tried to send the file it worked. 

    Thanks again,


    Trish Thompson

    Sunday, February 19, 2012 7:37 PM
  • I have brand new windows 7 64 bit Dell with Office 2010. But i I first noticed an issue when scanning with SnapScan and trying to send to email. It failed. Then I tried saving it and sending it to a mail recipient. Failed. Also when in a Word doc. I ge t the message "Word couldn't send mail because of MAPI failure: "Unspecified error".

    When I try to send a file from Excel the message reads "General mail failure. Quit Microsoft Excel, restart the mail system, and try again."

    I can of course start an email then attach a file BUT I SHOULDN'T HAVE TO!

    I have tried uninstalling Office and reinstalling. Nothing

    I have run the Office repair utility. Nothing

    I have run fixmapi.exe. Nothing

    I have made Outlook my default program and that I am running as administrator. Nothing

    I have checked that I have no compatibility check boxes checked. Nothing

    Does anybody have an answer for me?

    I have read of some techniques where you can remove the word 'fax' from all the lines in a certain file but I am not sure about that one.

    Thursday, October 18, 2012 4:12 AM
  • Have you tried going to Run services.msc and disabling Windows Search? Saw this solution on another post and it was reported to be a successful resolution. I have also found that it tends to work if the file is .docx or .xlsx instead of .doc or .xls.
    Wednesday, November 07, 2012 3:24 PM
  • Here is a simple solution sure to work.

    1. Start

    2. Search for Winword

    3. Right Click Winword and choose properties ( I instead would choose open file location just to know where the rest of windows programs can be found. Once there, right click Winword again and choose properties.

    4. Click compatabilty tab

    5. Check run as administrator at the bottom

    6. Apply

    7. Do the same for all Office programs If so desired (on the same file location where you found winword just look for Excel, Powerpoint, etc. and make sure the file you choose is an application type file)

    Jic, it is not obligatory to apply the above solution for to all Office programs. You can do it just to the ones you want to send email from. If you only need Word to have this functionality just do it for Winword and thats it.

    Sunday, December 09, 2012 1:32 AM
  • I have a similar situation that hopefully someone here will have the answer.

    I am currently using Windows 8 Mail App for receiving/sending mail.  It is very basic for now (quite surprising coming from Microsoft), but it works.  

    The problem is that Microsoft Excel/Word won't send an attachment directly from the software as it states that I don't have a mail program on my system.  When in fact, I do....

    How do I get Microsoft Excel/Word to recognize Mail App as my "Mail Program"?  Right now, I go to the Mail App and send the excel/word file from there.  I should be able to do that from the Excel/Word Software.



    Sunday, December 09, 2012 1:51 PM
  • Hi, I was recently experiencing a mapi failure in Word as well (I don't have Outlook - I use a Home/Student version).  Why would "run as administrator" be the solution?  Should the program Save&Send as Attachment work without having to change this setting?

    Tuesday, June 10, 2014 6:48 PM
  • I had the same error, i don't know why. I'll try sending it from outlook.

    Wednesday, October 28, 2015 11:30 PM
  • Getting these same errors on a Citrix server but only for some users not all. Have narrowed it down to RightFaxUtil installed on server and users clicking OK for it to be a default app but them not having any associated account on the fax server. Not sure what's set up on your local machines but suggest it might be worthwhile looking outside MS Office and instead at other apps that utilise MAPI for their functions.


    Tuesday, November 24, 2015 12:27 AM