Office 2007 saving .tmp files over VPN and WAN link


  • Several users occasionally report issues saving .ppt and .xlsx files over VPN or a WAN link (DS3).  The file appears to save, but when the user checks back later, the file has disappeared.  In its place is a .tmp file - named something like ADWEDG.tmp.  I'm usually able to change the extension from .tmp to .xlsx and the file will open.

    The users are running Windows7 and Office 2007.

    Several other folks have mentioned this issue in the forums, but I haven't seen an answer yet.


    Wednesday, February 16, 2011 3:36 PM

All replies

  • Hello,
    Thank you for your question.

    I am trying to involve someone familiar with this topic to further look at this issue. There might be some time delay. Appreciate your patience.
    Thank you for your understanding and support.

    Best Regards,

    Sally Tang
    TechNet Subscriber Support in forum
    If you have any feedback on our support, please contact  

    Thursday, February 17, 2011 9:15 AM
  • Hello,

    We have seen this issue with Office applications and mostly it is caused because of Antivirus software. Following is the kb article which provides information how Word application creates temp file during the process of Save.

    211632 Description of how Word creates temporary files;EN-US;211632

    I would suggest try disabling Antivirus software on both client and server side and see if you can repro the issue again. As you mentioned the .tmp file is there I think may be antivirus process is stopping Excel application to complete the save process.

    Regards!!! Navdeep Bawa
    • Marked as answer by Sally Tang Monday, February 21, 2011 3:59 AM
    • Unmarked as answer by David Wolters Thursday, December 08, 2011 3:34 PM
    Thursday, February 17, 2011 4:28 PM
  • Sally, please unmark this as answered, since it has NOT been answered. You've also marked another similar thread, which has also NOT been answered. Turning the antivirus off on the client and server is NOT an option.

    We all understand that Excel and Word create temp files. The problem is, in my case, that after closing Excel 2010 (on Windows 7), the file that was being edited is gone and only the .tmp file remains. And my client's computer is on the LAN, not using VPN.

    -- Henri
    Thursday, February 24, 2011 8:46 PM
  • If you google this issues, you will see that like me, thousands of people are having this same issue.  The only responses to the problem seem to be: well you must be running an add-in that is causing the problem, or, you must be running anti-virus that is causing the problem.

    Does anyone at Microsoft realize or care that this is a legitimate bug that needs attention? 

    It is amazing that someone would mark this off as solved.

    Monday, March 07, 2011 2:01 AM
  • Hello,

    I just wanted to note that I am having this issue as well.   Out of 50 users only one user seems to be affected.  It only occures on her computer, but it is fine in terminal services.

    Which would suggest it is a problem with her computer directly.   She is not connected via a VPN or slow wan link.

    (I found related article suggesting low bandwidth may be an issue)

    For the other people having this issue what version of Antivirus are you using?   While this doesn't seem like the answer I am willing to persue any option.

    We are using Symantec Endpoint Version 11.

    We are using Office 2007 with the latest service pack.


    Monday, March 07, 2011 2:16 AM
  • Same problem, only one user is experiencing this problem while all others are fine. The user is on the LAN, not VPN. The AV solution is the latest version (7) Trend Micro Worry-Free Business Advanced with patch. The problem machine is a new Dell Vostro T220 running Windows 7 Pro and Office Home & Business 2010. There's an identical machine in the office, along with a mix of Win XP, Vista, Office 2003 and Office 2007. Nobody else is having this problem.

    I am wondering, since most other reports seem to be VPN related, perhaps this user has a poor LAN connection, a bad cable or something like that.

    -- Henri
    • Proposed as answer by IT wHo'e Monday, March 21, 2011 5:19 PM
    • Unproposed as answer by IT wHo'e Monday, March 21, 2011 6:17 PM
    Monday, March 07, 2011 3:58 PM
  • Same problem, only one user is experiencing this problem while all others are fine. The user is on the LAN, not VPN. The AV solution is the latest version (7) Trend Micro Worry-Free Business Advanced with patch. The problem machine is a new Dell Vostro T220 running Windows 7 Pro and Office Home & Business 2010. There's an identical machine in the office, along with a mix of Win XP, Vista, Office 2003 and Office 2007. Nobody else is having this problem.

    I am wondering, since most other reports seem to be VPN related, perhaps this user has a poor LAN connection, a bad cable or something like that.

    -- Henri

    Considering that most reports of this issue are VPN related, I decided to investigate along the lines of poor network connection. Our I.S. department supports a few thousand PCs, and the only person I know of having this issue was on a split network outlet (RJ-11 to RJ-45) and possibly on CAT 3 cabling - it's gov't and hopefully they cut the cheque to re-wire the bldg this year!

    I then checked the link speed and duplex for the NIC and found that it had auto-negotiated to 100mbps full duplex. This will definitely produce poor network performance as that sort of botched wiring could only hope for 10mbps half duplex. I've made the necessary change, and although it will take a few weeks for me to confirm that this was the issue, I am hopeful that it is now resolved.

    Interestingly, in the early stages of the user reporting the issue, I asked the user to save a Desktop copy and work with that. They had the same problem, with a (no ~) .tmp file being saved to the Desktop each time the user manually saved. This could possibly be Excel attempting to reach the Documents folder which we have re-directed to a network share.

    It would really be nice if MS showed an interest in helping resolve these types of issues, instead of making a suggestion and then marking the thread as solved.

    Monday, March 21, 2011 6:04 PM
  • ... and the .tmp file does not have the expected ~*.tmp format

    It's just ????????.tmp - alphanumeric and all caps.
    Monday, March 21, 2011 6:13 PM
  • I had a user complaining of the same problems.  They were stating their files go missing and complaining that it was extremely slow to open files over the VPN in Excel.  I tested and found it was anywhere from 1-5 minutes for excel files via the VPN.  Excel would sit there and say "Processing" over and over and then finally download and open.  I went into the Trust Center in Office 2010 and told it to allow "Network Trusted Locations" I then added the shared drive mapping for my users files to the Trusted Zone"  upon doing this the files opened much faster and the "Processing" did not repeat like it was.  I was never able to duplicate the file issue the user was having but they told me the error has not occurred since I added their shared drive to a Trusted Location.

    Hope this Helps!

    • Proposed as answer by Ian Summers Friday, June 24, 2011 3:42 PM
    Friday, March 25, 2011 2:32 PM
  • We're having the same issue...Windows7 Office 2010. User gets 'locked for editing by ‘another satisfied Office9 user' even though there's only one user (the user trying to open the file) using the file.

    Sally, have you heard from you contact regarding this issue?

    Wednesday, April 13, 2011 11:03 PM
  • We are also experiencing this issue, using Microsoft Forefront AV.  I have had constant reports of this issue along with my own personal experience for months now.  This problem affects desktops that are constantly connected to the LAN as well as laptops.

    All of our machines sync profile folders to the network.  This does not appear to affect Windows XP clients, only Windows 7 clients.  My personal profile had over 30 of these .tmp files, and if you rename the file to .xls or .xlsx it opens with the file contents that were originally saved.  Most of our clients use Office 2007, I use Office 2010 and still experience the same issue. 

    Some users are reporting errors of "Excel cannot save the file."   Others (including myself) do not have the error popup but do have the .tmp files.

    With Microsoft Forefront AV, how can this be blamed on the antivirus software?  Pretty ridiculous answer if you ask me. We would appreciate a real solution from Microsoft on this issue. 

    Edit: I am a domain administrator, so permissions are not likely to be an issue in the case of my profile.


    2nd Edit: file names are in this format -- 46443475.tmp.  No '~' or '$' in the file name and they are not hidden files.
    Friday, June 24, 2011 2:51 PM
  • We had similar issues with office files not being saved successfully and only being left with TMP file versions.  We turned our antivirus option for scanning files on other computers OFF and the problem went away.  We further lab confirmed that without any antivirus on the machine there was not a problem but when antivirus was on the machine (with remote scanning enabled) the problem occurred.

    Our specific antivirus was Symantec Endpoint Protection Small Business.  We turned off the "scan files on remote computers" option.

    May we all make money in the sequel.
    Friday, June 24, 2011 6:02 PM
  • I have since concluded that this issue (original file being replaced with all caps 8 digit alphanumeric temp file e.g. 6JH37JHF.tmp) is a result of poor network performance and/or a timeout-to-write "feature" in Office 2010.

    Through exhaustive troubleshooting which included having the user work with local files only, re-imaging the PC, replacing the PC, moving the PC to another area/outlet, and finally having Networking re-re-wire the user's station (they got it wrong the first time) - the only steps that alleviated the issue were moving the PC to another network outlet, and the rewiring of the problematic location.

    As stated in my previous post, the affected user/pc continued to have this issue when asked to save and work from files on the Desktop. This seemed to rule out the network, but with re-directed folders being used (User's Documents folder) if Excel were to, for whatever reason, try to access that folder while saving... well... maybe Microsoft can shed some light on this for us?

    What I am certain of is that the network was responsible for the issue whether or not the file existed on the network, and this suggests that it is likely occuring as a result of a timeout - whether due to poor network access or file system access. This may lend credence to the Antivirus-at-fault statements, as they can inhibit efficient file access times - but if all other users (thousands of them in my case) with the same anti-virus software aren't having the issue, odds are that isn't the problem.

    Resultant of my experience, research and subsequent conclusions, I would suggest to those being affected by this to do some sort of stress test on the affected PC's network connection (if it is wireless, internet, or VPN based - I would assume that this is the cause.) Verify DNS settings, Link speed and duplex, number of collisions, and whatever else could possibly hinder or momentarily disrupt network throughput. Test whatever media the affected files are being saved to, as I strongly suspect that slow disk writes will have the same effect.

    Antivirus is just as likely a cause as is poor design on Microsoft's part... and the suggestion that is so often made by "Microsoft Professionals" to turn off your corporate Anti-virus software is just... well... I'll stop here.

    To those who have spent the money and are afflicted with this issue - good luck to you!

    To those who received the money and don't seem to care about this issue - shame on you!

    - RonSum
    • Proposed as answer by IT wHo'e Saturday, June 25, 2011 3:21 PM
    Friday, June 24, 2011 11:40 PM
  • We are also having this issue on our LAN.  I am in a school setting that just switched from a Novell environment to an all Microsoft environment (Server 2008 R2 servers and Windows 7 clients).  After the issues we have been having I would switch back in a heartbeat if I could but I digress.  Somewhere in researching this issue someone said it could be related to folder redirection so here are the settings that I think could pertain to this:

    Setting:                                                                                                Student:                                              Staff:
    Grant user exclusive rights                                                                  disabled                                               same
    Move contents to new location                                                            enabled                                               same
    Apply to XP  and older OS                                                                    disabled                                               same
    Do not automatically make available offline                                         not configured                                     enabled
    ‘at the server’                                                                                      only specified available offline             same

    As you can see everything is the same for Staff and Students except the “Do not automatically make redirected folders available offline”  but staff save ok and students quite often get a .tmp file when saving an Office file.  Also the student configuration is what Microsoft recommends.  We changed the staff because with some staff sharing computers we were filling the computer with CSC files (but that’s a whole different issue).

    As for VPN or WAN issues these are all on a Gig to the desktop wired network.

    Thursday, December 08, 2011 1:42 PM
  • Don't assume that having a gigabit connection makes it OK. Test that connection first. Do all the students share a common component, like the same switch? then test the switch and the connection from that switch to the rest of the LAN.
    -- Henri
    Thursday, December 08, 2011 4:02 PM
  • We have a core switch that all staff and student computers run to so yes it is a common switch but staff computers work.  I also haven't seen any problems when a staff member logs in to a student computer although that doesn't happen too often.
    Thursday, December 08, 2011 7:10 PM
  • We are seeing this issue too, however in our case it seems to be linked to when the file server is running very slowly following a failed backup job.

    We are running Windows 7 SP1 with Office 2010 (14.0.6023.100) redirecting Documents to a share on Windows Server 2008 R2.

    In many cases the TMP file is 0 Bytes, thus the work is lost.

    Allow me to spell that out: THIS BEHAVIOUR IS CAUSING USERS TO LOSE WORK.

    The symptoms seems to be an awfully lot like this one fixed in Vista SP1 apparently.

    Does anyone know of any recent hotfixes / configuration changes that we may make to eliminate this issue? My 800 users hotdesk across 320 PCs and laptops with around 90 - 250 logons/hr so folder redirection is a pre-req.


    Thursday, January 26, 2012 11:06 AM
  • One of the computers at my office is experiencing this same problem, and it happened rather suddenly. Antivirus software is Microsoft security essentials, and disabling real time protection to not fix the temp file creation. When I save any word file, it says there was an error reading the file being saved. When I check the location it was supposed to save to, there is a ADSF435.TMP file in its place.


    The computer is an old HP running Vista basic, but several of the other computers on the network are running the same setup.




    This is crazy! Microsoft, it looks like thousands of other people are having this problem!





    Thursday, January 26, 2012 1:50 PM
  • We were having the same problem but the root of the problem and the fix were very simple. It turns out that the staff had AD permissions that allowed them to create and modify files and folders but they could not delete anything. I fixed the AD permissions by adding the "modify" permission for staff to that folder and the problem stopped. It looks like MS Word creates temp files with the auto save every 10 minutes but if the logged in user cannot delete files in the folder they are working them the temp files just keep accumulating and getting saved with an alphanumeric name .tmp. I hope this is helpful to at least some of you.

    • Proposed as answer by Tony_Mac Thursday, April 05, 2012 6:02 PM
    Wednesday, February 08, 2012 6:51 PM
  • Having the same issues here.

    An advanced document I have imports csv files into a background sheet, they are manipulated, and saved back out to the network drive.

    What I don't quite understand is that the .tmp file is created and the original is seemingly REMOVED from the server. I get why it creates the tmp file, but nothing in my code touches the original, the general process (using the Scripting.FileSystemObject) is

    Open ******.csv

    Copy Cells

    Paste to Sheet(2)

    Close ******.csv

    At at this point, sometimes, the original file disappears. Quite a problem when the next/final step is

    Open ******.csv


    Save&Close ******.csv

    If it can't get the file, that's a big problem. I'm honestly considering rewriting the whole structure to run in access tables - even if it does mean an extra step of conversion going in and out of Access.

    THIS NEVER HAPPENED IN XP.... It's only the switch to Enterprise Win 7 & Office 2010 that's brought it about.

    Not Happy

    I should also point out that this is NOT over VPN or WAN... though we do have that functionality. It's happening on a wired LAN network!
    Friday, February 24, 2012 11:25 AM
  • We still see the problem occasionally.

    However it has almost entirely been eliminated. It was apparent that the issue occours most often when the fileserver was under heavy load and ping times started to exceed 80ms. This suggested that it was related to interactions with the offline files service, which is deeply integrated with smb/smb2.

    We took steps to reduce the load on the fileserver. Included disabling realtime scanninng by the Anti Virus Software.

    Furthermore we also installed all the hotfixes recommended in the comments section of this blog:

    and most of the hotfixes realting to Windows 7 performance from this blog:

    And updated Office 2010:

    Usual caveats apply with regard to hotfixes. Many of the above will install LDR version of components.

    Hope this is of use to some.

    Wednesday, April 04, 2012 9:58 AM
  • This is the best thread I have seen on this topic, as we have a number of individuals experiencing the problem as well, and I would like to thank all that contributed to this thread. 

    I am in a large enterprise environment, and latency for our remote sites seems to be part of the issue.  There are also WAN optimizers that stand between the clients and the file servers in some cases.

    Clients are Windows 7 Enterprise x86 running Office 2010.  I am in the process of ensuring that any affected machines have both Win7 SP1 and Office 2010 SP1 installed because I know that there a number of hotfixes that got rolled into those service packs (especially for SMB).  Interestingly, some customers also report problems saving other files (not MS Office files) to network shares as well.  In some cases, it works the second time they try to save it.

    A lot of companies have upgraded from Windows XP to Windows 7.  Let me shed some light on some differences that I have discovered based on troubleshooting and discussions with Microsoft Premier Support (anyone can jump in if I am mistaken on any of this).  The SMB client is completely re-written.  In fact, Windows XP has a single SMB driver (for SMB 1.0), whereas Windows Vista and 7 have two, and then a redirector that determines whether it is an SMB 1.0 or SMB 2.x communication (1.0 if the server is 2003, 2.x if the server is 2008/2008R2).  From tests that I have done in our environment (lots of DFS referrals, lots of servers/shares, lots of sites, etc.), SMB 1.0 communications for Windows 7 clients are slower than Windows XP.  Your mileage may vary.  I was also told by Microsoft that the TCP/IP stack was completely re-written, so when your Win7 clients behave differently from WinXP, do not be surprised.

    Good luck to all that have experienced this issue.  Based on the locations of individuals at our company experiencing the issue, I am inclined to agree with Nick Batchelor's assessment that it is likely a combination of high latency with Win 7 / Office 2010 that creates the recipe for the file-save issue.

    • Edited by joeweaver Thursday, December 06, 2012 6:29 PM missed a couple of words
    Thursday, December 06, 2012 4:07 PM
  • Joe, we came to the same conclusion.  Anything that adds latency increases the likelihood of the scenario.

    May we all make money in the sequel.

    Monday, December 31, 2012 4:58 PM
  • Hi,

    this week a customer noticed a similar problem, when keeping two computers in sync that are connected to a (embedded Linux) NAS system on a GBit LAN.

    Two workgroup computers have a folder redirection for "My Documents" to the same shared folder of a (embedded Linux) NAS system. Both computers use Offline Folders, so that the customer can work with one of the computers when she's abroad (but also in her home office).

    So when saving a Microsoft Office document, e. g. docx, the computer used to edit the file shows a .docx document, the other computer (same folder opened in Windows Explorer) shows a .tmp file.

    In the end both computers show a sync conflict ending up in resolving it on both computers - on both machine you have to look which tmp or docx file has the latest content.

    There are similar other threads, so I would like, where I think fits it best, so I'll add entries there to discuss this entry further.

    Thursday, January 10, 2013 9:47 PM
  • Hi Joe et al.

    I would strongly urge you to begin testing the hot fixes listed in the blogs above. I appreciate that you may be in an environment with strong change control constraints - but data loss ought to be a serious enough issue to get them through to at least a subset of your deployed user base. They really do improve the situation from the SP1 state.

    Since those articles were published there have been further TCPIP hotfixes which empirical evidence (and their own description) suggest improved performance can be got from clients and servers. More Client Side Cache and Shell32 improvements have also been released to address additional corruption and inconsistant views. These can be found by searching the KB for component file names and the windows7 sp1  build number (7601).

    Additionally the latest Office updates (which it appears are a standard recommendation in troubleshooting office data loss) are listed here:List of Office 2010 related hotfixes post SP1 for Office 2010 Service Pack 1.

    Finally I have recently become aware of the new tool by Mark Russinovich, psping, which can help testing and measurement of your networks' performance.  If you need to do side by side testing to justify hotfix deployment this tool should be useful.

    In our environment, from a client with a recent LDR tcpip.sys on a very quiet network (out of hours testing, no backups running) to a Server running sp1 RTM+WindowsUpdates I am mostly seeing 7.3 - 7.9 ms latency on a test using 8MB of data. However on one test run I saw a latency of 70.34ms.  

    Something I have not mentioned elsewhere is that on our desktop computers, inorder  to mitigate the impact of high latency we have increased the slow link mode transition to 300ms.

    Finally I would highly recommend Windows 7 Internal Volume 1. This book has proved in valuable in helping me understand the interdependencies of many of the windows components, and helped justify deployment of relatively untested LDR hotfixes to production servers and clients.

    Sunday, January 20, 2013 8:12 AM
  • Microsoft has now released a rollup with all the above mentioned hotfixes in one package:

    Thursday, March 14, 2013 12:37 PM
  • I don't know if I've got the same issue but could be.

    Client with Windows 7 SP1, Office 2010

    Server Windows 2003 on intranet LAN

    One user (I call "A") save correctly some docs (Word) on sharef folder "Direz" on server and it read correctly the folder content.

    Another user ("B") try to read the content folder and he finds only ########.tmp files.

    After some tests I found that User A has "OFFLINE files sync" enabled on "Direz" shared folder... uhm...

    I backup all files from "Direz" to a local folder (I don't want to loose some files)... and then on user pc (Win 7) through Control Panel > Sync > Manage offline files > DISABLE offline files .

    Restart the system

    Now "Direz" is not synced for offlines files and its content is the same for A user (like user B finds, only .tmp files).

    So I copied my "backup" files from local to the shared folder and now all users see everything ok and when user A save his files on shared folder everything is ok, file .tmps are out (where doc are closed and saved) and .doc are correctly saved.

    Hope this helps someone

    Ciao, Gianfranco

    Wednesday, October 02, 2013 8:30 AM