Office 2010 MAK auto activation


  • I've recently been working on auto activating a deployment of Office 2010 with multiple failures. I have used the OCT to configure the Office components I want installed which works correctly. Also the adding of a MAK key to the install works. 

    I started by just by adding the AUTO_ACTIVATE = 1 line under the Modifiy Setup Properties category. I've also tried adding various Post Install commands to the Add installations and run programs to call the ospp.vbs script to force auto activation. I've even tried adding a batch script to run post install through OCT. My account is a network account with local admin privileges and it seems to have made no difference. Whenever I run the ospp.vbs /act command or batch file manually, office activates with no errors. 

    Any assistance with this issue would be appreciated. Thanks.

    Friday, December 21, 2012 3:19 PM

All replies

  • Have you tried editing the config.xml?  The line below added to the config.xml might help you as long as the computers have an active internet connection.

    <Setting ID="AUTO_ACTIVATE" Value="1"/>

    Also, a reboot might cause a glitch in this process so don't force a reboot in your installation of office.

    Be kind and Mark as Answer if I helped.

    • Proposed as answer by Chris DeCarlo Monday, December 31, 2012 12:50 AM
    • Marked as answer by Max MengModerator Wednesday, January 02, 2013 5:00 AM
    • Unmarked as answer by cdsmithams Thursday, January 03, 2013 2:12 PM
    Monday, December 24, 2012 11:11 AM
  • I checked and that variable was already set. I do not force reboots.

    I have been able to activate manually as I said and a batch file works fine. I'm trying to figure out how to run the batch file after I install Office 2010 through SCCM2012.

    • Edited by cdsmithams Thursday, January 03, 2013 2:13 PM
    Thursday, January 03, 2013 2:12 PM
  • What?  Post your batch file if you want us to correct options in your batch file.  Also, you never mentioned SCCM 2012 so this almost sounds like a brand new question now with all these added bits.

    Be kind and Mark as Answer if I helped.

    Thursday, January 03, 2013 2:43 PM
  • Sorry I should have been a bit clearer. I've been hammering away at the autoactivation of Office 2010 for a couple weeks with no success. My end goal is to deploy it over SCCM2012 using the built in OCT for customization but so far not even a standalone install of Office will autoactivate. In one of my attempts I've used a batch file in the OCT for postinstall with no success. This batch file works fine when run manually after Office setup. This is the batch file contents for reference:

    @echo off & setLocal enabledelayedexpansion
    if exist "C:\Program Files\Microsoft Office\Office14\OSPP.VBS" (
     set PPATH="C:\Program Files\"
    ) else (
     set PPATH="C:\Program Files (x86)\"

    start "" C:\WINDOWS\system32\cscript.exe %PPATH%"Microsoft Office\Office14\OSPP.VBS" /act

    This is just one my many attempts at autoactivation.

    Sorry again for the confusion.

    • Edited by cdsmithams Thursday, January 03, 2013 3:27 PM
    Thursday, January 03, 2013 3:26 PM
  • OK I understand a bit better now.  So quick question, is the "custom.msp" file you created with the OCT stored in the Updates folder during installation?  

    Be kind and Mark as Answer if I helped.

    Thursday, January 03, 2013 4:07 PM
  • Yeah. Its the only file in the Updates folder and I've run the setup.exe by itself and with the /adminfile option.
    Thursday, January 03, 2013 7:51 PM
  • So, you're running the Office installation, and attempting to activate Office, via ConfigMgr?
    And that's executing as LocalSystem (the default)?

    Does your internet access/proxy require authentication to reach the MS activation server URLs?
    (If so, have you exempted that URL pattern from auth, or, authorised "Domain Computers" or "Authenticated Users" as permitted to access that URL?)(assuming you are using AD-authentication at your proxy, if any)

    Has the setup logfile for Office got anything useful to reveal about what was attempted and resulted?

    [if the setup is executing as LocalSystem then the logfile would be at something like 

    (Please take a moment to "Vote as Helpful" and/or "Mark as Answer", where applicable.
    This helps the community, keeps the forums tidy, and recognises useful contributions. Thanks!)

    • Edited by DonPick Friday, January 04, 2013 12:31 AM
    Thursday, January 03, 2013 11:57 PM
  • Ok, are you using a proxy server?  If so then maybe the CM2012 account that is pushing that activation script can't get through the proxy to the internet for the activation so see if you can run that script under the context of the user during logon or an account that can get through your proxy.

    Another option is to try having the script add the product key first and then run ACT just to see if that helps.

    cscript ospp.vbs /inpkey:xxxxx-xxxxx-xxxxx-xxxxx-xxxxx
    cscript ospp.vbs /act

    Oh also, in your batch file your paths are wrong where you have:

    "start "" C:\WINDOWS\system32\cscript.exe %PPATH%"Microsoft Office\Office14\OSPP.VBS" /act"

     I'm not sure what "Start "" is for one.  Two, you should use system variables so no matter where windows is installed it will resolve correctly such as %ProgramFile% for C:\ProgramFiles or %windir% for C:\Windows, etc.  Third you have it stating %PPATH%"Microsoft Office\..." the paranthesis should be before %PPATH% and look like this "%PPATH%Microsoft Office\..." otherwise it will almost assume its two locations.  

    Be kind and Mark as Answer if I helped.

    Friday, January 04, 2013 12:03 AM
  • Okay so its been a few days and I've done some testing. I have a copy of Office 2013 that I will be using later  but as a test I set up the install using that version of the OCT similar to 2010. The first thing I did was add the AUTO_ACTIVATE=1 setting then did a test install of 2013. 2013 auto activates with no issues and no errors on the same system I was doing my 2010 testing. Is there some unknown issue with 2010 that I'm missing? 

    As for the batch file, I've refined it using your suggestions Chris so it works correctly now and am attempting to call it through the OCT for 2010. I've placed it under Add Installations and Run Programs and the batch file itself is in the updates folder with the msp file. The line I attempt to call it with is:

    [post install]  \\amsfileserver\apps$\MSOffice2010\Updates\autoactivate.bat

    But it does not seem to run. Any further help would be appreciated.

    Friday, January 18, 2013 2:05 PM