Outlook 2007 - Attachment Save As Type only has - All Files will not save as the correct extension.


  • I'm saving a file from attachment on outlook and if we changed the file name the file will be missing the extension. 

    If someone sent a picture file or doc file and I changed the name the file will be unreadable unless I edit the file name.  The drop down option on the Save As option is missing the file type and it just has the "All Files" option anyway to enable the extensions.


    Thursday, December 02, 2010 12:32 AM

All replies

  • Hi,



    From your description , I understand that save as cannot extent in your Office 2007.

    All the default files and outlook just saves it using the same name and extension as on the message.

    Do you have Windows operating system set to hide the extensions for known file types? If so, show extensions and you'll see outlook is saving them as filename.doc.

    From windows explorer, Organize button, folder and search options.

    Look on the View tab for the option to hide known file types.




    Sunday, December 05, 2010 5:07 AM
  • Hi harry,

    Do you have Windows operating system set to hide the extensions for known file types? If so, show extensions and you'll see outlook is saving them as filename.doc.

    I tried it both ways. That was my first instinct but it didn't fix it.


    The issue is that the save as type will only have All file and not the type that the file is. Example I change the filename to abc then the extension doesn't reflect on the file.
    Tuesday, December 07, 2010 10:22 PM
  • anyone please help!
    Friday, December 17, 2010 6:08 PM
  • bump
    Tuesday, January 04, 2011 6:21 PM
  • We have the same problem.

    Using Windows 2008 R2 with Outlook 2007.

    Users wants to save a .pdf file but the file extension is missing.

    This problem exist also with office files.


    Any ideas are welcome....

    Wout Tigelaar Sr. Systems Engineer
    Friday, May 13, 2011 4:48 AM
  • Bump!  Exact same problem here.



    Attachment  doc1.pdf shows up as that in the email.  Right click, save as, now shows as doc1 (no extension) and file type shows as All Files with no other option to select.


    Same thing happens with .doc, .wpd, .wav, etc


    User is running Win 7 w/Outlook 2007.  Does not happen on all users with the same setup.  Help would be appreciated!

    Friday, October 07, 2011 1:15 PM
  • for what it's worth, we have the same issue.  

    google-fu seems to just lead to people wth the issue, and no idea on cause.


    Wednesday, November 23, 2011 5:18 AM
  • Same issue here, saving a file from an outlook message saves it without an extension.  I then have to manually navigate to that file and add the extension (e.g., ".pdf") so that Windows knows how to treat the file.

    The issue is NOT that file extensions are hidden.  The saved file is not saved with an extension.

    Friday, December 30, 2011 11:23 PM
  • I figured out how to fix this issue. I completely uninstalled the program and reinstalled it with sp1. 
    Friday, December 30, 2011 11:25 PM
  • On Windows XP SP3, with Microsoft Outlook 2007 (Dutch version), I have the same problem.

    What version did you have installed before?


    Monday, January 07, 2013 4:42 PM
  • Hi I have also same problem ...useing windows 7 Pro with Outlook 2007 !! Plz Help if you have good Solutionfor it .

    Wednesday, November 12, 2014 7:19 AM
  • Same issue here as well. The file attached to the email clearly says .docx but when saved (save as) the file extensions disappears.

    Please suggest solutions
    Sunday, October 04, 2015 6:28 PM
  • Hi everyone, I've found the solution. All you need to do is update to SP3 and install the compatibility pack. 

    !important: install the one bellow after the one above!

    Hope this will help you. Could not find a solution all over the internet!

    • Proposed as answer by nickbazie Friday, June 16, 2017 11:35 AM
    Friday, June 16, 2017 11:04 AM