locked
Turn off AutoComplete in OWA

    Question

  •  Hello,
    I know how to turn off the AutoComplete (Suggest names) option from
    group policy for Outlook. Is there a way to do this for Outlook Web
    Access?

    Thanks!
    Steve D
    Monday, January 12, 2009 3:34 PM

Answers

  • Issue description: How to disable “Auto Complete” feature via OWA?


    I assume that your exchange version is 2007, since exchange 2003 doesn’t have “Auto Complete” function on OWA

    Explanation: The e-mail list is saved in users’ mailboxes, it is loaded when user click the “New” to compose messages. The function is by design, it can't be disabled per my knowledge

    The only available option is to delete e-mail entries:

    1.       Delete an entry from the list using OWA

    a.       Login to mailbox via OWA

    b.      Create a new meeting request

    c.       Begin typing the entry you want to delete until you see it in the Auto Complete list

    d.      To remove one entry from the list, highlight the name in the Auto Complete list, arrow up and arrow down allow you to highlight the name you want to remove

    e.      When the entry is highlighted, press the Delete button on your keyboard

    2.       Delete the entire list using OWA Light

    a.       Log in to mailbox using Outlook Web Access Light

    b.      Go to Options -> Messaging

    c.       Under Email Name Resolution, click "Clear Most Recent Recipients List"

    3.       Delete the cache entries from the mailbox with MFCMAPI

    a.       Launch MFCMAPI on a PC where it has user’s mail profile that is not configured for Exchange Cached Mode from Outlook.

    b.      “Session” menu->choose “Logon and Display Store Table”->choose mail profile in jumped window

    c.       On the top-pane, double-click user’s mailbox and go to next window

    d.      In the next window->right-click “Root Container”-> select “Open Associated Content Table”

    e.      Scroll until you see the “Message Class” column. Right-click on the IPM.Configuration.Owa.AutocompleteCache entry and select “Delete Message”.

    f.        In the “Delete Item” window select "Permanent delete passing DELETE_HARD_DELETE (unrecoverable)" from the deletion style drop down box, and click OK. This will permanently delete this message.

    Notes: It won’t prevent e-mail addresses from caching again in the future

    • Proposed as answer by Alan.Gim Thursday, January 15, 2009 1:13 AM
    • Marked as answer by Steve Detwiler Friday, January 16, 2009 3:10 PM
    Wednesday, January 14, 2009 2:38 AM

All replies

  • Issue description: How to disable “Auto Complete” feature via OWA?


    I assume that your exchange version is 2007, since exchange 2003 doesn’t have “Auto Complete” function on OWA

    Explanation: The e-mail list is saved in users’ mailboxes, it is loaded when user click the “New” to compose messages. The function is by design, it can't be disabled per my knowledge

    The only available option is to delete e-mail entries:

    1.       Delete an entry from the list using OWA

    a.       Login to mailbox via OWA

    b.      Create a new meeting request

    c.       Begin typing the entry you want to delete until you see it in the Auto Complete list

    d.      To remove one entry from the list, highlight the name in the Auto Complete list, arrow up and arrow down allow you to highlight the name you want to remove

    e.      When the entry is highlighted, press the Delete button on your keyboard

    2.       Delete the entire list using OWA Light

    a.       Log in to mailbox using Outlook Web Access Light

    b.      Go to Options -> Messaging

    c.       Under Email Name Resolution, click "Clear Most Recent Recipients List"

    3.       Delete the cache entries from the mailbox with MFCMAPI

    a.       Launch MFCMAPI on a PC where it has user’s mail profile that is not configured for Exchange Cached Mode from Outlook.

    b.      “Session” menu->choose “Logon and Display Store Table”->choose mail profile in jumped window

    c.       On the top-pane, double-click user’s mailbox and go to next window

    d.      In the next window->right-click “Root Container”-> select “Open Associated Content Table”

    e.      Scroll until you see the “Message Class” column. Right-click on the IPM.Configuration.Owa.AutocompleteCache entry and select “Delete Message”.

    f.        In the “Delete Item” window select "Permanent delete passing DELETE_HARD_DELETE (unrecoverable)" from the deletion style drop down box, and click OK. This will permanently delete this message.

    Notes: It won’t prevent e-mail addresses from caching again in the future

    • Proposed as answer by Alan.Gim Thursday, January 15, 2009 1:13 AM
    • Marked as answer by Steve Detwiler Friday, January 16, 2009 3:10 PM
    Wednesday, January 14, 2009 2:38 AM
  • Thanks for the info.  Wish it could be turned off, but not a big deal.
    Friday, January 16, 2009 3:10 PM
  • J
    Monday, January 19, 2009 12:59 AM
  • The stepts outlined by James-Luo work great to remove a cached e-mail address in OWA 2010. Strangely enough it won't work when creating a new e-mail message and trying to hit delete, but it does work when creating a new meeting. Thanks for sharing this useful piece of information!
    Sunday, December 20, 2009 8:59 PM
  • Can that be done through PowerShell, i have about thousand users, with the same problem…

    Wednesday, January 23, 2013 7:59 AM
  • Can I disable the  OWA "Auto Complete" for all users by using powershell ?
    Wednesday, July 09, 2014 4:27 PM
  • Possible solution: Try this

    Tuesday, June 14, 2016 1:01 PM