none
Outlook 2010 search not working RRS feed

  • Question

  • I'm used to this happening on occasion where I need to re-index email but today I've had 10+ people come over and say that their Outlook search results are no accurate or it's coming up with nothing. Anyone else notice this?

    It's happening to one client that uses Outlook 2010 (Gmail sync) and I've also had a number of people complain from a different office where they use Outlook 2016 (POP mail).

    I wonder if it's related to any recent Windows Updates that may have been released.



    • Edited by pstoric Wednesday, June 14, 2017 6:59 PM
    Wednesday, June 14, 2017 6:43 PM

All replies

  • I'm having the same issue reported with Outlook 2010 (G sync). Tried rebuilding the indexing and still didn't fix issue. 
    Wednesday, June 14, 2017 7:20 PM
  • Yea I've done that and also mad some new Outlook profiles. Only time will tell if the new Outlook profiles do the trick but I know re-indexing did not fix it 100%. Not not sure what else to do. Usually I do the following in this order

    -re-index

    -create new outlook profile

    -check windows search service

    I've posted on Reddit and got one reply:

    "I've got one user that reported this error today using Outlook 2007.

    We tried...

    • Rebuilding the index
    • Repairing Office
    • Recreating her Outlook profile
    • Reinstalling the Windows Search service
    • Disabling all add-ins

    None worked.

    Couple things I've noted...

    • Running Outlook in safe mode yields good searches, but working through the add-ins or turning off the reading pane in normal mode do nothing

    • Searching via the Start Menu still works, so it's definitely something in Outlook and not the index itself

    We ran out of time to try more but will attempt reinstalling Office at a later time. May not be the same issue are you, but I hope it helps."

    Wednesday, June 14, 2017 7:25 PM
  • same issue, checked the update history and there was a wack load of updates this morning installed. 

    Outlook search does not filter the results, basically the results is showing the inbox.

    rebuilt index, nothing

    uninstalled Office 2010, nothing

    didn't delete the .pst file and rebuild via GAS


    Wednesday, June 14, 2017 9:32 PM
  • Same issue on Win 7, Outlook 2010 client.  Everything was fine until the updates below were installed.  Will complete a  restore shortly after the user has left for the day.  The weird thing I noticed, is that your search term is highlighted within the emails, but the email search results are not culled. 

    Security Update for Microsoft Office 2010 (KB320346,1] 32-Bit Edition
    Security Update for Microsoft Office 2010 (KB3191908] 32-Bit Edition
    Security Update for Microsoft Outlook 2010 (KB3203467] 32-Bit Edition
    Security Update for Microsoft Silverlight (KB4023307]
    Windows Malicious Software Removal Tool x64 - June 2017 (KB890830)
    Security Update for Microsoft Office 2010 (KB3191844) 32-Bit Edition
    2017-06 Security Monthly Quality Roll up for Windows 7 for x64-based Syst ems (KB4022719)
    Security Update for Microsoft Office 2010 (KB3118389) 32-Bit Edition
    Security Update for Microsoft Word 2010 (KB3203464) 32-Bit Edit ion
    Security Update for Micrornft Offic e 2010 (KB3203460] 32-Bit Edition


    Wednesday, June 14, 2017 11:13 PM
  • Thanks for the details. Going to check some effected machines for those KB's now.
    • Proposed as answer by TiTusTiTus Thursday, June 15, 2017 7:12 AM
    • Unproposed as answer by TiTusTiTus Thursday, June 15, 2017 7:13 AM
    Thursday, June 15, 2017 12:07 AM
  • So I decided to uninstall the KBs one at a time and checked to see if it had any effect.  Uninstalling the following finally worked.  Unfortunately once you remove the update the index starts to rebuild itself.  Which is not really a bad thing, but in my case we're talking about 70k+ emails for each user affected.  So its going to take a while.

    2017-06 Security Monthly Quality Roll up for Windows 7 for x64-based Syst ems (KB4022719)

    • Proposed as answer by TiTusTiTus Thursday, June 15, 2017 7:13 AM
    • Unproposed as answer by TiTusTiTus Thursday, June 15, 2017 5:05 PM
    Thursday, June 15, 2017 7:13 AM
  • Update...Removing KB4022719 seems to have a worse effect as now searching in Outlook yields not results. Any input form Microsoft on here?

    TiTusTitus, were you able to resolve?

    • Edited by pstoric Thursday, June 15, 2017 1:42 PM
    Thursday, June 15, 2017 1:31 PM
  • Just had a Windows 10 user apply updates and reboot. Outlook 2010 search not functioning now....
    Thursday, June 15, 2017 2:12 PM
  • Same issue. PCs running Win7 and 8 seem to be affected. No Results yield even after re-indexing their gigantic .pst files.
    Thursday, June 15, 2017 2:34 PM
  • We are running into same problem in our office after recent update. Any suggestions for a fix?
    Thursday, June 15, 2017 2:55 PM
  • With Outlook Open... do START > "Indexing Options" > MODIFY > Uncheck Outlook > OK to everything to close Indexing windows.

    Close Outlook.

    Open Outlook.

    START > "Indexing Options" > MODIFY > Check Outlook (and C:\ if it's unchecked) > OK to everything to close Indexing windows. 

    You can test a search immediately in Outlook.  It will be slow, but it should rebuild OK.

    From Ryan Madej over at spiceworks.

    This Worked for me. 

    Thursday, June 15, 2017 3:12 PM
  • Thanks StormArmageddon, not a perfect solution but search function mostly working as was.  Again Thanks
    • Proposed as answer by Billw62 Wednesday, October 11, 2017 4:22 PM
    Thursday, June 15, 2017 3:37 PM
  • I too came across this issue. Rebuilding the index did not help. Went back to basics and uninstalled/reinstalled Office 2010. Worked perfectly. Makes sense too. The search index is within Outlook so it will get a fresh start upon reinstall.

    Hope that helps.

    Thursday, June 15, 2017 3:52 PM
  • that did not work for us.
    Thursday, June 15, 2017 4:30 PM
  • Also A System Restore prior to 6/13/207 also seems to work.

    Thursday, June 15, 2017 8:14 PM
  • I have the same problem, did you were able to find the solution?
    Thursday, June 15, 2017 8:22 PM
  • We have also been seeing this issues affecting Outlook 2010 on both Windows 7 and 10 machines. I have showed a few users how to patch it on a temporary basis but once outlook is restarted we atre in the same boat. Does not seem to be affecting Office 2013 or office 2016.

    Has anyone seen anything from Microsoft on this issue and if they are looking at it. Seems like they made changes in one of the updates on how the OS indexing interacts with applications.

    Rob Tieman

    Friday, June 16, 2017 2:12 PM
  • I used StormArmageddon's solution yesterday and fixed the issue but this morning the problem is back. If we do a system restore will the issue be back on the next update?

    *Edit* My customer informed me that the issue is happening only for user that uses GSSMO (G Suite Sync for Microsoft Outlook)


    • Edited by David P P Friday, June 16, 2017 3:40 PM
    Friday, June 16, 2017 2:20 PM
  • The "fix" will only work until outlook is closed. 

    You have to do it again every time they close outlook :-\ 

    Friday, June 16, 2017 4:04 PM
  • From Google:

    Although the GSSMO tool allows you to set up a sync to Outlook however we do not support any issues tied to Outlook itself like the searching of data within the mail client.
    With this in mind I would advise reaching out to Outlooks support directly to query this with them directly.

    Friday, June 16, 2017 6:14 PM
  • Workaround:

    With Outlook Open... do START > "Indexing Options" > MODIFY > Uncheck Outlook > OK to everything to close Indexing windows.

    Close Outlook.

    Open Outlook.

    START > "Indexing Options" > MODIFY > Check Outlook (and C:\ if it's unchecked) > OK to everything to close Indexing windows. 


    • Proposed as answer by cslee03027 Thursday, July 27, 2017 4:21 AM
    Monday, June 19, 2017 4:08 PM
  • Also having this issue, over 50 users reporting it now this week.  All on Office 2010, Windows 7 systems, on-premises Exchange 2007 server.  I've already tried all the usual tips (rebuild index, create new profile, etc.) without success.

    Have been telling them to "sit tight and wait for a patch from Microsoft", which doesn't go over very well.  Hope they respond soon!  :-(


    • Edited by Mike442 Monday, June 19, 2017 7:49 PM
    Monday, June 19, 2017 7:47 PM
  • remove:

    KB3191898 for Outlook 2007 Users

    KB3203467 for Outlook 2010 Users

    KB3191938 for Outlook 2013 Users

    and re-index e-mail

    Tuesday, June 20, 2017 8:23 AM
  • Same thing here. Affecting Windows 7, Windows 10 , Outlook 2007 and Outlook 2010! 

    Search doesn't work and re-indexing make no difference! Is there any official reply on this case from Microsoft?! I bet they did it to back stab people who are using G Suite and also to force them to upgrade to latest Office 2016!

    Did anyone try A.Serkan solution? Does it actually work?... we have like dozens super angry customers atm. We simply cannot just keep trying different things?!

    Tuesday, June 20, 2017 9:43 AM
  • Same here... users are adding up on the "I cannot find my emails" or even worse "i've lost my emails" queue. Still haven't managed to find a successful workaround.
    Tuesday, June 20, 2017 11:23 AM
  • For my client the workaround is the following (Windows 10 + Office 2010):

    • Uninstall KB3203467
    • Reboot machine
    • Start Outlook
    • Open "Indexing Options" from control panel (or do: rundll32.exe shell32.dll,Control_RunDLL srchadmin.dll from "Run" command.)
    • Disable Outlook indexing by selecting "Modify" and deselecting Outlook and apply the changes
    • Restart Outlook

    If you re-enable the indexing again for Outlook, like some are saying, the issue returns. For now leave it disabled until MS comes with a proper fix. Searching works, although it can be somewhat slower.


    • Edited by TechKr Tuesday, June 20, 2017 11:51 AM
    Tuesday, June 20, 2017 11:50 AM
  • Used that one too (TechKr) for one of the users. The user has over 27k of emails stored in over 20 folders. Searching in all outlook items is counterproductive, and asking the user to search to a specific folder (for faster results) almost started a revolution! There also seems to be a connection with the recent KB4022725. Still since others reported its removal to cause more problems than help, im staying away from that workaround. Repairig outlook, rebuilding the index, restarting the indexing service, also didn't work.
    • Edited by tsouvalasi Tuesday, June 20, 2017 12:37 PM
    Tuesday, June 20, 2017 12:36 PM
  • This worked for me; thanks for posting this.
    Tuesday, June 20, 2017 1:26 PM
  • Before I came to this, I tried the following also without resolution:

    • Removed and readded shared (cached) mailboxes
    • Repaired the Office 2010 installation through setup
    • Completely removed the Outlook profile and recreated it again
    • Rebuild the indexing

    Until now, the only thing that works is to disable the indexing, and I know this is not nice on large mailboxes (like my client also has), but it is better than nothing I guess. Waiting for a quick solution from Microsoft....

    I find it odd though that Microsoft does not speak of the search issue on their support page at all (https://support.office.com/en-us/article/You-receive-an-error-when-opening-attachments-in-Outlook-3f6dbffd-8505-492d-b19f-b3b89369ed9b?ui=en-US&rs=en-US&ad=US) They only speak of the attachment problem.

    Any clarification Microsoft? Does anyone has more information about this?

    Tuesday, June 20, 2017 1:32 PM
  • Thank you so much StormArmageddon - this issue was driving me nuts but the fix worked for me.  Disappointed Microsoft didn't offer this simple fix on any of their official help sites :(
    Tuesday, June 20, 2017 2:46 PM
  • I'm getting the same issue on Office 2016 Windows 10 with all the updates as of yesterday.

    Issue started about a week ago. I have tried rebuilding all the indexes and did a repair on all my .pst files and still nothing.

    I have not tried any of the above suggestions as of yet but will. 

    Anyone else getting this on 2016 and resolved the issue?


    Tuesday, June 20, 2017 3:04 PM
  • I can confirm that disabling indexing on Outlook works.   Very slow searching now that the file is not indexed but functional.

    The process for me was open Outlook, click on search window, then go into tools, indexing options, modify and took check out of box by Outlook.    

    This is for Outlook 2010

    • Edited by Dundlefutz Tuesday, June 20, 2017 5:03 PM
    Tuesday, June 20, 2017 5:00 PM
  • Experienced the same issue with the following configuration:

    OS: Windows 7 Professional/Ultimate
    E-mail Client: Outlook 2010 32bit
    E-mail Host: Google (G Suite)

    Work-a-round involved the following items:

    1. Removal/Hide KB4022719
    2. Removal/Hide all related Outlook updates from last weeks Patch Tuesday.
    3. Rebuild index

    So far, user is able to utilize instant search and indexed items are decreasing as expected.  If anyone receives permanent patch please note.

    Tuesday, June 20, 2017 7:02 PM
  • I'm used to this happening on occasion where I need to re-index email but today I've had 10+ people come over and say that their Outlook search results are no accurate or it's coming up with nothing. Anyone else notice this?

    It's happening to one client that uses Outlook 2010 (Gmail sync) and I've also had a number of people complain from a different office where they use Outlook 2016 (POP mail).

    I wonder if it's related to any recent Windows Updates that may have been released.



    We're having the same issue. Search does not work in 2010 after index rebuild, but it does seem to work in 2016 after index rebuild. I tried the GApps v 3.8, and the current GSSM v4. 

    I tried StormArmageddon's solution, but the user left for the day, we'll just have to continue tomorrow.

    Uninstalling KB4022719 is not an option, since it's part of security update. I'd rather lose search than not having latest security update.


    Wednesday, June 21, 2017 12:18 AM
  • Same as my company when updated the following security updated at 15th Jun,2017. User unabled to search the recent email and the indexing always prompted had a lot of email searching three days long. And some of normal attachments will be block in the unsafe mode and unable to open.Hope Microsoft resolve these problem ASAP.

    Affected system: Win7 and Win10, installed outlook2010.  Outlook2013 not affected.

    - Security Update for Microsoft Office 2010 (KB3203460) 32-Bit Edition
    - Security Update for Microsoft Word 2010 (KB3203464) 32-Bit Edition
    - Security Update for Microsoft Office 2010 (KB3118389) 32-Bit Edition
    - 2017-06 適用於 Windows 7,x64 架構系統的每月安全性品質彙總套件 (KB4022719)
    - Security Update for Microsoft Office 2010 (KB3191844) 32-Bit Edition
    - Windows Malicious Software Removal Tool x64 - June 2017 (KB890830)
    - Security Update for Microsoft Outlook 2010 (KB3203467) 32-Bit Edition
    - Security Update for Microsoft Office 2010 (KB3191908) 32-Bit Edition
    - Security Update for Microsoft Office 2010 (KB3203461) 32-Bit Edition


    • Edited by unipecasia Wednesday, June 21, 2017 3:54 AM
    Wednesday, June 21, 2017 3:45 AM
  • Experienced the same issue with the following configuration:

    OS: Windows 7 Professional/Ultimate
    E-mail Client: Outlook 2010 32bit
    E-mail Host: Google (G Suite)

    Work-a-round involved the following items:

    1. Removal/Hide KB4022719
    2. Removal/Hide all related Outlook updates from last weeks Patch Tuesday.
    3. Rebuild index

    So far, user is able to utilize instant search and indexed items are decreasing as expected.  If anyone receives permanent patch please note.

    Dear Scooter, thank you for taking the time to share your solution. Users are about to crucify me if i don't offer them a solution, still though removing all of the updates is somewhat of an overkill don't you think? Could it be only the two updates: KB3203467 and KB4022719 enough to do the job? I just have to mention here that Email host is irrelevant of the actual problem.
    Wednesday, June 21, 2017 10:10 AM
  • This Outlook 2010 search issue is affecting all of my company's computers in the office (20+ machines).

    • OS: Windows 7 64-bit
    • Email Client: Office (Outlook) 2010 32-bit
    • Email Host: Network Solutions
    • Outlook search indexing never finishes, and new emails are not searchable. This began with the patch Tuesday updates for June 2017

    On one machine I was able to get search functionality restored (without indexing, so slower getting results) by removing KB4022719 and KB2553308, restarting and then re-indexing . I approved both updates for removal in WSUS, they should be uninstalled on all clients this evening. It would be great if this fairly major problem was addressed with the next batch of updates.


    • Edited by AWaugh Wednesday, June 21, 2017 2:29 PM spacing
    Wednesday, June 21, 2017 2:28 PM
  • There was only about 3 Outlook specific updates which were installed from last week.  I'm sure you could disable each update and run a Rebuild Index after each one.

    One thing I did to verify that indexing was working properly, is wait for the first decrease in number of items to index, and run a search for a simple word like "the"  If the items appeared instantly, I knew indexing was working versus if it slowly crawled through the e-mails.

    Other individuals decided to utilize Web Access for search features and leave the update in place for security purposes.

    Wednesday, June 21, 2017 5:09 PM
  • I have only seen it thus far on Outlook 2010 on Win 7 and Win 10.  I have limited number of 2016 Outlook users and they have not yet reported the issue.  All are on Googles Outlook sync
    Wednesday, June 21, 2017 7:11 PM
  • Same issue on multiple computers , will try to remove the update and rebuild the indexing
    Wednesday, June 21, 2017 8:00 PM
  • has anyone come across this issue since the june updates. Users using word 2010 on windows 7 64bit cannot save certain documents. They click the save button or save as butoon and it does not save or bring up the save as dialogue box to choose location??
    Wednesday, June 21, 2017 8:06 PM
  • Can't believe there has been no permanent fix for this yet... 
    Thursday, June 22, 2017 12:17 AM
  • I've got 40+ people with Outlook 2010 on Win Pro 7,8,10 with the same problems.  We do not use any Google Docs, Suite, or Sync.  I can confirm that removing KB3203467 ONLY fixes the unnecessarily blocked email attachments and has no affect on the broken indexing.  I will be using System Restore on an affected users computer, then re-installing updates one by one, testing between each one until I find the cause.  What a colossal waste of my time. Thanks Microsoft.  
    Thursday, June 22, 2017 1:41 AM
  • Hi,

    Thank you all for reporting this and sharing the details. The following is an official page of all the known issues that have been reported after installing the recent updates:

    https://support.office.com/en-us/article/Outlook-known-issues-in-the-June-2017-security-updates-3f6dbffd-8505-492d-b19f-b3b89369ed9b?ui=en-US&rs=en-US&ad=US

    Regarding the search issue in Outlook, it affects all Outlook versions on Windows 7, Windows 8, Windows 10.

    The workaround that we recommended is to set a registry key that will cause Outlook to stop using the local Windows Search service.  When this registry key is set, Outlook will use its own built-in search engine.

    If there is anything new, I will update here. Thank you all for your great understanding.

    Regards,

    Ethan Hua


    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, June 22, 2017 3:24 AM
    Moderator
  • I have the same issue. Approx. 30 PCs with Windows 10 and Microsoft Office 2010 Home and Business with Google App Sync/G-Sync Suite. Last week’s (middle of June, 2017) updates brought some mess. Problems with INDEXING (Search) in Outlook. SEARCH only highlights your searching tag in a whole mail list, but do not filter appropriate objects. E.g. you need manually scroll down all mail list to find what you searching for.

    Nothing could fix this. Tried different solutions many times providing with close/reopen/reboot application and Windows every time:

    -Scanpst

    -Check/uncheck Microsoft Outlook modules in Indexing Modify options

    -Rebuilding index. Apparently Windows rebuilds index normally, but do not see Outlook mail objects.

    Tip: If cannot Rebuild Index (or it rebuilds very fast (less than a minute), can help Disable Windows Search service – Reboot PC – Enable the service again (to Automatic Delayed Start) - than start Rebuilding again. It takes some hours to finish.

    PC without June updates work good.

    Additional problem is that Outlook 2010 after June updates started to block attachments with a dot in the end of a name. For example, files like testfile..xlsx  are permanently blocked. Probably because of TWO dots before extension. And playing with registry workaround (Level1Remove) does not help. The only way to restore those files – download it from Mail Service Web account connected to the Outlook.

    It looks like Outlook 2016 NOT affected by both problems. Well.. Nice try to sell new software.

    The only workaround I have found is to exclude Microsoft Outlook 2010 pst file from Indexing. This way you will search mails every time newly. That is much slower. But if you have SSD drive – it will be faster.

    We waiting for patches from MS.


    • Edited by EugeneGr Thursday, June 22, 2017 1:21 PM
    Thursday, June 22, 2017 1:18 PM
  • I have Microsoft Office Professional Plus 2013 on Windows 7 and suddenly had Outlook Instant Search problems -- it wouldn't find results that were definitely there, would only find old search results, would hang without finding anything and the search box couldn't be x'd out, I would have to switch folders... and the weirdest problem was that when it did find results, if I deleted one, it wouldn't go away!  I noticed Outlook was no longer enabled in Control Panel > Indexing Options; I tried repairing Office which restored it to the Indexing Options, and rebuilt the Index, but nothing helped.  Finally I removed the update KB4022719, and after giving Outlook time to re-index, all my search functionality is back! 
    Thursday, June 22, 2017 2:11 PM
  • The link above refers to the registry key:

    Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Windows Search

    But none of my clients have this key.  Over 100 desktops, Win7, mixed Office 2010/2013 32b environment.  

    Was hoping to deploy this fix with a GPO until the patch comes out.  Why doesnt everyone have the key you refer to?

    P.S. I can confirm manually removing Outlook indexing from WDS fixes the problem, albeit with a performance penalty.

    Thursday, June 22, 2017 5:45 PM
  • Looks like patch will be issued on 6/27. Came across this on Reddit

    "

    I keep seeing a ton of conflicting info, but the general pattern I see is it breaks down into two categories.

    These cause all the attachment issues. There is no "fix" patch that is coming to address this though. They are behavior changes that have to be dealt with as indicated in the article.

    • Security update for Outlook 2007: June 13, 2017 - KB3191898
    • Security update for Outlook 2010: June 13, 2017 - KB3203467
    • Security update for Outlook 2013: June 13, 2017 - KB3191938
    • Security update for Outlook 2016: June 13, 2017 - KB3191932

    These cause the Search issues, and they are releasing a fix on 6/27

    • Security update for Windows 8, June 13, 2017 - KB4022726
    • Security update for Windows 10, June 13, 2017 - KB4022715
    • Security update for Windows 10, June 13, 2017 - KB4022725
    • Security update for Windows 7, June 13, 2017 - KB4022719
    • Security update for Windows 7, June 13, 2017 - KB4022722"
    Thursday, June 22, 2017 6:04 PM
  • With Outlook Open... do START > "Indexing Options" > MODIFY > Uncheck Outlook > OK to everything to close Indexing windows.

    Close Outlook.

    Open Outlook.

    START > "Indexing Options" > MODIFY > Check Outlook (and C:\ if it's unchecked) > OK to everything to close Indexing windows. 

    You can test a search immediately in Outlook.  It will be slow, but it should rebuild OK.

    From Ryan Madej over at spiceworks.

    This Worked for me. 

     This WORKED for me!

    Thank you very much StormArmageddon!!!!!!!!

    I had done these steps several time but never in that specific order. I had been working on this for days! 


    Thursday, June 22, 2017 8:25 PM
  • It's not a perm fix and it's slower than instant search but it's better then nothing.
    Friday, June 23, 2017 1:04 PM
  • Hey guys. Found a fix for those running 2010 on Windows 10 machines.

    Uninstalled KB 4022715 and the search reindexed and began functioning as normal. Microsoft has stated a fix is coming on the 27th.

    Hope this helps

    Friday, June 23, 2017 5:21 PM
  • In O2010 I had to naviate via File > Options > Search > Indexing Options... but the rest of this reply worked for me. Thank you, @StormArmageddon.
    Friday, June 23, 2017 6:03 PM
  • I'm waiting for the fix!

    since my company update our PCs to win7 with outlook 2010

    I have this problem!

    it's so inconvenience!

    Our IT guy doesn't know how to do with this either!

    How can a big company like Microsoft neglect loophole like this!

    Search is so important for daily office day!

    It's awkward to find the very email from more than 2000 emails by using my bare eyes!!!!!!!!

    GOD~~~~~~~~~~~~ 

    Monday, June 26, 2017 3:59 AM
  • Great. Saved my life. Thank you so much, StormArmageddon
    Tuesday, June 27, 2017 12:22 AM
  • There is official workaround for the issue: disable windows search via registry

    Innovation distinguishes between a leader and a follower - Steve Jobs

    Tuesday, June 27, 2017 10:43 AM
  • Any updates on the patch that's supposed to be released today to fix that?
    • Proposed as answer by Wilsonyg Tuesday, June 27, 2017 2:17 PM
    • Unproposed as answer by Wilsonyg Tuesday, June 27, 2017 2:17 PM
    Tuesday, June 27, 2017 1:07 PM
  • Hi Ethan,

    Quote from your earlier response. Is MS Security Patch team still scheduling a fix release for this issue?

    Hi,

    Thank you all for reporting this and sharing the details. The following is an official page of all the known issues that have been reported after installing the recent updates:

    Regarding the search issue in Outlook, it affects all Outlook versions on Windows 7, Windows 8, Windows 10.

    As mentioned in the link above, a Windows Update fix release is scheduled on 6/27. Until then, the workaround that we recommended is to set a registry key that will cause Outlook to stop using the local Windows Search service.  When this registry key is set, Outlook will use its own built-in search engine.

    Thank you all for your great understanding.

    Regards, 

    Ethan Hua

    Tuesday, June 27, 2017 2:22 PM
  • Is the patch going to released today? If not when?
    Tuesday, June 27, 2017 2:34 PM
  • Patch is out!  G
    Tuesday, June 27, 2017 6:00 PM
  • Patch is out!  Go to window updates on your pc ....search for updates.  There are three updates that have been added.  You have to select and download from there.  Fixed my stuff.  
    Tuesday, June 27, 2017 6:01 PM
  • its ready.  Go to window updates should see three for 6/27.  I went with all three.  Everything works great now.

    brian

    Tuesday, June 27, 2017 6:02 PM
  • Could anyone post the patch numbers of the updates you installed?  I only got a .NetFramework update and it has not fixed my issue.

    Thanks!

    Tuesday, June 27, 2017 6:19 PM
  • Could anyone post the patch numbers of the updates you installed?  I only got a .NetFramework update and it has not fixed my issue.

    Thanks!


    I'm also only seeing the .Net patch. We are running Win7 Pro and Outlook 2010 in our environment.
    Tuesday, June 27, 2017 7:34 PM
  • I set the registry key that will cause Outlook to stop using the local Windows Search service.

    Do I have to disable that registry?

    Thanks

    Tuesday, June 27, 2017 8:23 PM
  • Will this fix help if im using google sync?

    Thanks

    Tuesday, June 27, 2017 8:43 PM
  • It didn't work for me..I am using Google Sync..

    Any suggestion?

    Tuesday, June 27, 2017 8:56 PM
  • Just set the registry key that will cause Outlook to stop using the local Windows Search service.

    Tuesday, June 27, 2017 9:06 PM
  • KB4022168 is out for Win 7.  Where is the patch for Win 10 users running Outlook 2010? 
    Tuesday, June 27, 2017 10:27 PM
  • I have been checking and waiting today for the promised Windows 8.1 Outlook 2010 patch/KB update but nothing.

    I need this search function restored or I'm screwed. If I get screwed I'll have to VERY SERIOUSLY consider moving off Windows. This is unacceptable and even if MS says I can fix it by upgrading, I find that highly manipulative which I can then expect in the future so moving off is actually promoted by this behavior.

    Wednesday, June 28, 2017 12:38 AM
  • Hi All,

    Windows has released fixes via Windows Updates to address a reliability issue in Windows Search.  Below are the relevant KB updates for each version:

    Note: If you implemented the workaround that mentioned above, you can now set the PreventIndexingOutlook registry key to DWORD: 0 to go back to using Windows Search.

    If there is any questions, please feel free to let us know.

    Regards,

    Ethan Hua


    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, June 28, 2017 7:48 AM
    Moderator
  • When do you release update patch for the Windows 10 version 1511 ?
    • Proposed as answer by AviWein Thursday, August 17, 2017 7:12 PM
    Wednesday, June 28, 2017 8:33 AM
  • This solution and patch does NOT fix the issue when leveraging Google Apps Sync - the issue continues to exist.  Do we have nay insight as to why this is?
    • Edited by Dave Rubin Wednesday, June 28, 2017 3:52 PM
    Wednesday, June 28, 2017 3:52 PM
  • I have not had any success as well. Using windows 10 with Office 2007 and 2010. Office 2016 does not seem to be affected. Outlook search gives no results. I have also tried to resync gsuite sync for the profile, I deleted old profile and rebooted after updated and resynched gsuite, waited for a few hours to index the user (user has less then 500mb of emails) still no search results. Anyone that has a fix do anything different to get it to work. 
    Wednesday, June 28, 2017 7:58 PM
  • When do you release update patch for the Windows 10 version 1511 ?
    Exactly! I do not understand why version 1511 is not mentioned somewhere! Even the support page does not mention it at all. So Microsoft, not everyone is on the latest build, please inform us about the fix for build 1511.
    • Edited by TechKr Thursday, June 29, 2017 12:07 PM
    Thursday, June 29, 2017 12:07 PM
  • Hi All,

    Windows has released fixes via Windows Updates to address a reliability issue in Windows Search.  Below are the relevant KB updates for each version:

    • Windows 7 - June 27, 2017 update            

    • Windows 8.1 - June 27, 2017 update            

    • Windows 10 Version 1703 - June 27, 2017 update            

    Note: If you implemented the workaround that mentioned above, you can now set the PreventIndexingOutlook registry key to DWORD: 0 to go back to using Windows Search.

    If there is any questions, please feel free to let us know.

    Regards,

    Ethan Hua

    Hi Ethan,

    Also asking you, when is Microsoft planning to bring the fix for Windows 10 build 1511? Build 1511 is also not mentioned on the support page https://support.office.com/en-us/article/Outlook-known-issues-in-the-June-2017-security-updates-3f6dbffd-8505-492d-b19f-b3b89369ed9b?ui=en-US&rs=en-US&ad=US

    Why? Build 1511 received KB4022714 which started breaking things together with the Outlook KB3203467 update.

    EDIT:

    Searching for another KB mentioned in another forum I came across  KB4032693 which is for build 1511. This update is released 27-jun-2017 and adresses "a reliability issue in Windows Search". Will try this update as soon as possible to see if it fixes the search issue in Oulook.

    Can anyone already confirm this is a fix for the Outlook Search issue on Windows 10 - 1511 with Outlook 2010 SP2? If so, why isn't this KB mentioned in the support article?!

    On the page below you can also search for other Windows 10 builds: 

    https://support.microsoft.com/en-us/help/4032693/windows-10-update-kb4032693

    EDIT 2:

    Although it states that KB4032693 update causes some new issues with Internet Explorer 11.... *sigh*


    • Edited by TechKr Thursday, June 29, 2017 1:46 PM
    Thursday, June 29, 2017 12:46 PM
  • I installed the update and now search in Outlook 2010 doesnt work at all.  I get no results regardless of the search string.
    Thursday, June 29, 2017 2:31 PM
  • I installed the update and now search in Outlook 2010 doesnt work at all.  I get no results regardless of the search string.
    Same here - completed update now the search function says "no matches found" for anything is search in Outlook 2010
    Thursday, June 29, 2017 5:37 PM
  • I have my Updates set for manual install so I can review them and I haven't seen a June 27th update for this.

    Where is the patch(es) for Windows 8.1 Outlook 2010 Search Index?

    Or at least tell us which KB updates to uninstall to get the native Windows Search Service working.

    Registry Key workaround to enable a SLOW search isn't a workaround.

    This is a SERIOUS problem and I'm not getting the feeling Microsoft is treating it as such.

    Thursday, June 29, 2017 6:56 PM
  • This Search Indexing problem affects searching in "Windows Updates > View update history" too so you can't search for specific updates, you have to scroll through a search manually. This problem compounds at every turn.
    Thursday, June 29, 2017 7:03 PM
  • I installed the update and now search in Outlook 2010 doesnt work at all.  I get no results regardless of the search string.

    Same here - completed update now the search function says "no matches found" for anything is search in Outlook 2010

    Yeah I saw that too one some machines, BUT there is a solution that works (for me). On the affected machines you have to rebuild the index AND let it complete te be able to search again.

    1- Close Outlook
    2- Go to control panel - indexing options
    3- Click Advanced
    4- Click Rebuild

    Start Outlook and let it finish the indexing (you can view the status by setting the cursor in the search field, click on search tools - indexing status)

    • Edited by TechKr Thursday, June 29, 2017 11:18 PM
    Thursday, June 29, 2017 11:10 PM
  • I have a machine running Windows 10 Pro Version 1703 OS Build 15063.413 and Office Home and Business 2010 14.0.7182.5000 with G Suite Sync 4.0.7.0. I have applied all updates but I am still unable to use the search function. Has anybody else with Windows 10 resolved this issue? If I remove outlook from the search and add it back in the search works until i reboot. 
    Friday, June 30, 2017 6:46 AM
  • Unfortunately this didn't work for us - one user the index hit 0 and then 20 minutes later I checked indexing status and it was back up in 1000's.  I have rebuilt the Outlook 2010 profile and still it is indexing.  Also searched for the KB updates and nothing found.  Also we have not had a 27 June update last updates installed were 14 June.  Am losing patience...........
    Friday, June 30, 2017 10:11 AM
  • Hi there,

    I am using Outlook 2010 with G Suit Sync and this release didn't work for me.

    How can we do to fix it?

    Regards

    Aline

    Friday, June 30, 2017 2:21 PM
  • Just set the registry key that will cause Outlook to stop using the local Windows Search service.

    I did it and It worked..

    Thanks

    Friday, June 30, 2017 7:57 PM
  • Still waiting 4 days later for the Windows Update fix release is scheduled on 6/27 for Windows 8.1 Outlook 2010.

    What's going on?!

    Saturday, July 1, 2017 7:40 PM
  • Still waiting 4 days later for the Windows Update fix release is scheduled on 6/27 for Windows 8.1 Outlook 2010.

    What's going on?!

    For Windows 8.1, please try to install the following update:

    https://support.microsoft.com/en-us/help/4022720/windows-8-1-windows-server-2012-r2-update-kb4022720

    Regards,

    Ethan Hua


    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, July 3, 2017 3:32 AM
    Moderator
  • Hello everyone,

    I already tried everything that i could find on the internet to solucionate this problem, and no success.

    I also tried the update for windows 7 with KB4022168, remove the workaround solution and re-index.

    After doing this, it search but only emails from 2015 or before that so i think that i cant search on the local mailbox, but emais that are archived are being search well.

    No sucess here.... Does anyone already solve this WINDOWS search problem?

    I have problems on:

    Outlook 2010 and Outlook 2016

    On windows 7, 8.1 and 10

    Many thanks.


    Monday, July 3, 2017 2:54 PM
  •  Just set the registry key that will cause Outlook to stop using the local Windows Search service.

    Follow below:

    1. Click Start, click Run, type regedit in the Open box, and then click OK.

    2. Locate and then click the following subkey in the registry:
      HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows

    3. On the Edit menu, point to New, and then click New Key and name the key Windows Search.

    4. Click on the new key Windows Search.

    5. On the Edit menu, point to New, and then click DWORD Value.

    6. Type PreventIndexingOutlook for the name of the DWORD, and then press Enter.

    7. Right-click PreventIndexingOutlook, and then click Modify.

    8. In the Value data box, type 1 to enable the registry entry, and then click OK.

    9. Note to disable the PreventIndexingOutlook setting, type 0 (zero), and then click OK.

    10. Exit Registry Editor, and then restart Outlook.

    Thanks

    • Proposed as answer by Mark Brown 123 Monday, July 3, 2017 9:38 PM
    • Unproposed as answer by Mark Brown 123 Monday, July 3, 2017 9:38 PM
    • Proposed as answer by bgaulin Thursday, August 3, 2017 5:12 PM
    Monday, July 3, 2017 9:38 PM
  • Thats the workaround solucion and it's already implemented.

    Microsoft told that on 27th June they will fix the problem using some update package that i think it's KB4022168 i already instale it and didn´t solve the problem that's why im asking if that worked for someone.

    Tuesday, July 4, 2017 8:11 AM
  • This worked for me as well... In the new G-suite the search was not working when followed the above steps it started working
    Tuesday, July 4, 2017 11:49 AM
  • It realy works but its very slow searching.

    I need a definitive solucion that was suppost to be this KB4022168 and for me wasn't. I need to know if the KB4022168 solucion worked to someone else, because for me didn´t.
    Tuesday, July 4, 2017 1:30 PM
  • I'm downloading KB4022723 for W10 1607. Has anyone confirmed that this fixes the search issue with Microsoft? Will test on a few of my own machines and report back.

    Tuesday, July 4, 2017 1:42 PM
  • Are you working with G-Suite??

    If so, then this patch wont work for you.

    Thanks

    Tuesday, July 4, 2017 2:02 PM
  • Are you working with G-Suite??

    If so, then this patch wont work for you.

    Thanks
    Tuesday, July 4, 2017 2:02 PM
  • Yes, we use Google Sync Suite
    Tuesday, July 4, 2017 2:29 PM
  • Then the only solution for now is to Follow below:

    1. Click Start, click Run, type regedit in the Open box, and then click OK.

    2. Locate and then click the following subkey in the registry:
      HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows

    3. On the Edit menu, point to New, and then click New Key and name the key Windows Search.

    4. Click on the new key Windows Search.

    5. On the Edit menu, point to New, and then click DWORD Value.

    6. Type PreventIndexingOutlook for the name of the DWORD, and then press Enter.

    7. Right-click PreventIndexingOutlook, and then click Modify.

    8. In the Value data box, type 1 to enable the registry entry, and then click OK.

    9. Note to disable the PreventIndexingOutlook setting, type 0 (zero), and then click OK.

    10. Exit Registry Editor, and then restart Outlook.

    Thanks

    • Proposed as answer by bgaulin Thursday, August 3, 2017 5:13 PM
    Tuesday, July 4, 2017 5:27 PM
  • I'm curious if anyone who is having issues with Windows 7, Outlook 2010 and G Suite has tried upgrading their Outlook to a more current version.  Did this solve the issue or is the continued G Suite problem happening in all versions of Outlook?
    Tuesday, July 4, 2017 5:45 PM
  • There's a "2017-06 Preview of Monthly Rollup - KB4022720" at this link but I don't see a way to download the Update File.

    Find Downloads didn't find KB4022720 either. Any why isn't this update being presented via 'System and Security > Windows Update?'

    Tuesday, July 4, 2017 10:25 PM
  • You can right click on the .PST file -> Advanced -> Check "Allow this file to have contents indexed in addition to file properties".   This for some reason gets the emails caught up indexing for a short time.   But your users will have to check this box every day as it doesn't stay checked.

    I am doing this approach instead of doing a registry edit for my users while I earnestly await a fix from Microsoft!

    Wednesday, July 5, 2017 3:14 PM
  • Just to report back, installing KB4022723 on several W10 1607 machines did NOT fix the indexing issue. 

    Users are getting frustrated and we're at Microsoft's mercy for a fix here.

    • Proposed as answer by WeltonITlady Friday, July 7, 2017 4:08 PM
    • Unproposed as answer by WeltonITlady Friday, July 7, 2017 4:08 PM
    Thursday, July 6, 2017 2:16 PM
  • Running Outlook 2010 v14.0.7182.5000 (32-bit) on Windows 10 v1703 (using G Suite Sync for Microsoft Outlook)

    Tried all the fixes described in every forum, NONE worked. This included rebuilding the indexing, recreating my profile, removing windows updates, adding registry entries for Windows Search...

    Today I RESOLVED this issue by doing the following:

    1. Installing all Windows Updates (including KB4022725 that was flagged for causing the problem on my version of Windows).

    2. Restart.

    3. Open Outlook.

    4. Go to File > Options > Search > Indexing Options > Modify > UNCHECK Microsoft Outlook > OK > Close > OK.

    5. Close Outlook.

    6. Open Outlook*.

    *Note: you will need to re-select locations.

    This resolved the issue INSTANTLY on all our machines (5) without removing security updates. Emails don't show up in Windows Search results, but they never did and we are okay with that!

    Hope this helps you and saves people HOURS of troubleshooting!

    Friday, July 7, 2017 4:05 PM
  • Running Outlook 2010 v14.0.7182.5000 (32-bit) on Windows 10 v1703 (using G Suite Sync for Microsoft Outlook)

    Tried all the fixes described in every forum, NONE worked. This included rebuilding the indexing, recreating my profile, removing windows updates, adding registry entries for Windows Search...

    Today I RESOLVED this issue by doing the following:

    1. Installing all Windows Updates (including KB4022725 that was flagged for causing the problem on my version of Windows).

    2. Restart.

    3. Open Outlook.

    4. Go to File > Options > Search > Indexing Options > Modify > UNCHECK Microsoft Outlook > OK > Close > OK.

    5. Close Outlook.

    6. Open Outlook*.

    *Note: you will need to re-select locations.

    This resolved the issue INSTANTLY on all our machines (5) without removing security updates. Emails don't show up in Windows Search results, but they never did and we are okay with that!

    Hope this helps you and saves HOURS of troubleshooting!
    • Proposed as answer by WeltonITlady Friday, July 7, 2017 4:09 PM
    Friday, July 7, 2017 4:09 PM
  • This is not the solution, WeltonITlady.

    You're simply just turning Windows Index off for Outlook, resulting in VERY slow queries on large inboxes/slow machines. The only solution is, if Google Sync and Outlook/Microsoft will come up with an solution for making the Windows Index work on the Gmail-folders in Outlook again.

    Btw. your idea has already been posted alot of times in the thread. Please read before posting.

    Thanks for your input anyway :)

    Monday, July 10, 2017 7:38 AM
  • After updated this patch KB4022168, my user resolved the indexing problem temporarily,but seems to two weeks later the indexing problem occurred again after user rebooted the PC or some windows service patch updated.  The user have serveral pst outlook files mounted and their size from 5GB to 90GB. The outlook version is 14.0.7182.5000 (32 bit) and Win7 system.
    Tuesday, July 11, 2017 3:18 AM
  • This "band aid" worked for me. Thank you. I hope that Microsoft gets it fixed soon!
    • Proposed as answer by bgrady13 Thursday, July 13, 2017 8:50 PM
    Wednesday, July 12, 2017 1:32 PM
  • Thanks, tried a bunch of stuff and this finally worked.

    t

    w

    Friday, July 14, 2017 7:41 AM
  • As per recommendation as someone in this thread, for W10 1607 machines running Outlook 2010 without Gsync, the fix we use is:

    Install KB4022723
    Locate PST file needed for be indexed.
    Right click > Properties > Advanced > Check box "Allow this file to have it's content indexed in addition to file properties"

    Has worked on about 10 computers so far. Testing on a Creators Updated machine this afternoon.
    • Proposed as answer by HRd Guy Friday, July 14, 2017 2:13 PM
    Friday, July 14, 2017 2:12 PM
  • Same exact result for me.  

    I have windows 10, outlook 2010, g suite sync.  Very difficult to do regular activities without a culling search!

    Friday, July 14, 2017 2:17 PM
  • Outstanding StormArmageddon...this worked for me!
    Friday, July 14, 2017 2:22 PM
  • With Outlook Open... do START > "Indexing Options" > MODIFY > Uncheck Outlook > OK to everything to close Indexing windows.

    Close Outlook.

    Open Outlook.

    START > "Indexing Options" > MODIFY > Check Outlook (and C:\ if it's unchecked) > OK to everything to close Indexing windows. 

    You can test a search immediately in Outlook.  It will be slow, but it should rebuild OK.

    From Ryan Madej over at spiceworks.

    This Worked for me. 

    This worked until reboot. 

    Nothing else has worked. 

    Any way to make this fix permanent? Thanks so much, this is a frustrating issue.

    Monday, July 17, 2017 5:15 PM
  • StormArmageddon you should change your name to ROCK STAR!!!!!

    Worked for me on three different clients.

    Tuesday, July 18, 2017 11:59 PM
  • New roll up pack from microsoft was released for the issue and this fixed the issue for my environment.

    June 27, 2017—KB4022168 (Monthly Rollup)

    Reference Link:

    https://answers.microsoft.com/en-us/msoffice/forum/msoffice_outlook-mso_other/after-windows-june-2017-update-outlook-2010-search/58e27598-ab59-4cc0-b8cb-8a5a5dd62eee

    • Proposed as answer by Rohan Jadhav Friday, July 21, 2017 9:12 AM
    Friday, July 21, 2017 9:11 AM
  • I see this is for Win 7.  Is there one for Win 10 and Outlook/Office 2010?
    Tuesday, July 25, 2017 7:26 PM
  • Still no fix on this side wit Win 7 and office 2010. So far the only fix I have that works well has been to upgrade to office 2013.  

    Wednesday, July 26, 2017 12:36 AM
  • Works like a charm! Thanks for the solution.
    Thursday, July 27, 2017 4:21 AM
  • https://support.office.com/en-us/article/Outlook-known-issues-in-the-June-2017-security-updates-3f6dbffd-8505-492d-b19f-b3b89369ed9b

    You can see in topic nº 5, the KB to fix the problem to all versions of windows. download it an install after that if still not works you must re-index everything again.

    After that should be well.

    Monday, July 31, 2017 8:37 AM
  • Yea I've done that and also mad some new Outlook profiles. Only time will tell if the new Outlook profiles do the trick but I know re-indexing did not fix it 100%. Not not sure what else to do. Usually I do the following in this order

    -re-index

    -create new outlook profile

    -check windows search service

    I've posted on Reddit and got one reply:

    "I've got one user that reported this error today using Outlook 2007.

    We tried...

    • Rebuilding the index
    • Repairing Office
    • Recreating her Outlook profile
    • Reinstalling the Windows Search service
    • Disabling all add-ins

    None worked.

    Couple things I've noted...

    • Running Outlook in safe mode yields good searches, but working through the add-ins or turning off the reading pane in normal mode do nothing

    • Searching via the Start Menu still works, so it's definitely something in Outlook and not the index itself

    We ran out of time to try more but will attempt reinstalling Office at a later time. May not be the same issue are you, but I hope it helps."

    This worked on several computers where I work.  I tried it a few weeks ago and it didn't work, but today it did.  Thanks!

    Monday, July 31, 2017 1:38 PM
  • I have started testing on some computer just unchecking outlook from the indexing option and it appears to be working after restarting outlook. I suspect it will cause a few issues with windows search functions but users are now able to search withing outlook. Will be checking back over the next few days to see if this holds for my users. 

    Monday, July 31, 2017 6:24 PM
  • This worked for me, I couldn't find the KB3203467, i found kb3203468, but just stopping indexing for outlook worked. It is slow, but at least it works, all the other fix's didn't work after restarting. thanks
    Thursday, August 3, 2017 4:57 PM
  • this works for me.

    Thanks

    Monday, August 7, 2017 6:10 PM
  • I spent DOZENS of hours getting to the bottom of this problem. Re-indexing, removing Outlook from the indexing and re-adding it, windows updates, removing updates, adding new updates, registry changes, calling Gsuite tech support....none of it helped...but I finally stumbled on something that helped me.

    Get a good backup of PST.

    I unistalled that gsuite sync POS, and that took a while and then I could not open Outlook 2010 anymore (errors on start). Then I deleted the profile, and I still could not open Outlook (different error on start). Then I ran a repair on Outlook from add/remove programs. Then I set it back up like any new e-mail account (no Gsuite sync POS) and it started to sync. After is synced for a bit I tested the search function, and for the first time in months it stated working.

    The cynical side of me believes that Gsuite makes changes to Outlook that disables search to force people off Outlook and to Gmail and google keeps their 'King of Search' designation. Who knows? I lost a lot of love for Google during all this, because I nearly lost 2 clients and thousands of dollars fixing it.

    This was a long and arduous journey, and I don't think I will ever trust Gsuite in the future.


    • Edited by Dougbdl Monday, August 14, 2017 7:41 PM
    Monday, August 14, 2017 7:38 PM
  • Get rid of the Gsuite sync service. It is the problem. My fix is posted above.
    Monday, August 14, 2017 7:43 PM
  • Get rid of the Gsuite sync service. It is the problem. My fix is posted above.
    Monday, August 14, 2017 7:45 PM
  • So if you uninstall GSuit/Gsync you only can configure the profile as IMAP right?

    If i use IMAP configuration the shcedule on the calendar will not be updated/sycnonised?



    I dont Belive that GSuit/GSync it's the problem because all my company has it, and only on the Outlook 2010 that it doesn't work.


    Wednesday, August 16, 2017 8:13 AM
  • Can anyone help to get it work?

    I'm a bit lucky. I just start having this issue 3 weeks ago, as since Windows 10 I'm disabling and blacking any windows update. 3 weeks ago I decided to accept updates and since then my Outlook search returns "no match found". 

    tried reindex and all above, nothing worked.

    Regedit trick PreventIndexingOutlook works now. I add to choose DWORD 32bit like the Office version and not 64bit like the OS!

    it works in Safe Mode.

    Windows 10 Outlook 2010.

    Trying here once again before dropping Outlook from all computers and using something else.

    can anyone recommend an Outlook replacement (using google)?

    I'm sure its Microsoft games against Gmail users!



    • Edited by AviWein Thursday, August 17, 2017 7:45 PM
    Thursday, August 17, 2017 6:30 PM
  • BEST Replacement to Outlook EMAIL FOR GSUITE/Gmail USERS instead of Outlook (and yes syncs calendar/contacts with Gmail) is EMCLIENT, https://www.emclient.com

    EM Client - free for up to 2 email accounts. 

    Monday, August 21, 2017 5:10 PM
  • Great!
    Wednesday, August 23, 2017 6:44 AM
  • Facing Outlook search Problem? Don’t worry here you will definitely get the quick solution to fix Outlook Search problem. After a deep search, I read solution to fix Outlook search Issue here.

    Find the article here: https://sysinfotools.com/blog/resolved-fix-outlook-search-problem/

    Wednesday, August 23, 2017 12:29 PM
  • I have a few email inboxes.   The only one not allowing a search was G Suite.   I unchecked the G Suite email inbox in the MODIFY area....  Then restarted Outlook and all the inboxes... including G Suite are now searchable.
    Thursday, August 24, 2017 11:48 AM
  • We just started seeing this issue a few weeks ago.  I have discovered 2 things.  The first was that the search issue was only affecting users who were not cached.  I could simply cache these users and then their search would start working.  The problem for these few users that were not cached is that uncaching them was a fix for another  issue that involved the syncing of delegate calendars and items disappearing.....

    Any way they needed to keep their cache off.  I found another blog that identified my issue as being a corrupted index on the database server after our logs drive filled up and mail went down.  They suggested to rebuild the search index....

    Well in testing rebuilding the search index came my second discovery....  while the rebuilding is in process it stops the Microsoft exchange search indexer service and during that moment I was being impatient and was trying the searches any way and they started working all of a sudden.  I thought it was fixed but when it completed and restarted the service again I was back to no search results at all.  After running it a couple more times and confused as to why it started working and then stopped, it finally hit me that when the service was stopped the searches worked.

    So I stopped the  service and put it in manual mode so that it would not start itself.  My searches are now working for myself not being cached and I also checked to make sure that if I was cached that the searches would still work and they do.  I have only tested on myself at this point but everything seems to work. 

    If anyone else would like to comment on this or test my theory I would be happy to hear your thoughts.

    God bless you all

    Monday, September 4, 2017 3:01 PM
  • I have tried all suggestions with no luck. Does anybody have a fix for this - Outlook 2010 on Windows 10 with Google Sync. Lack of a search facility makes the combination unusable i feel?
    Saturday, September 9, 2017 10:02 AM
  • This worked for me as well
    Friday, September 15, 2017 1:26 AM
  • Thank you this worked for me as well. 
    Thursday, September 21, 2017 10:17 PM
  • This solution works for me. Thanks so much!
    Thursday, September 28, 2017 4:23 PM
  • I used the solution proposed by someone else and it finally works! Go to indexing options, then 'modify'. Go the Microsoft Outlook app folder in Indexing options and expand the folder, and then uncheck Google Synch (G Suite). As soon as I did this my search started working! 
    Wednesday, October 4, 2017 5:00 PM
  • THIS WORKED!!!!! THANK YOU SO MUCH!!
    Saturday, October 7, 2017 4:35 PM
  • You saved my life!:) Thanks!
    • Edited by Cica Maca Tuesday, October 17, 2017 8:51 PM
    Tuesday, October 17, 2017 8:50 PM
  • This worked for us as well! Thank you. We were suffering for months.
    Wednesday, October 18, 2017 4:51 AM
  • This is the only thing that made it work. Thanks!
    Wednesday, October 18, 2017 1:28 PM
  • It's worked for me. Thank you so much!
    Wednesday, October 18, 2017 6:04 PM
  • This worked for me as well. I survived 6 months without Outlook search functionality, always resorting to the Google web interface when I had to search emails. Thanks for this simple fix, I can regain my sanity. FYI...this was Windows 7 and Outlook 2010. However, I still don't see Outlook results in my Windows search like I used to, just when searching from within Outlook.

    David A. Bermingham, MVP, Senior Technical Evangelist, SIOS Technology Corp

    Tuesday, October 24, 2017 4:20 PM
  • While unchecking the "G Suite" box did at least force Outlook to start searching again, in my case it only kicked it over to the old slow "non-indexed" search rather than actually fixing the underlying problem that the emails are not being indexed.  As such, "instant search" is still broken with no apparent fix as yet.  Unless someone's figured that part out yet?
    Wednesday, October 25, 2017 1:43 PM
  • This worked great for me.

    Rebuilding index worked out. I was afraid I'd have to re-install outlook with my POP account and then hope that it works but this fix saved me from all that hassle.

    THANK YOU

    Monday, October 30, 2017 5:20 PM
  • After MONTHS of struggeling with the no more working search: this helps, at least for the work IN outlook.

    I still not get results from the start-search windows, but however I give you 100 points for your advice!

    BRGDS

    Roger

    Wednesday, November 1, 2017 4:03 PM
  • Hi David,

    The solution works for G Suite Sync on Windows 7 with Outlook 2010, I've used it on multiple computers, and you don't have to remove Outlook from indexing (better search!).

    This was originally posted by IT-COA on a Spiceworks post (https://community.spiceworks.com/topic/2005797-outlook-2010-sp2-search-broken-after-june-13-2017-updates) I've copied and pasted the instructions below. More detailed version on the above link.

    So the new Instructions to restore the search feature (using indexing) are:

    If you have any of the following updates remove them:

    KB3203467 - (has been replaced by KB2956078)
    KB2597089 - (After removing a new update, KB2956076, will be there and should be installed)
    KB2956078 - (Will need to be hidden so it doesn’t re-install)

    Re-index Outlook

    My only issue is finding a solution for Windows 8.1 and 10...

    Wednesday, November 8, 2017 11:22 AM
  • This solution works on Windows 7 with Outlook 2010 (and keep indexing working).

    So the new Instructions to restore the search feature (using indexing) are:

    If you have any of the following updates remove them:

    KB3203467 - (has been replaced by KB2956078)
    KB2597089 - (After removing a new update, KB2956076, will be there and should be installed)
    KB2956078 - (Will need to be hidden so it doesn’t re-install)

    Disable indexing.

    Restart Outlook.

    Re-enable indexing

    Restart Outlook

    Wait for indexing... test your search.

    My only issue is getting this solution working for Windows 8.1/10...

    Wednesday, November 8, 2017 11:25 AM
  • Microsoft Office Standard 2010
    Outlook Version : 14.0.4760.1000 ( 32-bit )

    OS Version - Windows 10 Pro

    Issue Resolved

    I had the same issue .

    Indexing 5 percentage and stops indexing .

    My PST Size Total is 50 GB + .

    Microsoft Office 2010 Service Pack  was installed from Windows Updates few days before .

    Since the update happened on wards the issue started for me .

    Removed installed service pack for Office 2010 .

    And Indexing Start Automatically and Working for me

    Even this is not the proper way .

    Issue Solved For Me .

    Thanks & Regards

    Sarayu Prasad

    Monday, November 13, 2017 10:28 AM
  • I noticed on a User who had this issue that in Search Tools > Locations to Search ... The IMAP account was unticked and only had a tick next to Outlook Data File which has no mail content. Re-ticked the IMAP account and now Searching works!!

    Thursday, November 23, 2017 12:50 PM
  • I used the solution proposed by someone else and it finally works! Go to indexing options, then 'modify'. Go the Microsoft Outlook app folder in Indexing options and expand the folder, and then uncheck Google Synch (G Suite). As soon as I did this my search started working! 
    Thank you!! Worked here!! 
    Monday, November 27, 2017 10:17 PM
  • I applied this solution and worked fine without unistall any Update from windows. I am running Windows 10 Pro and Office 2010 (Outlook 2010 of course).

    Thank you to your steps

    Tuesday, November 28, 2017 8:50 PM
  • Kidders this was the one for me. Been doing my head in.
    Thursday, December 14, 2017 1:06 PM
  • This worked for me too!  thank you for sharing as this issue is a frequent problem for me and waiting for my IT team to get to me can take a while.  thanks!!!
    Monday, December 18, 2017 7:54 PM
  • Thanks StormArmageddon -- my search failed after Win 10 update (and rollback because of other issues) in Dec 2017.  This worked to fix Outlook search.
    Wednesday, December 20, 2017 5:38 AM
  • This worked for me!! Thanks!
    Friday, November 30, 2018 3:46 PM