none
SharePoint Tree navigation weird behavior RRS feed

  • Question

  • Hello,

    I have a weird behavior on my SharePoint Standard 2013 Tree navigation.

    I've created a library with some folders in it. I've break the autorisation inheritance on all folders and give autorisation to my user A on 2 of them. In the Library view, everything works like expected (he doesn't see folders where he doesn't have access to). But in the tree view, he can see some of them.

    I've check the autorisation (with the "check autorization" tool) and I confirm that he doesn't have access to them, but with the tree view he can click on them and open them ! He don't see the content fortunately :) but i don't understand why some folder are visible and some not..

    The publishing feature is not activated, neither the Publication infrastructure features.

    Any clue ?


    Thursday, November 12, 2015 5:02 PM

All replies

  • Hi,

    Does the user appear on other places with Limited Access behind its name? You can find out by using Check Permissions for instance. If the user has Limited Access behind its name, it is probably in another group. See for a better explanation https://social.technet.microsoft.com/Forums/sharepoint/en-US/aac2b433-cd57-4ccb-9935-9e3ee04b2fdb/urgent-how-do-i-get-treeview-to-show-only-document-libraries-users-have-permission-to-access

    Can you find the user has Limited Access to something?

    All the best,
    Quincy

    Friday, November 13, 2015 8:49 AM
  • Hi Quincy,

    The user doesn't have any access on those folders, if I use check permission on one of them the pop-up confirms that (it show "none").

    i don't understand why some folder are visible and some not..if i use "check permission",the result is the same on both folders..

    Tuesday, November 17, 2015 1:25 PM
  • No idea ? :/

    Does someone know where i can post this type of question to have an help from Microsoft ?

    Thursday, November 19, 2015 8:48 AM