none
Office\Word 2016 - Text missed from tables cell after KB4011039

    Question

  • Hello. After installing KB4011039 in Word 2016 filename.doc document lost cell text in table. Pls. look at screenshot.

    After removing mentioned KB patch text reappeared.

    Missed text in word table

    Wednesday, September 06, 2017 8:01 AM

All replies

  • Just to add to this, this update has caused a few headaches at work today. I've had a lot of panicking users thinking that a lot of there documents had been wiped.

    As stated above, removing the patch fixed the issue but this is something that needs addressing

    Wednesday, September 06, 2017 3:50 PM
  • We ran into the same issues yesterday, we have recalled the patch from our pc's.
    Wednesday, September 06, 2017 7:51 PM
  • Same issue here. We rejected it on our WSUS.
    Thursday, September 07, 2017 5:50 AM
  • Hi Vladimir,

    Thanks for your feedback. I would like to confirm if the problematic Table cells are merged cells or other specific formatting applied on it.

    I did a test in my Word 2016. After installed KB4011039, I can reproduce your issue when there are merged cells in table, the content in the merged cells are missing randomly. After uninstalled it, there is no issue. Please confirm if it is the same scenario as yours.

    Currently, please try to uninstall KB4011039 for the affected Word 2016 application as a workaround. I have helped to submit this feedback to Word team. It may need some time to release a fix on it. Your patience is highly appreciated.

    Best Regards,

    Winnie Liang


    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, September 07, 2017 6:04 AM
    Moderator
  • I can confirm that is exact scenario is happening on our sites.  I have manually uninstalled the patch on a few computers today, and have setup our WSUS to remove it everywhere .. 

    Once this KB is removed , the Word docs display correctly.


    Michael Mollard Network Administrator Moreton Bay College Brisbane, Australia.

    Thursday, September 07, 2017 6:13 AM
  • I can confirm this is happing on our site also. I hope Microsoft will fix this really quick with a patch.
    Thursday, September 07, 2017 7:43 AM
  • This looks a whole lot like the bug in last month's KB 3213656

    https://www.computerworld.com/article/3219655/microsoft-windows/word-outlook-merged-cell-problem-arises-after-install-of-patch-kb-3213656.html

    In both cases - KB 3213656 and KB 4011039 - it appears as if uninstalling the bad patch fixes the problem. Looks like Microsoft either (a) didn't see last month's bug or (b) saw it and decided they couldn't wait to fix it.

    I wonder if there are more, similar problems lurking?


    Woody Leonhard, writer, curmudgeon, and card-carrying Windows Victim

    Friday, September 08, 2017 8:14 PM
  • The bug reapears with update KB4011039 (September 5, 2017)

    See also Update KB4011039 causes again Word/Outlook 2016 table bug.

    ------------------------------------------------------------------------------

    *** Can someone of the Microsoft moderators escalate this to the Office product group - thanks.

    Addendum: Hours after my post in MS answers forum, a Microsoft employee came back with the following answer:

    Done! Working on getting all the docs updated now. I’m told the Patch with the fix is targeted for October.


    Gruß/greetings G. Born - Blogs: http://blog.borncity.com


    Friday, September 08, 2017 11:05 PM
  • Had this same issue on my home computer. Raised it with Microsoft and also noted it down here on their feedback section: https://word.uservoice.com/forums/304924-word-for-windows-desktop-application/suggestions/31332460-kb4011039 
    Monday, September 11, 2017 2:07 AM
  • Any Ideas to when this might be fixed? As we have over 1300 computers that have just recived KB4011039 which has also broken tables in all word documents. (and this KB has been reported is not being patched until October) And now we cannot remove this upodate via WSUS due to Windows 10 and WSUS doies not remove updates anymore via the approval- removal options within WSUS.

    And we cannot manually remove the update on 1300 as we dont have the manpower or time now we are into College Term

    David Hallam

    Monday, September 11, 2017 2:52 PM
  • Hi,

    I have the same pb. And WSUS does not remove this KB.

    We have 600 computers et it is not possible to remove this fix on each computer.

    So, How to do?

    Thank you for your help.

    B Lemon

    Monday, September 11, 2017 4:01 PM
  • You can script the uninstall and use Group Policy (or your method of choice) to run the script.

    wusa.exe /uninstall /kb:4011039 /quiet /norestart

    But... if you have 1300 computers, you probably should be waiting a bit longer before you approve updates to them en masse.  I'm not trying to sound snarky at all, but with the state of Windows Update, you can no longer just assume they'll work.  Give yourself a select few people to be your guinea pigs for new updates before pushing them out to everyone.

    Monday, September 11, 2017 5:47 PM
  • I tried the wusa approach, unsuccessfully.. on Windows 10.

    https://social.technet.microsoft.com/Forums/windows/en-US/f6594e00-2400-4276-85a1-fb06485b53e6/issues-with-wusaexe-and-windows-10-enterprise?forum=win10itprogeneral


    Michael Mollard Network Administrator Moreton Bay College Brisbane, Australia.

    Monday, September 11, 2017 9:58 PM
  • Hi all,

    Thanks for all your feedback. This known issue for Word 2016 has been published in the following article:
    After installing KB 3213656 or KB 4011039, merged table cells don’t work correctly in Word or Outlook 

    ISSUE        

    After installing the August 8, 2017, update for Word 2016 (KB3213656) or the September 5, 2017, update for Word 2016 (KB4011039), you may encounter the following issues:

    • If you merge vertical cells in a table, the cell content disappears, and you can’t select the merged cell.

    • If you open an existing document that has a table with merged cells, the cells will appear to be blank.

    This issue occurs only for those who receive Office 2016 updates using Windows Installer technology (MSI). If you have a Click-to-Run edition of Office, such as Office 365 Personal, you won’t encounter this issue.

    STATUS: WORKAROUND        

    As a workaround, you can uninstall both KBs and your tables will return to normal. We anticipate releasing the fix for this issue in the next monthly update, tentatively scheduled for October 3, 2017.

    Thanks again for all your patience.

    Best Regards,

    Winnie Liang


    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Tuesday, September 12, 2017 1:46 AM
    Moderator
  • Hi

    Wsus Package Publisher

    Neue Update - msiexec.exe 

    msiexec.exe /I {90160000-0011-0000-0000-0000000FF1CE} MSIPATCHREMOVE={A36375BB-E79D-411D-BF1E-C7E8120A08A9} /q /norestart  (MS Office 32bit German)

    msiexec.exe /I {90160000-0011-0000-0000-0000000FF1CE} MSIPATCHREMOVE={37811086-784B-4EB8-B009-09DF9278ED9F} /q /norestart (MS Office 64bit German)

    Source: http://www.jniesen.de/?p=2064

    Best Regards,

    Wojciech Stachowiak


    Tuesday, September 12, 2017 9:21 AM
  • hi

    I try to unsinstall the kb with a script (runas administrator):

    "wusa.exe /uninstall /kb:4011039 /quiet /norestart"

    But i have the box error :

    « we need to start a separate installation to complete this update ».

    I think this is a problem of elevation, but I do not see how to get around this elevation.

    I try to realize this script with autoit, but i have the same problem.

    Thank you for your help.

    Wednesday, September 13, 2017 4:06 PM
  • I don't understand why Microsoft still continuous to deliver this KB to customer. This morning (14/9/2017), all the PCs in our campus (over 100 PC ) automatically updated the KB. Now, we need to remove it manually. Anyone can help me?

    Thursday, September 14, 2017 6:16 AM
  • Great thread, we've had some clients report this issue and we were suspecting it may have been a Windows Update.

    For us we have approved the update for removal in WSUS with a deadline in the past - seems to be that some machines do not like WUSA with this update.

    Since then things have been running smoothly, table cells are visible and working again.

    Cheers


    Rory Fewell

    (CCNA, MOS)

    Windows Server 2012 and Networking Fundamentals Apprentice

    Visit my site!

    View me on GitHub!


    • Edited by Rory Fewell Thursday, September 14, 2017 8:04 AM
    Thursday, September 14, 2017 6:32 AM
  • FYI, I'm finding that if I switch to "Outline" or "Draft" view (in the "View" tab), the missing text reappears. Not ideal, but it may get you through in a pinch.

    Thanks,
    Adam

    Thursday, September 14, 2017 9:42 PM
  • Just thought I'd chip in again because I've had a site that would not correctly remove this update from computers when it is set as 'Approved for Removal' in WSUS.

    These Office updates can't be removed with the WUSA tool, only MSIEXEC can be used to remove them via command line, and as such you have to get the GUID of your Office install, and the patch GUID of the MSP file.

    I have found that this update patches 4 products, and so shows up four times in 'View installed updates' within Programs & Features, if you search through the registry for KB4011039, you should find four instances where it is listed under the patch's display name.

    The site I was working on has the English US version of Microsoft Office 2016 Professional Plus installed, the following commands worked for uninstalling the KB patch from both 32-bit and 64-bit installs:

    msiexec /package {90160000-0011-0000-0000-0000000FF1CE} /uninstall {A36375BB-E79D-411D-BF1E-C7E8120A08A9} /qn
    msiexec /package {90160000-012B-0409-0000-0000000FF1CE} /uninstall {A36375BB-E79D-411D-BF1E-C7E8120A08A9} /qn
    msiexec /package {90160000-001A-0409-0000-0000000FF1CE} /uninstall {A36375BB-E79D-411D-BF1E-C7E8120A08A9} /qn
    msiexec /package {90160000-001B-0409-0000-0000000FF1CE} /uninstall {A36375BB-E79D-411D-BF1E-C7E8120A08A9} /qn
    
    msiexec /package {90160000-0011-0000-0000-0000000FF1CE} /uninstall {37811086-784B-4EB8-B009-09DF9278ED9F} /qn
    msiexec /package {90160000-012B-0409-0000-0000000FF1CE} /uninstall {37811086-784B-4EB8-B009-09DF9278ED9F} /qn
    msiexec /package {90160000-001A-0409-0000-0000000FF1CE} /uninstall {37811086-784B-4EB8-B009-09DF9278ED9F} /qn
    msiexec /package {90160000-001B-0409-0000-0000000FF1CE} /uninstall {37811086-784B-4EB8-B009-09DF9278ED9F} /qn

    The first four commands are for 32-bit, and the latter four are for 64-bit.

    I hope this helps someone else, because hunting through the registry to obtain those package GUIDs took me an hour or so.

    Cheers


    Rory Fewell

    (CCNA, MOS)

    Windows Server 2012 and Networking Fundamentals Apprentice

    Visit my site!

    View me on GitHub!

    Friday, September 15, 2017 5:35 PM
  • Thanks Rory! Saved me atleast some time when getting back with the GUIDs. The first one (0011) works and isnt language bound. The three others appear language bound.

    For everyone using Office 2016 (Swedish) Sv-Se 32-bit the GUIDS are:

    msiexec /package {90160000-0011-0000-0000-0000000FF1CE} MSIPATCHREMOVE={A36375BB-E79D-411D-BF1E-C7E8120A08A9} /q /norestart
    
    msiexec /package {90160000-012B-041D-0000-0000000FF1CE} MSIPATCHREMOVE={A36375BB-E79D-411D-BF1E-C7E8120A08A9} /q /norestart
    
    msiexec /package {90160000-001A-041D-0000-0000000FF1CE} MSIPATCHREMOVE={A36375BB-E79D-411D-BF1E-C7E8120A08A9} /q /norestart
    
    msiexec /package {90160000-001B-041D-0000-0000000FF1CE} MSIPATCHREMOVE={A36375BB-E79D-411D-BF1E-C7E8120A08A9} /q /norestart

    Monday, September 18, 2017 2:05 PM
  • WOW this KB is still released even today!!!

    I had some users reporting this issues.  Thought 95% was an update.  However the users had over 70 updates from this month. so i had to uninstall office completely and reinstalled.  Then the text appeared on the word doc.  After installing the 58 updates the text was missing again.  Managed to spot the word KB, uninstalled and now it is working.  I have hide this update on the user's PC so hopefully this issue does not re-appear. 

    Wednesday, September 20, 2017 7:50 AM