locked
Installation failed- not digitally signed with a trusted certificate

    Question

  • Have a Windows Mobile 6.1 OS on Palm Treo Pro. PRIOR to setting up MS Exchange 2007 mailbox on device, any preloaded apps could be updated. User could download/install/update apps.  AFTER connection to MS Exchange 2007 established, no other installations/updates allowed.  This message received every time 

    "Installation was unsuccessful.The program or setting cannot be installed because it is not digitally signed with a trusted certificate."


    Neither Palm nor Mobile carrier able to resolve this issue. Device has been hard reset, reset to manufacture original shipping settings, device even replaced.  Only way is to update and install/update software prior to establishing MS Exchange 07 connections. 

    However, some software, such as Windows updates have updates that need updating more than once. And, while few apps are installed, if one should find an app to install, it can not be installed once MS Exchange connection is up and running.

    Have tried this with no success
    http://support.microsoft.com/default.aspx/kb/915840

    Is their a resolution for this issue?

    Thanks!
    Steve

    Monday, March 08, 2010 1:26 AM

All replies

  • Hi,

    Have you applied any activesync policies from Exchange 2007. In Exchange 2007 you can apply activesync policy and enforced for blocking unsigned application. Can you check whether you have enabled the Option "Allow unsigned applications" & "Allow unsigned installation packages"

    Please refer the below link for more information.

    http://technet.microsoft.com/en-us/library/bb123484.aspx


    ___________________
    Sanjay
    • Proposed as answer by Elvis Wei Tuesday, March 09, 2010 8:38 AM
    Monday, March 08, 2010 7:13 AM
  • Hi Steve,

    I agree with Sanjay, please check your ActiveSync policy settings and let us know the result.

    Thanks,

    Elvis

    Tuesday, March 09, 2010 8:39 AM
  • Still checking on this .  We have MS Exchange 2007.  The link above refers to Exchange 2010.  If it applies, to exchange 2007 also, I think it would solve the issue.
    Sunday, March 14, 2010 3:11 AM
  • Would this be the information we need to apply to 2007?
    http://technet.microsoft.com/en-us/library/aa997575(EXCHG.80).aspx

    Sunday, March 14, 2010 3:36 AM
  • Hi Steve,

     

    The configuration settings we want to confirm in this situation is the same in Exchange 2007 and Exchange 2010. Here is articles for Exchange 2007: http://technet.microsoft.com/en-us/library/bb123484(EXCHG.80).aspx

     

    Please make sure you have enabled "Allow unsigned applications" & "Allow unsigned installation packages" in ActiveSync policy settings. Installing Root certificate doesn’t have relationship with the current issue.

     

    Thanks,

     

    Elvis

    • Proposed as answer by Elvis Wei Monday, March 22, 2010 9:15 AM
    Monday, March 15, 2010 3:19 AM
  • Thank you.  Will let you know.  I appreciate the direction.
    Sunday, March 21, 2010 9:22 PM