none
Microsoft.ACE.OLEDB.12.0' provider is not registered on the local machine.

    Question

  • hi,

        I have two servers and both are of 64bit Windows server 2003 OS. I am getting the error "The Microsoft.ACE.OLEDB.12.0' provider is not registered on the local machine" in one server only.

    FYI.. I can see "office12" folder in one server(where it is working fine) in the location"C:\Program Files(x86)\Common Files\Microsoft Shared\OFFICE12" but not on the ther one. On the other server(where i am getting the error) is having "office11" folder in the same location. Could you please help.

    Is it a problem with Access Database Engine ?

    Tuesday, October 19, 2010 4:53 AM

Answers

  • Sorry if this is bringing up an old thread, but google returned this to me and I solved the problem myself, so I thought I would explain my different solution.

    I also received this error about Microsoft.ACE.OLEDB.12.0 not being registered on the local machine. I tried changing my build to x86 as suggested. Still didn't work. Finally, I realized that I don't have Access 2007, I have the 2010 version. Don't know if that matters, but I do know that installing the 2007 Office System Driver: Data Connectivity Components did solve the problem. Hope it helps!

    • Proposed as answer by David Schlum Friday, September 09, 2011 9:56 PM
    • Marked as answer by David Wolters Monday, March 12, 2012 6:21 PM
    Tuesday, August 02, 2011 2:24 PM
  • Hi,

        Thanks for your reply, but if I run the same build in other servers(of same 64 bit OS version) it is running fine. I am facing this problem only, if i try to read any excel file of 2007 version(.xlsx), but not .xls files. I am trying to read those files from VB.net application.

         FYI... I can see "MS Access Database Engine 2007" in "Add and Remove" programes of other servers, where it is running fine. So, will that help, if I install "MS Access Database Engine" in this server as well.

    http://www.microsoft.com/downloads/en/details.aspx?familyid=7554F536-8C28-4598-9B72-EF94E038C891&displaylang=en  

     

    • Marked as answer by geek_jumper Friday, November 19, 2010 5:36 AM
    Wednesday, October 20, 2010 4:48 AM

All replies

  • Hi,

    I think this issue is caused by you are running 64-bit windows and there are no MS Access drivers that run 64-bit. So I suggest you trying to change your build configuration to x86. You can do that on the project properties dialog under "Compile>Advanced Compile Options...>Target CPU". Change it to "x86". Then clean and rebuild your solution.

    Hope that helps.

    • Proposed as answer by emaraszek Friday, November 30, 2012 9:45 PM
    Wednesday, October 20, 2010 2:15 AM
  • Hi,

        Thanks for your reply, but if I run the same build in other servers(of same 64 bit OS version) it is running fine. I am facing this problem only, if i try to read any excel file of 2007 version(.xlsx), but not .xls files. I am trying to read those files from VB.net application.

         FYI... I can see "MS Access Database Engine 2007" in "Add and Remove" programes of other servers, where it is running fine. So, will that help, if I install "MS Access Database Engine" in this server as well.

    http://www.microsoft.com/downloads/en/details.aspx?familyid=7554F536-8C28-4598-9B72-EF94E038C891&displaylang=en  

     

    • Marked as answer by geek_jumper Friday, November 19, 2010 5:36 AM
    Wednesday, October 20, 2010 4:48 AM
  • Hi,

    I think this issue is caused by you are running 64-bit windows and there are no MS Access drivers that run 64-bit. So I suggest you trying to change your build configuration to x86. You can do that on the project properties dialog under "Compile>Advanced Compile Options...>Target CPU". Change it to "x86". Then clean and rebuild your solution.

    Hope that helps.


    that's true if you are working in a 64-bit machine. Change the compile option to X86 solved my issue. Thanks a lot!
    • Proposed as answer by Liudi90 Wednesday, April 25, 2012 2:19 AM
    Thursday, February 24, 2011 2:12 PM
  • Sorry if this is bringing up an old thread, but google returned this to me and I solved the problem myself, so I thought I would explain my different solution.

    I also received this error about Microsoft.ACE.OLEDB.12.0 not being registered on the local machine. I tried changing my build to x86 as suggested. Still didn't work. Finally, I realized that I don't have Access 2007, I have the 2010 version. Don't know if that matters, but I do know that installing the 2007 Office System Driver: Data Connectivity Components did solve the problem. Hope it helps!

    • Proposed as answer by David Schlum Friday, September 09, 2011 9:56 PM
    • Marked as answer by David Wolters Monday, March 12, 2012 6:21 PM
    Tuesday, August 02, 2011 2:24 PM
  • Sorry if this is bringing up an old thread, but google returned this to me and I solved the problem myself, so I thought I would explain my different solution.

    I also received this error about Microsoft.ACE.OLEDB.12.0 not being registered on the local machine. I tried changing my build to x86 as suggested. Still didn't work. Finally, I realized that I don't have Access 2007, I have the 2010 version. Don't know if that matters, but I do know that installing the 2007 Office System Driver: Data Connectivity Components did solve the problem. Hope it helps!


    I was getting the same error when trying to import data from an Excel 2007 Spreadsheet into a SQL Server 2008 R2 database using SQL Server 2008 R2 Management Studio. I also had Office 2010 installed instead of Office 2007. I was able to fix the issue using tom.anderson's suggestion of installing the 2007 Office System Driver: Data Connectivity Components.
    • Proposed as answer by Mesillaguy Tuesday, December 27, 2011 2:42 PM
    Friday, September 09, 2011 9:58 PM
  • Thanks.

    Saved me time...

    Friday, September 23, 2011 10:02 PM
  • This an happen because of mismatch in application compiler settings and xBits version installed on a syste. Refer http://yoursandmyideas.wordpress.com/2011/02/05/how-to-read-or-write-excel-file-using-ace-oledb-data-provider/
    Thursday, November 03, 2011 4:13 AM
  • Thanks David -- That solution worked perfectly!
    Tuesday, December 27, 2011 2:42 PM
  • If you have 64 bit machine and 32 bit office 2010 intsall on your machine and you are getting the above error then follow the below link.

    http://www.arboundy.com/2010/11/the-microsoft.ace.oledb.12.0-provider-is-not-registered-on-the-local-machine/

     

     

    Thanks

    Shukraj khadse


    Thursday, January 19, 2012 11:43 AM
  • In my scenario I had no issue with 32-bit Office 2010 running on 64-bit windows 7.
    However, with 64-bit Office 2010, I encountered the Microsoft.ACE.OLEDB.12.error.  The installation of 2007 Office System Driver: Data Connectivity Components resolved it.
    Friday, February 17, 2012 3:06 PM
  • Thank you, Mr. Anderson. 
    Tuesday, April 17, 2012 7:34 PM
  • Thank You tom.anderson ! 2007 Office System Driver: Data Connectivity Components did solve the problem!

    Cheers, Stephan

    (Win7 Enterprise x64; Office Pro 2010 x64; VS C# 2010)


    To life is christ, to die is gain...


    • Edited by Stepe Saturday, May 12, 2012 9:05 AM
    Saturday, May 12, 2012 9:03 AM
  • Thanks a Ton!!!...It really saved me a lot of time


    Friday, May 25, 2012 10:07 AM
  • Hi,

    I think this issue is caused by you are running 64-bit windows and there are no MS Access drivers that run 64-bit. So I suggest you trying to change your build configuration to x86. You can do that on the project properties dialog under "Compile>Advanced Compile Options...>Target CPU". Change it to "x86". Then clean and rebuild your solution.

    Hope that helps.


    This worked for me on a 64-bit server with Visual Studio 2012 and Access 2010 (x86) installed
    • Proposed as answer by CodeGirl19 Tuesday, September 03, 2013 4:06 PM
    • Unproposed as answer by CodeGirl19 Tuesday, September 03, 2013 4:07 PM
    Friday, November 30, 2012 9:45 PM
  • See here:

    http://kambiz-na.blogspot.com/2012/12/microsoftaceoledb120-provider-is-not.html

    Wednesday, December 12, 2012 8:09 AM
  • Thanks a lot Tom. I had the same issue and solved following the above steps. 
    • Edited by SQL KD Tuesday, February 12, 2013 6:25 PM
    Tuesday, February 12, 2013 6:25 PM
  • hi geek,

    I also have the same problem, but this time around mine is just a normal laptop running on x64 architecture.

    Pls me fix this; i know yours worked.

    Thanks...

    Friday, February 15, 2013 5:04 AM
  • You are the man! Thank you very much.
    Friday, July 19, 2013 8:55 PM
  • Thank you!!! It worked perfectly and I was under a lot of pressure with production support... :) 
    Wednesday, July 31, 2013 1:57 PM
  • Thanks, that solved the issue for me too!
    Thursday, August 08, 2013 9:39 AM
  • This error usually occurs when there is a mismatch between the bits allocation of the system on which the application  is built and that of the server system it is hosted into.

    If the base system is 32-bits and server is say, 64 bits....This error will erupt.

    To resolve,

    1.) Go to IIS on the server

    2.) Check for the application pool on which the website is hosted.

    3.) Right Click on that application pool and go to properties.

    4.) Set "Enable32-bitsApplication" to true.

    • Proposed as answer by Florin Gugui Wednesday, November 13, 2013 1:33 PM
    Thursday, August 29, 2013 9:26 AM
  • This worked for me, many thanks save me a lot of time.

    

    Tuesday, September 03, 2013 4:08 PM
  • Thanks I have same issue realted to office.But now its working well..thanks again
    Tuesday, November 26, 2013 10:43 AM
  • Thanks, this resolved my issue, down loaded and installed the data connectivity components
    Monday, February 17, 2014 6:18 PM