none
Public Folder forward option "Leave message intact" not working

    Question

  • I've seen a few older postings about this, but none of them have a solution.  We've upgraded to Exchange 2013 and we're using Public Folder rules to forward messages. When we set the forward type to be "Leave message intact", the message never gets forwarded.  The other two options "Standard" and "Insert message as an attachment" work fine.  In Exchange 2007 the "Leave message intact" option worked also.  I've seen some suggestions to use transport rules, but that won't work for what we're trying to do, so I'm wondering if there's another workaround for this issue.

    Thanks,

    Richard


    Thanks, Rich

    Thursday, February 19, 2015 4:34 PM

Answers

  • Hi,

    I searched a lot, this issue is a known problem in Exchange 2013. Currently, there is no fix for this issue.

    To work around this problem, you can use the following command.

    Set-MailPublicFolder "mail enable public folder" -ForwardingAddress "address" -DeliverToMailboxAndForward:$True

    Thannks for understanding.

    Best regards,

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com


    Belinda Ma
    TechNet Community Support

    Friday, February 20, 2015 6:09 AM
    Moderator

All replies

  • Hi,

    I searched a lot, this issue is a known problem in Exchange 2013. Currently, there is no fix for this issue.

    To work around this problem, you can use the following command.

    Set-MailPublicFolder "mail enable public folder" -ForwardingAddress "address" -DeliverToMailboxAndForward:$True

    Thannks for understanding.

    Best regards,

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com


    Belinda Ma
    TechNet Community Support

    Friday, February 20, 2015 6:09 AM
    Moderator
  • Unfortunately, that's not a sufficient workaround.  We need to forward emails based on different criteria, such as sender, subject, etc.  This will not let us do that.  Can you find out when Microsoft plans to address this issue?

    Thanks,

    Richard


    Thanks, Rich

    Friday, February 20, 2015 4:06 PM
  • Hi,

    Currently, there is no official document about this problem. Let's wait for the fix for this issue with patience.

    Thanks for understanding.

    Best regards,

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com


    Belinda Ma
    TechNet Community Support

    Monday, March 02, 2015 1:03 AM
    Moderator
  • Any updates on this issue? 
    Thursday, July 09, 2015 2:52 PM
  • Doesn't seem like it yet. I've had a call open with Microsoft for 34 days now and have been through 5 or 6 different technicians. I stumbled on this post today and brought it to their attention, they seemed unaware it was an issue at all. Running CU7 on the servers that currently host the PF mailboxes so I can confirm the problem is happening at least through that level.
    Wednesday, August 12, 2015 6:59 PM
  • Hopefully we'll finally get some attention on this.  I can't believe others aren't screaming about this.  It's really affecting our ability to filter out emails from our public folders.

    Rich


    Thanks, Rich

    Wednesday, August 12, 2015 7:06 PM
  • We were screaming about this issue 18 month ago. Can't believe the MS techs were unaware of the Problem till Aug 2015 !!
    We've spend a lot of hours to clean up the mess caused by this behavior and mainly to find the reason.


    • Edited by ICEBIT Tuesday, September 22, 2015 9:43 AM
    Tuesday, September 22, 2015 9:42 AM
  • I'll add my name to this list. I have a customer that was using Exchange 2010 on-premise They had over 100 rules setup in the Folder Assistant to forward emails to subfolders and delete the original, using the Leave Message Intact option. It worked great. There were different teams and each team monitored different subfolders.  All emails came in through a single shared address, and were auto-distributed. Well, on 10/16, they moved to Office 365, and on 10/19 they realized two things:

    1. The rules on the public folder didn't carry over (this was a cutover migration, and the public folders were 'migrated' by exporting to a PST, then importing the PST into the new public folder database)
    2. After recreating a few rules, it was quickly discovered that the forward option was silently failing, but it was successfully deleting the originals.

    So, instead of moving emails, they were just discarded.  I've had a case open with Microsoft for 24 days now, and today I was notified it was moved up to Escalation Services. The engineer I am working with now said he "found an active investigation with Product Engineering for an issue where Contributor rights fail to execute public folder rules."  His suggestion was to change the permissions for both Anonymous and Default from Contributor and Reviewer to Author (for both).  I did, no change.  He did mentioned it may take some time for the cached permissions to clear out, but I figured I'd post here so I could find my way back to update if I ever find a resolution or if someone reading this has one.


    Sr System Engineer | Vision One IT Consulting | www.v1corp.com

    Friday, November 13, 2015 1:17 AM
  • Hi,

    we are having the same issue. In our case "leave message intact" works in case a sender in an internal user and can be authenticated, but the rule does not work, if an user is external or in case an email is sent by an application with an open relay.

    We finaly got an official answer from the Microsoft that the fix will be delivered in Exchange 2013 Cumulitive Update 13. So we are looking forward to test it, hope it works.

    Friday, May 20, 2016 1:04 PM