none
Continuous Outlook prompts (Not the usual suspects) RRS feed

  • Question

  • Yes, I am having an issue and am in need of assistance.

    ISSUE
    Outlook 2013/2016 are continuously prompting for credentials. You can can the prompt, double click the "Disconnect or Need Password" and it will work for a few minutes, then prompt again.

    CAUSE
    Powershell 5.0 was installed on the Exchange 2013 server when it should not have been during our update cycle. Issue was noticed yesterday when EMS was unable to connect. Powershell 5.0 was uninstalled and server was restarted. From that point on, Outlook has started prompting for credentials. This wasn't occuring before. All settings for Autodiscover, permissions, etc seem to be correct.

    SERVER
    2012 R2
    Exchange 2013 CU13 (just installed today as wasn't aware I was missing it)
    Single server hosting all roles

    *** UPDATED INFO ***
    - .Net 4.6.1 was installed BEFORE CU13
    - WMF 5.0 was installed and uninstalled
    KB3146715 has been installed

    CLIENTS
    W7/8.1/10
    Outlook 2013 and 2016 (365 local install)

    Thanks!


    • Edited by CraigMCSA Thursday, August 18, 2016 3:52 PM
    Thursday, August 18, 2016 2:47 PM

Answers

All replies

  • Hi

    Did .Net 4.6.1 also apply? What errors are you seeing in the logs.


    Edward van Biljon - Exchange MVP

    Thursday, August 18, 2016 3:08 PM
    Moderator
  • Ya I just realized .Net 4.6.1 was also applied. I just finished applying KB3146715 to see if that solves anything. Otherwise I might just uninstall 4.6.1 (which I probably should have done).

    Thursday, August 18, 2016 3:16 PM
  • If you on CU13 then it is supported else you should remove it.

    Edward van Biljon - Exchange MVP

    Thursday, August 18, 2016 3:18 PM
    Moderator
  • It was installed before CU13 was installed. I don't know how that one wasn't installed already, but I just did that this morning also. So I was in an unsupported config with 4.6.1 (Pre CU13 being installed) and WMF 5.0 installed.
    • Edited by CraigMCSA Thursday, August 18, 2016 3:20 PM
    Thursday, August 18, 2016 3:19 PM
  • yes if you had .net 4.6.1 prior to CU13 then you should have uninstalled it :-)

    Edward van Biljon - Exchange MVP

    Thursday, August 18, 2016 3:21 PM
    Moderator
  • Do you suggest uninstalling 4.6.1?

    I have applied CU13 and the KB3146715 but issue still persists. Not seeing anything really standing out in Application logs. Anywhere else nothing stands out either.

    Thursday, August 18, 2016 3:25 PM
  • You can but it will take a bit of cleanup to get it gone.

    Edward van Biljon - Exchange MVP

    Thursday, August 18, 2016 3:30 PM
    Moderator
  • Do you have any other thoughts or places to start looking?
    Thursday, August 18, 2016 3:36 PM
  • Reverted to .Net 4.5.2 via following procedure:

    1. If the server has already automatically updated to 4.6.1 and has not rebooted yet, do so now to allow the installation to complete
    2. Stop all running services related to Exchange.  You can run the following cmdlet from Exchange Management Shell to accomplish this:  (Test-ServiceHealth).ServicesRunning | %{Stop-Service $_ -Force}
    3. Go to add/remove programs, select view installed updates, and find the entry for KB3102467.  Uninstall the update.  Reboot when prompted.
    4. Check the version of the .NET Framework and verify that it is showing 4.5.2.  If it shows a version prior to 4.5.2 go to windows update, check for updates, and install .NET 4.5.2 via the KB2934520 update.  Do NOT select 4.6.1/KB3102467.  Reboot when prompted.  If it shows 4.5.2 proceed to step 5.
    5. Stop services using the command from step 2.  Run a repair of .NET 4.5.2 by downloading the offline installer, running setup, and choosing the repair option.  Reboot when setup is complete.
    6. Apply the February security updates for .NET 4.5.2 by going to Windows update, checking for updates, and installing KB3122654 and KB3127226.  Do NOT select KB3102467.  Reboot after installation.
    7. After reboot verify that the .NET Framework version is 4.5.2 and that security updates KB3122654 and KB3127226 are installed.
    8. Follow the steps here to block future automatic installations of .NET 4.6.1.

    Issue still persists.

    Thursday, August 18, 2016 4:50 PM
  • Not sure what may have fixed it, but issue has gone away. Been prompt free for ~1 hour on multiple users.
    Thursday, August 18, 2016 7:17 PM
  • Glad its all working, sorry for the delay.

    Edward van Biljon - Exchange MVP

    Friday, August 19, 2016 11:40 AM
    Moderator
  • Hi,

    Glad this issue solved, and please share your solution if it's possible.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Allen Wang
    TechNet Community Support

    Friday, August 19, 2016 11:41 AM
  • What's the fix?
    Have the same problem with exchange and outlook.

    I only didn't have .NET 4.6.1 installed.

    Tuesday, September 20, 2016 8:28 AM