Excel cannot complete this task with available resources. Choose less data or close other applications


  • I am using Excel 2007 and on Windows 7 laptop.  Each time I try to copy and paste in an excel workbook, I get the following error:  "Excel cannot complete this task with available resources.   Choose less data or close other applications".  I'm not sure what I need to do in order to get rid of this message.


    • Moved by Sally Tang Monday, August 23, 2010 8:45 AM (From:Office 2007 Application Compatibility)
    Friday, August 20, 2010 4:30 PM


  • Hi,


    Go to the folder:

    C:\Documents and Settings\\<username>\ Application Data\Microsoft\Excel (for Windows XP)

    C:\Users\<username>\AppData\Local\Microsoft\Excel (For Windows Vista and Windows 7)

    and delete all the files in that folder.

    Best Regards,


    Sally Tang

    • Marked as answer by Sally Tang Thursday, August 26, 2010 8:51 AM
    Monday, August 23, 2010 8:51 AM

All replies

  • Hi,


    Go to the folder:

    C:\Documents and Settings\\<username>\ Application Data\Microsoft\Excel (for Windows XP)

    C:\Users\<username>\AppData\Local\Microsoft\Excel (For Windows Vista and Windows 7)

    and delete all the files in that folder.

    Best Regards,


    Sally Tang

    • Marked as answer by Sally Tang Thursday, August 26, 2010 8:51 AM
    Monday, August 23, 2010 8:51 AM
  • sally

    i am working with windows 7, and you said to go to "

    C:\Users\<username>\AppData\Local\Microsoft\Excel (For Windows Vista and Windows 7)".

    However, on my machine it is not in \Local\ but in \Roaming\.  why is there a difference please, and does it matter?


    • Proposed as answer by charlyto83 Wednesday, August 28, 2013 12:15 PM
    Friday, October 15, 2010 11:35 AM
  • Sally,


    C:\ Users\<username>\AppData\Local\Microsoft \Excel is not there.

    Within the Microsoft folder there is an Office folder containing two folders: 12.0 (empty) and ONetConfig (two files: f0b1f0037a277fb88e72b38bd2e30c

    c2.xml, and f0b1f0037a277fb88e72b38bd2e30cc2.sig). There is also a file (PowerPoint.qat), but that's it for the folder Office.

    Thursday, March 10, 2011 8:14 PM
  • I am having the same issue described in this thread. I am running 32 bit Office 2010 Professional in 64 bit Windows 7. I frequently get this error exporting dynamic worksheets out of Microsoft CRM 4, when clicking on data, connections, properties (to see the SQL query that was execuited) even with very small spreadsheets. The link

    C:\Users\<username>\AppData\Local\Microsoft\Excel (For Windows Vista and Windows 7)


    doesn't exist in Windows 7.

    Any other ideas about how to fix this very annoying issue?


    Monday, May 16, 2011 12:35 PM
  • So no one has any answers for this? I am surprised that Microsoft hasn't picked up and figured this out yet. There is no excel  folder on my C:\users\(name)\appdata\local\Microsoft.

    So just abandon the thread and wish the users good luck? impressive for Technet!

    Wednesday, May 18, 2011 3:33 PM
  • The correct path is:



    This is for Windows 7.


    For the above, excel doesn't exsist in the above path.


    Hope this helps.

    Thursday, May 26, 2011 3:53 PM
  • Tried this solution on a clients computer with no effect.  Still encountering the "Out of Resources" error.  Windows 7 64-bit, the files the user is having the issue with are created in either Excel 2003 or 2010 32-bit.  Our Excel 2010 users have their default save format set to Excel 2003.
    • Edited by TSTI_EHeil Friday, September 16, 2011 9:49 AM
    Friday, September 16, 2011 9:49 AM
  • This work for my instance of this problem, running Windows 7 with MS Office 2010.

    Thanks for the tip.

    Monday, October 17, 2011 9:53 PM
  • Hi Guys,


    Thanks for the reply, but this is not a permanent solution. If i delete these files from the folder mentioned above, after some time the problem occures again.

    The real solution would be that these temporary files are not remain in this directory.

    Any ideas?





    Thursday, November 03, 2011 12:17 PM
  • Have you gotten a solution to this yet?  This error is affecting multiple users in my environment and I cannot find a solid answer on any forums.  This is driving me nuts.
    Tuesday, January 17, 2012 9:23 PM
  • Anyone???
    Monday, January 30, 2012 6:54 PM
  • Hi All, Even I have a same issue that I cant insert and Delate any data.But after so many research I got a resulation, iof anyone need to add the rows and remove rows let me know I will clarify.
    Tuesday, February 07, 2012 4:04 PM
  • I am also having the same issue with a user, it happens randomly, and does not seem to be related to a certain file, the user can have one file open, and the error "Excel cannot complete this task with available resources. Choose less data or close other applications" will pop up, but upon closing and opening the same file, I can open 15 files at the same time and get no error. Any help would be helpful. Thanks.   Running Win7 Office 2010 x64

    Thursday, February 09, 2012 6:51 PM
  • Hi Mahammad Rafi

    Could you please post your solution?

    Thursday, February 09, 2012 9:10 PM
  • One thing that seems to be working is to go into task manager and then click the processes tab then find Excel.EXE while someone is running excel,right click on excel.exe, and set priority to High.  Seems to be working so far.  If that doesnt work, you can adjust the affinity level
    Thursday, February 09, 2012 10:09 PM
  • Setting the process to High didn't help me but after closing EXcel I found that it was still running in the process tab. That indicates that Excel isn't closing down as it should. I killed the process and opened the file which restarted Excel and all went well. It's not a solution and it is annoying but works around the issue until MS gets off its duff and fixes it.


    Tuesday, March 13, 2012 2:01 PM
  • Hi,

    I have had the same problem with my notebook (Dell D620) since last week.

    And I did everything that you're saying without good solution.

    Then I remembered that I'd change my antivirus (avast to AVG) last week, so after undo this change (uninstall AVG) the problem disappeared.

    I hope this help you to resolve your problems.


    Monday, March 26, 2012 3:37 AM
  • Hi,

    the same problem. Want to import a text file , 44MB, but, ok, some lines would create 1600 columns.

    I tried all listed workarounds , but nothing helped.

    Other ideas ?

    thanks a lot Wolfgang

    Wednesday, April 04, 2012 7:41 AM
  • Hi,

    the same problem. Want to import a text file , 44MB, but, ok, some lines would create 1600 columns.

    I tried all listed workarounds , but nothing helped.

    Other ideas ?

    thanks a lot Wolfgang

    i have the same problem with a user ever since upgrading to a precision ws with 8gb of ram. he's in the acct dept and uses excel extensively. here's what i've managed to find so far. his custom toobar seems to be causing it. excel 2007 works fine on this machine. so,  uninstalled /reinstalled office 2010 64. no help. finally after long troubeshooting hrs I discovered he was using a custom toolbar with about 30 icons on it. removed toolbar. excel 2010 works fine without it. so he rebuilt the toolbar from scratch in excel 2010. worked for two days then error started again.  installed excel 2007 32 and it works fine with his custom toolbar.  i'm now in the 
    process of having him add one function at a time to the toolbar to see if its just one or more of the functions causing it or the custom toolbar itself.  We've spent a few hours on this and his lost production is not setting in very well. as for now he's using office 2010 without excel and just using excel 2007 just so that he can use his custom toolbar.  what a crock. but it is working. however you lose the "new" features in excel 2010. which he's not pleased with at all.

    Wednesday, May 02, 2012 3:21 PM
  • After over 3 years of no problem, this started happening about a month ago.  To resolve temporarily, I close files and restart Excel - but eventually I can't open files. 

    My problem may have something to do with my  add-in "Classic Menu for Office v7.00".  I'm going to turn off this add-in to see if problem gets resolved.  I hope it something else because I very much prefer the classic Excel menus, and dislike the ribbons.

    Windows 7, Office 2007

     PS  Thanks for nothing Sally Tang & microsoft

    • Edited by Albiee Tuesday, May 08, 2012 8:56 PM
    Tuesday, May 08, 2012 8:54 PM
  • I had faced the same problem out there. Anyone has the solid solution for this kind of problem?
    • Proposed as answer by Wee Dod Thursday, May 24, 2012 1:25 PM
    • Unproposed as answer by Wee Dod Thursday, May 24, 2012 1:25 PM
    • Proposed as answer by Wee Dod Thursday, May 24, 2012 1:32 PM
    Wednesday, May 09, 2012 2:03 AM
  • We have found that on our network that you have to save it in compatibility mode (excel 97 – 2003 Workbook) so you can manipulate the data. Anything saved as a regular workbook we get the same message.

    • Proposed as answer by MJO tech Monday, May 14, 2012 6:51 PM
    Monday, May 14, 2012 6:50 PM
  • Hi Craved.

    We were having issues with sorting data in either small or large Excel files.

    We have machines running Windows 7-64bit / Office 2010 SP1-32bit with all current Windows / Offrice updates applied.

    The answer to our problem was to remove the following Security Update for MS Excel 2010 - KB2597166.

    Tested by attempting to open the spread sheet on various PC's and the one's with the above update always failed.

    We removed the update and since then we haven't had the problem. Changed it to hidden in Windows updates too so the user can accidently install it again.

    Hope this helps.

    Wee Dod.

    • Edited by Wee Dod Thursday, May 24, 2012 1:44 PM
    • Proposed as answer by doktorlenz Tuesday, June 05, 2012 5:13 PM
    Thursday, May 24, 2012 1:32 PM
  • That's interesting and would seem to point directly to a cause. I've found that on two identical machines both with Excel fully patched that the machine without any menu changes or add-ons - asap tools for example - loads the spreadsheet without giving me any silly messages. The system with the add-ons will load it if I turn off the preview pane in explorer. The system without add-ons has the preview pane turned on and as I said hasn't presented the issue. Seems to be wrapped around the menu system somehow, triggered perhaps by that security update.

    Wish MS would work on this instead trying to sell me 2010, I'm using 2007


    Thursday, May 24, 2012 2:09 PM
  • Hi Merlin,

    Our issue sorting data in Excel 2010. This could be 10 rows or 100,000 rows. Either way it failed if the update was installed.

    Removed it and everything worked fine.

    Have you checked the Microsoft Security Bulletin MS12-030?

    There is a KB Listed for Office 2007. Just a thought.

    Wee Dod

    Thursday, May 24, 2012 2:35 PM
  • Hi Wee Dod,

    I had Office 2010 on my office PC for month now, but automatic update was the last thing I suspected. Deinstallation of the Security Update for MS Excel 2010 - KB2597166 was my solution.

    The error message occured, when I tried to sort a very large list. But it worked on an less enhanced machine with Office/Excel 2007. So thanks for your solution :)

    Greetings from Hamburg, Germany


    Tuesday, June 05, 2012 5:28 PM
  • This worked for us as well.

    Thank You,


    Tuesday, June 05, 2012 8:50 PM
  • Thanks a million for this answer Wee Dod!!  Uninstalling the KB2597166 update resolved the issue for us as well.  Now, here's the next do we make sure that Microsoft truly fixes this issue?
    Thursday, June 07, 2012 5:18 PM
  • Hi Mahammad,

    Can you please clarify the resolution?  I'm having the same issue, and can't figure out a more permanent solution.

    Monday, June 11, 2012 9:42 PM
  • I have 2 machines, one Win XP 32 bit with Office 2010 and one Win 7 64 bit with Office 2010 both fully patched.  Both with the same problem.  Uninstalling the KB2597166 update resolved the issue for us as well. Not sure what the patch was supposed to fix.
    Tuesday, June 12, 2012 5:54 PM
  • I did not have KB2597166 installed. So an un-install was not the solution for me.

    Running a "Repair" option in Office 2010 removed the error message for me.

    • Proposed as answer by Ragnar_B Tuesday, March 19, 2013 7:48 PM
    Friday, June 22, 2012 4:25 PM
  • I simply saved it as a 97-2003 format and then reopened it.  Worked well.  Something was also stopping me from clicking on the File tab after this error.  This is a common way to fix items if the file does not have 2010 specific options.  My data was an export from Access.  Hope this helps.
    Friday, June 22, 2012 7:16 PM
  • Look for a fix in Windows 10.  MSFT has some quality, fairly simple to use products.  But when I boot up a Linux distro and I can sort over 100,000 records on a certain open source project from a fat CSV file on an inferior machine **Faster** than I can resolve what's going on with my Excel 2010 on Windows 7 Pro .... well, something is really wrong here.

    MSFT can't seem to grasp how many people like me have been so close to dropping MSFT all together.  Every month or two I have a *major* MSFT specific issue that brings my small office to a standstill.  I cannot do business this way.  We're already moving away from Outlook and IE, with a second string of machines running Linux.  The way things are going, it won't be long before we must drop everything MSFT and go to Apple or a Linux distro.

    Maybe someone in Redmond is listening .......

    Monday, August 27, 2012 6:50 PM
  • I tried every fix on the internet for the "not enough resources" error in Excel 2010 with no luck. It wasn't until I started looking at the version of Excel that I had a break through. By default Office is installed as 32-bit, but you can install a 64-bit version that allows Office to use all the resources that a work station has. 32 bit Excel only allows 2GB, whereas 64 uses all resources. This link explains how you should use 64 bit Office 2010 and how to install 64-bit editions of Office 2010 We have accountants that work with huge spread sheets and would always run into this issue after Office upgrade to 2010, once I switched them to Office 64-bit the problem stopped.  BTW go to file>help in any Office 2010 program to see what version you are running.
    Thursday, September 13, 2012 6:33 PM
  • Resaving the .xlsx as .xls made this problem disappear for me.

    I'm running Excel 2010 on Win 7 64 bit.

    • Proposed as answer by Sara in SLC Thursday, September 20, 2012 5:44 PM
    Thursday, September 20, 2012 5:43 PM
  • I had the same issue and it seems to be fixed when I did the following:

    Saved the excel doc as a Microsoft Excel file and then converted it to a Micosoft 97 file.

    After the conversion I made sure that all of the cells that were supposed to be empty were actually empty and did so by just highlighting those cells, hitting delete and confirming the deletion by removing those columns (or rows).

    Convert the Excel 97 file back into significantly reduced the size of the file and made it much more easy and take much less time to manipulate.


    Wednesday, October 17, 2012 4:57 PM
  • Hello,

    I have found exactly what fixes my 64bit Win7 Pro HP 12 GB memory 3.20 GHz machine when this 'error' occurs:

    As one poster stated, Alt-Cnrl-Delete to the Task Manager.  Under the Processes tab, sort Image Name, and END the process EXCEL.exe (after saving any open Excel files and closing them).

    Then reopening any Excel file works aok for me.


    Monday, October 29, 2012 5:25 PM
  • Didnt work for me. Running windows 7 64 bit / office 2010. I removed the update. Seemed to slow the problem down a bit but didnt fix the problem all way. I then decieded to roll back to excel 07 and the issue came back immediately. Now what todo.

    Thursday, March 14, 2013 8:42 PM
  • The Path you want to go to is "C:\Users\%USERNAME%\AppData\Roaming\Microsoft\Excel" with out the " " marks. By using %username% it will grab the user name you are currently logged in as.
    Wednesday, June 12, 2013 5:12 PM
  • recently i came across the same situation c.q. error indicating. My solution was:

    Basic information: Excel version 2013 EN

    a. Remove all files under the Auto Recover directory. This location can be found in excel under: options - Save - Under " Save workbooks" look for the autorecover file location.

    b. In windows set the DEP option to Turn on DEP for all programs and services except those I select

    c. This is the last option in case the problem persist, Run the a Office Repair.

    Wednesday, June 26, 2013 10:06 AM
  • Franklyn,

    Doesnt help...Can some one solve this error for me in office 13

    Monday, August 12, 2013 7:05 AM
  • Problem stopped for me after running C Cleaner
    • Proposed as answer by charlyto83 Wednesday, August 28, 2013 12:14 PM
    • Unproposed as answer by charlyto83 Wednesday, August 28, 2013 12:15 PM
    • Proposed as answer by charlyto83 Wednesday, August 28, 2013 12:15 PM
    Saturday, August 17, 2013 12:17 AM
  • Run a repair of office, that worked for me.

    Office 2010 on Windows 7 64 bits.

    Wednesday, August 28, 2013 12:16 PM
  • I'm using Office 2010. 

    Excel recently started misbehaving and throwing the 

    Excel cannot complete this task with available resources. Choose less data or close other applications 

    error. Based on some answers here, I uninstalled the latest MS security update for excel (in my case

    The error hasn't popped up so far. Hope this helps some other folks.

    Friday, September 06, 2013 7:34 AM
  • Try:

    C:\Users\<username>\AppData\Roaming\Microsoft\Excel (For Windows Vista and Windows 7)

    Hope this helps,

    Wednesday, September 25, 2013 5:43 PM
  • Hi

    this works for me :)

    thank you

    Tuesday, October 01, 2013 9:14 AM
  • I have one user (Windows 7 Pro x64, Excel 2010 x64, all current updates applied for both) who is experiencing this issue repeatedly.  We have tried every possible fix from Security Update for Excel KB2597166 does not show in the list of installed updates. The user does not have any menu customizations in Excel. There are no special add-ins in her Excel.

    The problem shows up when the user receives an Excel spreadsheet (doesn't matter with what version it was created, doesn't matter if it is .xls or .xlsx) via Outlook. She clicks on the spreadsheet attachment in Outlook to view it in Preview mode. She will then double-click the attachment and instead of Excel opening to show the spreadsheet she receives the error message "Excel cannot complete this task with available resources. Choose less data or close other applications." After this message appears Excel will not open again until either she reboots the computer or deletes the contents of the Roaming / Excel folder in AppData. However even when she deletes the contents of that folder Excel sometimes still won't start without the error message. Task Manager does not show a running Excel.exe process. When it gets to this point the only fix is to reboot the computer.

    Any OTHER ideas, Microsoft? This has gotten beyond annoying at this point. We have tried everything under the sun, including replacing the computer, to no avail.

    Wednesday, November 20, 2013 7:30 PM
  • This describes perfectly the problem that one user has here. Except the spreadsheet is just opened from Outlook without a preview.
    Wednesday, November 27, 2013 3:50 PM
  • I received the same message runnning Macros from *.xlsm files, I changed them to *.xls and the problen disappear.
    Tuesday, December 03, 2013 2:14 PM
  • I just had this problem with one of my users and came here looking for answers.  I tried to save as XLS instead of XLSX and I got a warning that columns and rows past a certain limit (56k or something) wouldn't be saved.  So I looked at the workbook, which contained about 6 sheets, none of them too huge.  However, on one of the sheets I noticed the horizontal scroll bar was extremely long, as if the sheet had thousands of columns, even though there was no visible data past maybe 30 columns.

    So I copied the 30 columns to a new sheet, deleted the original sheet, that fixed it.

    Something to try.

    Tuesday, December 03, 2013 5:00 PM
  • Mine got fixed by following number 5 from this Microsoft article:

    microsoft kb  2779852

    Method 5: Test a different Default Printer

    When Excel launches, it uses the default printer to help render the file. Try testing with the "Microsoft XPS Document Writer" as the default printer and see if we continue to get the error. To do this;
    Close Excel
    Open the printer and faxes window (XP) or Devices and Printers (Vista, 7, 8)
    Right click the "Microsoft XPS Document Writer" printer
    Click Set as Default

    Tuesday, January 07, 2014 6:23 AM
  • Not sure if it's related, but I was getting the same error and found I had data in one of the last cells, which made the document incredibly big. I couldn't find where the actual cell was, but when I saved it as Excel 97/2000 it gave a compatibility warning that I would lose it.

    Saving it as Excel 97 and then saving it back to 2010 fixed the problem for me.



    • Proposed as answer by Chris Ekin Thursday, February 13, 2014 7:08 PM
    Thursday, February 13, 2014 7:08 PM
  • They are listening, but they also listen to the huge number of people who want new features and other issues worked on before the more obscure version-related problems with complex files. 

    I've had this issue several times, and the less-IT-skilled people I work with allow it to stop them in their tracks. I have found that in most cases the file can be saved under a new name or new version and this eliminates the problem, which in my opinion is actually wrapped up in the hidden file properties that Microsoft uses to manage the file backup/temp process that is always working behind the scenes as you modify your file.

    As for moving to Apple or a Linux app...LOL. Been there...done is in no way better than what you are facing here. Just different. Apple will not lock up as often, just make sure you only want the features they offer and never need to share with many other users. Linux? You want new features? Get coding then....

    Thursday, May 15, 2014 3:15 PM
  • Having the exact same problem since installing Security Update for Microsoft Excel (KB2826033) 32-Bit Edition published 10/8/2013. Removed it, and it's back to working.

    Thanks Wee Dod for the tip. 

    Saturday, May 17, 2014 1:20 PM
  • I'm running windows 7 and found the files in the excel folder. Deleted all files. There were a couple that weren't files. Hope that doesn't cause me problems. Will let you know if it works. 
    Monday, May 19, 2014 9:09 PM
  • After trying many of the solutions found here and elsewhere in the internet. I found a simple (strange) solution that might work for you. Just save the workbook before doing the thing that create the problem. For example, I just saved the workbook before running the macro that will not work and produced this message and it works fine. I tried it many times and it works perfectly! for me. Save the workbook even if you just opened it.

    I hope it works for you,

    Good Luck

    Mubarak ALmutairi

    Friday, August 01, 2014 6:49 PM
  • Hello all,

    I have the same problem here and as you can see the user only have 1 Excel file opened and don't tell me the problem is because she has a lot of another programs there. The laptop has 4Gb of RAM enough RAM to do this.

    I have tried any of the solutions listed here but any of them has solved the problem

    1.- I have deleted the files in the path C:\Users\%USERNAME%\AppData\Roaming\Microsoft\Excel

    2.- I have uninstalled Office 

    3.- I have delete temp files

    4.- I have formated Windows

    5.- I have looked for the Updates

    6.- I have cleaned the register

    7.- I have replaced the laptop but...


    And this behavior is occuring in another user. There is one thing I have noticed between both of them, the files they use uses macros and are the same files also the files were created in Office 2003. It has to be a problem between versions and macros. My solution was simple... Start using LibreOffice and don't pay to Microsoft.

    Thursday, September 25, 2014 4:17 PM
  • I saved the xlsm, xlsb files as old format xls, and now it is working. Hope it helps.
    Friday, January 09, 2015 2:15 AM
  • For my scenario, killing "taskhost" process from Task Manager --> Processes did the trick.
    Thursday, June 25, 2015 3:11 AM
  • So far deleting the folders from user profile helped me.
    Friday, August 07, 2015 8:53 PM
  • for Windows 7 is the one with Roaming


    Thursday, October 01, 2015 7:02 AM
  • I know this post is old, but we are having this problem also.  You would think for the money Microsoft is taking from companies, Excel would just work! This post should not even exist!  So damn frustrating.
    Tuesday, September 26, 2017 6:09 PM