none
WMI Invalid class 0x80041010 RRS feed

  • Question

  • I wrote a script to perform a WMI software audit of my network in powershell.  The script runs fine however some workstations return an Invalid Class error.  If I run the a software query on the workstation/server locally I get:

    wmic /Failfast:on /node:"ausdc01" product GET /all

    Node - AUSDC01
    ERROR:
    Code = 0x80041010
    Description = Invalid class
    Facility = WMI

    We are talking random 2003 and XP PC's that are experiancing this problem.

    I am also getting the following event error logs:

    Event Type: Error
    Event Source: WinMgmt
    Event Category: None
    Event ID: 10
    Date:  1/12/2009
    Time:  9:57:43 AM
    User:  N/A
    Computer: AUSDC01
    Description:
    Event filter with query "select * from MSMCAEvent_MemoryError where (type = 3221553223) and (LogToEventlog <> 0)" could not be (re)activated in namespace "//./root/WMI" because of error 0x80041010. Events may not be delivered through this filter until the problem is corrected.

    Event Type: Error
    Event Source: WinMgmt
    Event Category: None
    Event ID: 10
    Date:  1/12/2009
    Time:  9:57:43 AM
    User:  N/A
    Computer: AUSDC01
    Description:
    Event filter with query "select * from MSMCAEvent_PCIBusError where (type = 2147811416) and (LogToEventlog <> 0)" could not be (re)activated in namespace "//./root/WMI" because of error 0x80041010. Events may not be delivered through this filter until the problem is corrected.

    Event Type: Error
    Event Source: WinMgmt
    Event Category: None
    Event ID: 10
    Date:  1/12/2009
    Time:  9:57:43 AM
    User:  N/A
    Computer: AUSDC01
    Description:
    Event filter with query "select * from MSMCAEvent_SMBIOSError where (type = 3221553253) and (LogToEventlog <> 0)" could not be (re)activated in namespace "//./root/WMI" because of error 0x80041010. Events may not be delivered through this filter until the problem is corrected.

    Event Type: Error
    Event Source: WinMgmt
    Event Category: None
    Event ID: 10
    Date:  1/12/2009
    Time:  9:57:43 AM
    User:  N/A
    Computer: AUSDC01
    Description:
    Event filter with query "select * from MSMCAEvent_CPUError where (type = 2147811392) and (LogToEventlog <> 0)" could not be (re)activated in namespace "//./root/WMI" because of error 0x80041010. Events may not be delivered through this filter until the problem is corrected.

    Event Type: Error
    Event Source: WinMgmt
    Event Category: None
    Event ID: 10
    Date:  1/12/2009
    Time:  9:57:43 AM
    User:  N/A
    Computer: AUSDC01
    Description:
    Event filter with query "select * from MSMCAEvent_PlatformSpecificError where (type = 3221553255) and (LogToEventlog <> 0)" could not be (re)activated in namespace "//./root/WMI" because of error 0x80041010. Events may not be delivered through this filter until the problem is corrected.

    Can anyone shed some light on this please?


    Clint Boessen MCSE, MCITP: Messaging
    Perth, Western Australia

    Blog: http://clintboessen.blogspot.com/
    Tuesday, December 1, 2009 2:38 AM

Answers

All replies