none
User Profile Synchronization Error - AutoSPInstaller RRS feed

  • Question

  • I installed SharePoint 2010(with SP2 on Windows Server 2008 R2 & SQL is 2012) using AutoSPInstaller in our test environment. Everything went fine until the script tried to create User Profile synchronization. I was getting the error as below when executing the step below.

    $newProfileServiceApp = New-SPProfileServiceApplication -Name "User Pro
    file Service Application" -ApplicationPool "SharePoint Hosted Services" -Profil
    eDBServer daa30471spt -ProfileDBName SPT_UserProfile -ProfileSyncDBServer daa30471spt -ProfileSyncDBName SPT_Profile_Sync -SocialDBServer daa30471spt -SocialD
    BName SPT_Profile_Social -MySiteHostLocation http://mysites.companyname.com:8080
    -MySiteManagedPath "personal"                                                                                                                                      ERROR MESSAGE:

    Creating User Profile Service Application as domain\SPT_Farm...
    New-SPProfileServiceApplication : The EXECUTE permission was denied on the obje
    ct 'sp_send_dbmail', database 'msdb', schema 'dbo'.
    At C:\Users\SPT_admin\AppData\Local\Temp\AutoSPInstaller-ScriptBlock.ps1:3 c
    har:56
    + $newProfileServiceApp = New-SPProfileServiceApplication <<<<  -Name "User Pro
    file Service Application" -ApplicationPool "SharePoint Hosted Services" -Profil
    eDBServer daa30471spt -ProfileDBName SPT_UserProfile -ProfileSyncDBServer daa30471spt -ProfileSyncDBName SPT_Profile_Sync -SocialDBServer daa30471spt -SocialD
    BName SPT_Profile_Social -MySiteHostLocation http://mysites.companyname.com:8080
    -MySiteManagedPath "personal"
        + CategoryInfo          : InvalidData: (Microsoft.Offic...viceApplication:
       SPCmdletNewProfileServiceApplication) [New-SPProfileServiceApplication], S
      qlException
        + FullyQualifiedErrorId : Microsoft.Office.Server.UserProfiles.PowerShell.
       SPCmdletNewProfileServiceApplication

    C:\Users\SPT_admin\AppData\Local\Temp\AutoSPInstaller-ScriptBlock.ps1 :  - F
    ailed to create User Profile Service Application
    At line:1 char:73
    + C:\Users\SPT_admin\AppData\Local\Temp\AutoSPInstaller-ScriptBlock.ps1 <<<<

        + CategoryInfo          : NotSpecified: (:) [Write-Error], WriteErrorExcep
       tion
        + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorExceptio
       n,AutoSPInstaller-ScriptBlock.ps1

    Press any key to exit...

    I skipped creating the user profile and completed the installation. Now I am trying to create using the CA using spt_admin account but still get the same error

    Please note that SPT_Farm account is a local admin and has logon locally on the application server and on the SQL both SPT_Admin & SPT_Farm has dbcreator, securityadmin roles and dbowner permission on all the databases.

    Any pointers for troubleshooting this is appreciated.




    • Edited by ViviSP Tuesday, March 28, 2017 3:20 PM
    Tuesday, March 28, 2017 3:16 PM

All replies

  • These service accounts must be domain accounts.  Additionally, the UPA account must have at least Replicate Changes permission in the domain.  See:

    Tuesday, March 28, 2017 5:05 PM
  • SPT_admin & SPT_Farm are domain accounts. I understand that sync account needs replicate directory changes in AD. However my User Profile configuration is failing in the very first step of creating the service application itself.

    I need some pointers to trouble shoot the issue.

    Between the ULS logs has the following error.

    Critical   Insufficient SQL database permissions for user 'Name: domain\SPT_admin SID: S-1-5-21-9852693-1636384874-311576647-95779 ImpersonationLevel: Impersonation' in database 'master' on SQL Server instance 'daa30471spt'. Additional error information from SQL Server is included below.  The EXECUTE permission was denied on the object 'sp_send_dbmail', database 'msdb', schema 'dbo'.           35162035-98a6-4700-824a-8b7c59d14f59



    • Edited by ViviSP Tuesday, March 28, 2017 6:26 PM
    Tuesday, March 28, 2017 6:26 PM