none
Moss 2010 Backup Fail with error: Reason: 15105

    Question

  • Hi, i am trying to make a manual Moss 2010 backup but it is failing.

    Is Moss i get the following for just about every DB:

    Object SharePoint2010_Config failed in event OnBackup. For more information, see the spbackup.log or sprestore.log file located in the backup directory.
    SqlException: Cannot open backup device 'C:\Backups\Moss\Manual\201008031220\spbr0000\000000C9.bak'. Operating system error 3(failed to retrieve text for this error. Reason: 15105).
    BACKUP DATABASE is terminating abnormally.

    On SQL ServerApp Log:

    BackupDiskFile::CreateMedia: Backup device 'C:\Backups\Moss\Manual\20100803\spbr0000\000000D5.bak' failed to create. Operating system error 3(failed to

    retrieve text for this error. Reason: 15105).

    and

    BACKUP failed to complete the command BACKUP DATABASE Application_Registry_Service_DB_6084142b7e3d473b8873362a35ff3fc0. Check the backup application log for detailed messages.

    Still having a look in SQL logs but not seing much...

    Thanks

     

    Tuesday, August 3, 2010 12:13 PM

Answers

  • Solution

    http://social.msdn.microsoft.com/Forums/en-US/sqldisasterrecovery/thread/1ee3dc8e-e11d-431d-9fa8-cfce93a968d9

    1) Launch SQL Server Configuration Manager - you should be able to find this program on your: Start menu -> All Programs -> Microsoft SQL Server 2008 -> Configuration Tools -> SQL Server Configuration Manager

    2) Expand tree view "SQL Server Services". On right pane, youl will see the list of Services installed. In my case, I will have to look at the SQL Server 2008 R2 instance. Previously, it was set to run under "NT AUTHORITY\NETWORK SERVICE"

    3) Click on this SQL Server instance -> Properties and change the "Log on" to LOCAL SYSTEM. The system will prompt you that it needs to restart the SQL Service. Please do so.

    4) Once this is done, you can then backup your database without any hassles!

    • Marked as answer by Danie Claassen Wednesday, April 10, 2013 7:31 AM
    Wednesday, April 10, 2013 7:31 AM

All replies

  • Probably a permission issue....Give SQL Server account read/write access to the folder c:\Backups.

    • Proposed as answer by BigFive Sunday, August 28, 2011 6:40 AM
    Tuesday, August 3, 2010 12:22 PM
  • i made the the sql user a local admin on the moss server
    Tuesday, August 3, 2010 12:27 PM
  • Can you please try backing up to a different drive and see if it makes any difference ? Also what OS are you running ?
    Tuesday, August 3, 2010 12:33 PM
  • ok, think it might be related to UAC... let me play around a bit.

     

    Tuesday, August 3, 2010 12:47 PM
  • It might be...try to run IE , SSMS as an administrator (Right click the shortcut and select run as admin from the context menu).
    Tuesday, August 3, 2010 1:10 PM
  • i have set UAC to the lowest level of security...

    I gave the user full right on the folder.

    It works if i point it to a external drive but not to a local drive...

    Anyway, can make backup to the external drive but of there is more suggestions im listening. This UAC cause more problems than it solve i think?

     

    Wednesday, August 4, 2010 11:36 AM
  • in my experience, free more space on the backup drive
    Wednesday, February 23, 2011 2:44 PM
  • I had a similar problem when i tried to take a backup.

    I was able to save the backup to the default folder C:\Program Files\Microsoft SQL Server\MSSQL10_50.MSSQLSERVER\MSSQL\Backup\

    but not to for example D:\Backup\

    I checked the default backup folder's security properties in explorer and noticed a user called SQLServerMSSQLUser$servername$MSSQLSERVER had some permissions. So i added the same user to D:\Backup security properties with the same permissions and it worked.

    Friday, March 30, 2012 12:18 PM
  • Hi,

    You need to create a Share and then give farm admin account and  the account running SQL server modify access to the share and NTFS.


    Regards
    Henrik A. Halmstrand
    sharepointrevealed.com
    getspconfig.codeplex.com
    Please click Mark As Answer; if a post solves your problem or Vote As Helpful; if a post has been useful to you.

    Friday, March 30, 2012 12:23 PM
  • It's picking up Backup location from the Registry - you need to change registry value on SQL server to location you want/that exists.

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\MSSQL.2\MSSQLServer\BackupDirectory

    Friday, March 30, 2012 9:21 PM
  • Solution

    http://social.msdn.microsoft.com/Forums/en-US/sqldisasterrecovery/thread/1ee3dc8e-e11d-431d-9fa8-cfce93a968d9

    1) Launch SQL Server Configuration Manager - you should be able to find this program on your: Start menu -> All Programs -> Microsoft SQL Server 2008 -> Configuration Tools -> SQL Server Configuration Manager

    2) Expand tree view "SQL Server Services". On right pane, youl will see the list of Services installed. In my case, I will have to look at the SQL Server 2008 R2 instance. Previously, it was set to run under "NT AUTHORITY\NETWORK SERVICE"

    3) Click on this SQL Server instance -> Properties and change the "Log on" to LOCAL SYSTEM. The system will prompt you that it needs to restart the SQL Service. Please do so.

    4) Once this is done, you can then backup your database without any hassles!

    • Marked as answer by Danie Claassen Wednesday, April 10, 2013 7:31 AM
    Wednesday, April 10, 2013 7:31 AM