none
Pending messages when email sent in to shared group RRS feed

  • Question

  •  Hi All, 

    Our organisations runs an on premise version of exchange 2013 CU 21 with 12 servers and 4 DAGs (3 servers per DAG)

    A few of our servers were recently migrated by a third party over to a new site/data center and ever since the migration we have encountered numerous issues.

    The issue i am looking in to at the moment and hoping to get some help on is that we have a universal mail enabled global IT security group with 3 mail enabled global security groups as similar to the below

    (G) BHV (GL) IT Infrastructure  (Universal Security)

    Inf UK (GL Security)

    Inf Asia (GL Security)

    Inf US (GL Security)

    When a member of the team, not just 1 member but all sends an email in to the group, sometimes it will send fine to all 31 recipients, but when sent again later it will only send to 18 or another amount less than 31. We have viewed this via running the delivery reports from ECP, the messages that don't send have a state of pending.

    I have Microsoft on the case also, but dont seem to be getting very far at the moment. 

    Thanks






    Thursday, September 19, 2019 12:02 PM

All replies

  • Hi,

     

    1.What's the target group? The universal mail enabled security group or one of the global mail enabled security groups?

    2.Are the pending messages delivered eventually?

     

    If the messages are not delivered finally, the sender would receive NDR messages. Please also provide the entire NDR message; If the messages are delivered, there might be some delay between different groups location, Exchange servers performance etc. 

     

    Regards,

    Kelvin Deng


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com


    • Proposed as answer by ThinkCenter Monday, September 23, 2019 8:02 AM
    Friday, September 20, 2019 3:21 AM
  • Hi,

     

    I am writing here to confirm with you how the thing going now?

     

    If you need further help, please provide more detailed information, so that we can give more appropriate suggestions.

     

    Regards,

    Kelvin Deng


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com


    Wednesday, September 25, 2019 7:30 AM
  • Hi Kelvin, 

    Thanks for getting back to me on this and sorry for the delay in response.

    1) The universal group

    2) Some of the messages are still in a pending state, this example was on the 05/09/2019 and have never been successfully delivered. I also noticed on the track and trace that it sometimes doesn't see the full 31 recipients. on the attached screenshot, its sees only 18 recipients and not the full 31.




    Wednesday, September 25, 2019 8:29 AM
  • Hi,

     

    I understand one sub team members send messages to the root team, sometimes messages to part of recipients are stuck. 

     

    You could open queue viewer and check if the message is stuck in the queue. The "Last Error"  tab shows the casue.

     


     

    For the missing messages, use the Message Tracking Log both on sender side server and the recipient side server to see if the missing messages departed/received.

     

    Get-TransportService | Get-MessageTrackingLog -Sender User@domain.com -Recipients recipient@domain.com -MessageSubject "Subject" | Sort-Object Timestamp

     

    The inbound messages also might stuck in queue, check it.

     

    Regards,

    Kelvin Deng


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com


    Monday, September 30, 2019 9:24 AM
  • Thanks Kelvin, i will check this.
    Tuesday, October 1, 2019 7:23 AM
  • Hi,

     

    I am writing here to confirm with you how the thing going now?

     

    If you need further help, please provide more detailed information, so that we can give more appropriate suggestions.

     

    Regards,

    Kelvin Deng


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com



    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com


    Monday, October 7, 2019 8:45 AM
  • Hi Kelvin, 

    We have since been migrated onto different exchange servers and the problem no longer exists.

    Thanks for all your help on this. 


     

    Monday, December 30, 2019 4:40 PM