none
Outlook 2010 Blocked Sender List Not Populating RRS feed

  • Question

  • Perhaps I'm doing something wrong or missing something.  But, I'm having trouble with the spam settings with Outlook 2010 (Professional Plus (x86) version on Windows 7 Ultimate (x64)).  In a nutshell, when I tell Outlook an email is spam, it doesn't remember it.

    • On the Options tab of Junk Email Options, I've got it set to High.
    • On the Safe Senders tab, I've deleted everything and then confirmed that the list repopulates as I select "Never Block Sender" from the junk options for an email.  Currently, I've got just one item in that list.
    • Safe Recipients is empty.
    • On Blocked Senders, I've deleted everything.  From a piece of spam, if I select Block Sender from the Junk options, Outlook promptly moves the email to the Junk folder, but does NOT put anything onto the Blocked Senders list.  New pieces of spam from that same address do NOT get treated as junk.  However, from the Blocked Senders tab, if I select the Add button and manually add an address, it shows up in the list.
    Anyone else seeing this?  Am I missing something?
    Monday, May 31, 2010 4:38 PM

Answers

  • Is anyone with this problem having multiple e-mail accounts delivered to the same PST file by any chance?

    This type of setup is seriously broken in Outlook 2010 (duplicates mail). I also found it displays the WRONG junk filter dialog box. The safe/block list is stored per account so next time you visit the Junk Options dialog, take a look at the title bar of the dialog - is the account name correct?

    It adds the blocked sender to the correct list but displays details for the wrong account when you go to check your settings. This only happens if you have multiple accounts setup for the same PST.


    MikeMcr,

    It's very possible you just solved my problem.  I have two email accounts being delivered to the same Inbox in the same .PST.  When I look at the title bar of the Junk Options filter, I see what you're talking about.  More specifically, I see the name of the Default email account in the title bar.  If I switch my Default email account under File | Account Settings | Account Settings | E-mail, that name changes to the new Default and, lo and behold, those Blocked Senders (and all the rest) appear.  I was seeing the same junk mail because it was coming in through different accounts and each account has its own set of lists.  I'll have to watch this for a while to make sure, but, again, I think you've solved my problem.

    Now, as for Microsoft, I disagree with their new treatment of email accounts.  Personally, I don't care which email account a message comes in from (though I can see that others might care).  I think it's silly to have the default profile creation process create a separate .PST for each email account.  I was miffed while trying to trouble-shoot this problem when I had to manually switch the destination for those email accounts back to the same Inbox of the .PST I wanted to use each time I created a new profile.  I'd much rather it worked the way it used to (i.e., email came in and I could apply rules to dump it into the folder I wanted).  But, this bit with each email account having its own set of lists, WITHOUT TELLING US AND WITH NO WAY TO SWITCH LISTS WITHOUT SWITCHING THE DEFAULT EMAIL ACCOUNT, takes the cake.  But, even forgetting the lack of notification or ability to switch lists, what's the logic of having separate lists?  If I want to block a sender (or allow one), why would I care which email account it came from?  Spam is spam.  Non-spam is non-spam.  It doesn't matter if a Viking gives it to me or a waitress does.  I either like it or I don't.  No matter who serves it up, I'm either going to eat it or toss it on the floor.  This should be a global filter.

    Anyway, thanks to MikeMcr.

    EDIT:  Another problem with treating these lists as local to the specific email account is that the Options tab of the Junk E-mail Options dialog is also treated as a local setting.  Specifically, each email account defaults to Low (I believe) junk email protection (this could very well be the problem that Charles Hull is seeing with the automatic spam filter using Microsoft's OUTLFLTR.DAT -- it's set to a low level of protection on his problem account).  Once again, I have to ask Microsoft, what logic they used to come up with this?  Did they think that the user would say:  "Gee, I don't want any virus and trojan filled phishing garbage coming into my system from Account A.  But, if it comes in via Account B, that's OK?"

    Sunday, June 27, 2010 12:03 PM

All replies

  • Hi David,

    I suggest you try to check the total size of blocked sender list. As total size of all lists combined cannot exceed 512K. Once the 512K limit is reached, Outlook alerts you and additional addresses aren't saved until you remove some from the list.

    If your issue is caused by the limited size, you can add a new registry key value to the following registry key:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem\

    Add a new DWORD value of Type Max Extended Rule Size and edit the Value Data, entering the maximum size (in bytes) you want to allow.

    If your issue is not related to limited size, try to keep your junk e-mail filter updated. Each version of Microsoft Outlook that contains a junk e-mail filter receives updates to the data file (outlfltr.dat) as part of the Microsoft-wide monthly update released on the second Tuesday of each month. The updated outlfltr.dat is the result of the evaluation of hundreds of thousands of spam messages and constantly increases the filter “catch” rate for incoming junk email.

    The recommended way to obtain updates to the Outlook Junk E-mail filter is by turning on the Automatic Updates option in the Windows Security Center.

    If you have done all above but it still not work, try to create a new outlook profile to test this issue.

    Go to Start > Control Panel, click Mail. The title bar of the Mail Setup dialog box contains the name of the current profile. To select a different existing profile, click Show Profiles, select the profile name, and then click Properties.

    Click Show Profiles. Choose Prompt for a profile to be used.

    Click Add.

    Type a name for the profile, and then click OK.

    Start Outlook, and choose this new profile.

     

    Tuesday, June 1, 2010 3:03 AM
    Moderator
  • Regarding the size of my lists:  unless there's something hidden, the total size of all my lists combined is somewhere on the order of 0 (zero) bytes.   I've manually deleted everything from the Safe Senders, Safe Recipients, and Blocked Senders list.  I have manually added 4 email domains (i.e., "@something.com") to the Blocked Senders list in an attempt to see if that works.  However, even though the names get added to the list, Outlook doesn't treat the incoming mail from those domains as junk.  I've also never gotten any kind of alert about the size of those lists (at most, I've had 30 or 40 entries in them).  Is there a file name/location I should be looking for to check the size?

    As for keeping the filter updated, I always do.  Regardless, the automatic filters aren't the problem.  The problem is with adding Blocked Senders on my own from spam that makes it through those filters (those filters do seem to be working, btw).

    Following your advice about trying a new profile, I set up a test profile.  The Blocked Senders list works fine there.  Is there some way to import all the data from one profile into another?

    Tuesday, June 1, 2010 8:00 PM
  • Following your advice about trying a new profile, I set up a test profile.  The Blocked Senders list works fine there.  Is there some way to import all the data from one profile into another?


    Hi David,

    You can export .pst file data from your old outlook profile and then import it into new outlook profile.

    To export an individual folder, such as the Contacts folder or the Calendar folder, follow these steps:

    1. On the File menu, click Import And Export.
    2. Click Export To File, and then click Next.
    3. Click Personal Folder file (.pst), and then click Next.
    4. Click the folder that you want to export, and then click Next.
    5. In Save exported file as, type the name of the file to which the data is exported.
    6. Click Finish.

    To import a .pst file into Outlook, follow these steps:

    1. On the File menu, click Import And Export.
    2. Click Import from another program or file, and then click Next.
    3. Click Personal folder file (.pst), and then click Next.
    4. Type the path and the name of the .pst file that you want to import, and then click Next.
    5. Click the folder into which the data is imported.
    6. Click Finish.
    Wednesday, June 2, 2010 3:46 AM
    Moderator
  • It's still not working.  Making the assumption my profile was ok and the problem was with the .pst file, I exported my .pst from my existing setup into a new one and then opened and used that one instead.  Same problem.  So, I created a new profile and told it to use that quasi-new .pst file as the destination for my email.  I opened Outlook with the new profile, saw that the proper .pst file was being used, and found the same problem:  Outlook will not populate the Blocked Senders list.  Since this worked with a new profile and a new .pst, but doesn't work with a new profile and an old .pst (even though I exported it to a new .pst thinking that any errors would get fixed in the process), I assume there's something wrong with my old .pst.  Is there some utility or method to repair a .pst file?
    Thursday, June 3, 2010 2:25 PM
  • I have experienced same problem as described by David.  The problem started after upgrading from Outlook 2007 to Outlook 2010.  I've also removed all blocked senders lists but it does not add any new entries when I click on Block Sender from Junk option.  Also, even if I add the whole domain to the blocked lists, I still get junk emails sent from those blocked domains.  It must be a bug in Outlook 2010.
    Thursday, June 3, 2010 5:33 PM
  • Like MEGACOM, I, too, upgraded from Office 2007 to 2010 (I forgot to mention that earlier:  sorry).
    Thursday, June 3, 2010 6:45 PM
  • I assume there's something wrong with my old .pst.  Is there some utility or method to repair a .pst file?

    To repair the .pst file

    1. On the Start menu, click Run.
    2. In the Open box, type

      drive:\Program Files\Common Files\System\Mapi\LocaleID\scanpst.exe

      where LocaleID is the locale identifier (LCID) for your installation of Microsoft Office. For example, the LCID for English (United States) is 1033. For a list of LCIDs, see Microsoft Office Help.

    3. Click OK.
    4. In the Enter the name of the file you want to scan box, type the path and file name given in the error message above.

      Note  You may not be able to use the Browse button to locate this file because it is located in a hidden folder.

    5. To change the options for logging errors during the scan, click Options. If you choose Replace log or Append to log, the log file is saved to the same directory as the .pst file.
    6. Click Start.
    7. When the file scan is completed, select the Make a backup of scanned file before repairing check box.
    8. Click Repair.

    If the file is successfully repaired, you will see a Repair complete message.

    Friday, June 4, 2010 1:08 AM
    Moderator
  • I'm in the process of trying SCANPST.EXE now.  But, I just wanted to mention that the path name is very different in Office 2010.  Instead of being under:

    C:\Program Files\Common Files\System\Mapi\1033\SCANPST.EXE,

    it's under:

    "C:\Program Files (x86)\Microsoft Office\Office14\SCANPST.EXE"

    UPDATE :  Nope.  It still doesn't work.  I ran SCANPST.EXE as noted, above.  It said "only minor inconsistencies were found in this file...."  I told it to repair them, but that Blocked Senders list still doesn't populate.

    Also, (and this started before I did the repair, so it's not associated with that), even though I had earlier said that the Safe Senders list was populating fine, it now appears that that's not always true.  Today, I tried adding a couple of addresses to that list by saying "Never Block Sender" and "Never Block Sender's Domain."  When I checked the Safe Senders list, I found that they hadn't been added.  Later, I did a "Never Block Sender" and it did get added to the list.

    I don't know what's happening with the Junk mail processing in Outlook 2010.  But, it sure looks like it's broken to me (i.e., a bug).

    Friday, June 4, 2010 11:44 AM
  • I upgraded from office 2007 to beta 2010 and had the problem.  Then I tried uninstalling beta 2010 and installed full version of 2010 still having same issue.  let me know if the scan works out for you.

     

    Thanks

    Thursday, June 10, 2010 9:47 PM
  • David, wanted to give you an update.  My problem was that the blocked senders list would populate but would not block messages.  I just created a brand new profile with a new .pst file and everything is working fine now.  I think it is having a problem with a O2k7 pst file.  You may want to try a new .pst file and then just mount your old .pst file to move your messages.

     

    Thursday, June 10, 2010 9:57 PM
  • I am having the same problem. I created a new PST file, but still cant add anything to the blocked senders list.
    Friday, June 11, 2010 12:42 AM
  • ...You may want to try a new .pst file and then just mount your old .pst file to move your messages.

     

    I tried exporting and importing my old .PST data into a new profile again and it still doesn't work.  When you say "mount your old .pst...," do you mean to just open it up in the new .PST and then manually copy the messages from  the old set of folder into the new ones?  That will handle the old "data."  But, what about things like the old Address Book, Contacts, and Tasks (I know I can export and then import my old Rules)?  Can those be copied similarly?
    Wednesday, June 16, 2010 9:32 PM
  • Using the new profile I'd created earlier in this thread, I started using a new .PST file.  The Blocked Senders list STILL does not populate.  Just for completeness, my process of producing the new .PST was:

    • While using my new profile and old .PST, I went to the New Items | More Items | Outlook Data File on the Home tab and created a new .PST with the same name as my old one but in a different folder.
    • Under the File tab, I went to Account Settings | Account Settings | Data Files and opened that data file
    • Back on the Home tab, I went to the bottom of the left-hand folder pane and selected the Folder List (CTRL+6) icon
    • From there, I copied all my own folders, the contents of the Sent Items folder, the Contacts folder, and the Tasks folder from my current .PST to the new one.
    • I then closed Outlook, moved my old .PST to yet another folder and moved my new .PST to my regular Outlook Files folder.  When I started Outlook again, it complained about not being able to find the folder, but it actually was there.  I shut down Outlook and restarted it and everything was there
    • But, as noted above, when I get a piece of Junk mail and tell it to Block Sender, nothing gets added to the Blocked Sender list.

     

    Monday, June 21, 2010 6:29 PM
  • I have a problem similar to David's, I can't populate the Blocked Sender List.  Also, no obvious junk mail is being blocked - I'm not sure whether I have an outlftl.dat file, or if I do Outlook doesn't seem to be using it.

    This was also an upgrade from Office 2007 to 2010, and I'm running Windows 7, 32 bit.  For this update I had uninstalled Office 2007 and then installed Office 2010.  Outlook 2010 found my outlook.pst and brought up the history and accounts.

    I have a second home computer which is okay.  This computer was running Office 2010 beta, and has been switched to released Office 2010.  It is running Windows 7 64 bit.  In this case the Blocked Sender List populates okay.  I can't find outlfltr.dat on that system - don't know how hidden this might be.

    FYI I am also running Outlook 2010 at work on Exchange and the Outlook junk mail filter is working okay.

    I have not tried setting up a new profile.  Also I can't find outlook.pst to scan it with scanpst.exe - it seems to be hidden somewhere.  I did save a backup.pst and scanned that; it reported just minor errors.

    Is it possible to find outlfltr.dat and outlook.pst in Windows 7?  How do you find the size of the blocked sender list file?

    Are there any ideas to get the junk mail filter working?

    Wednesday, June 23, 2010 4:22 AM
  • Charles,

    On my x64 system, OUTLFLTR.DAT is in the same folder as SCANPST.EXE:

    "C:\Program Files (x86)\Microsoft Office\Office14\"

    You can find where Outlook is storing your .PST from within Outlook by going to the File tab, selecting Account Settings (and then Account Settings again underneath that (why it's set up like that, I don't know)), and then looking under the Data Files tab on the box that pops up.

    I, too, would like to know where the manually added lists are kept and how to determine their sizes.

    EDIT:  While I was digging around on my system to find OUTLFLTR.DAT, I noticed that the Data Modified field in Windows Explorer for the file was 07/23/2009.  So, I renamed it and started up Outlook.  Outlook said it was configuring something.  When it was done, I closed it and found a new OUTLFLTR.DAT that was still dated 07/23/2009 and had the same size as the old one.  Interesting that Microsoft doesn't modify the date of that file when it updates it (probably because of configuration/security management or something).

    Wednesday, June 23, 2010 12:03 PM
  • David, thanks for the help, I ran SCANPST.exe on OUTLOOK.pst and it found and fixed quite a few errors.  However this didn't fix the Blocked Senders List problem.

    Jennifer - have you been able to duplicate this problem yet?

    Wednesday, June 23, 2010 2:26 PM
  • Hi Charles,

    I couldn't duplicate this problem. As I said before, you can try to create a new outlook profile. Always it is the simplest way.

    Thursday, June 24, 2010 8:25 AM
    Moderator
  • For me, creating a new profile only works as long as I don't copy my old data into it.  Where is the Blocked Senders list kept?  How do I determine its size?
    Thursday, June 24, 2010 11:45 AM
  • It's interesting that the problem still has not been resolved after almost 2 months.  It seems that everyone who had reported this problem so far seems to have been affected by this problem after upgrading from 2007 to 2010 version.  I am not a programmer but has been working in IT business for 17 years and it sure looks like a software bug to me (problem description is very consistent among users who had reported the problem in this forum) which Microsoft should seriously look into and provide a fix/solution for this annoying problem as many users will soon be upgrading from previous version to OL2010.   

    Yes - I've tried everything that Jennifer and others had suggested and still the same issue.  We've configured 3 different Exchange accounts from OL2010 and only the account that had been upgraded from OL2007 is affected by this problem. 

    Thursday, June 24, 2010 7:27 PM
  • I've tried everything I can think of, includng re-installing, and still no solution.

    My main issue is that the Outlook spam filter isn't working.  One of my old email accounts is a spam magnet and it really fills my inbox, so I need a solution.  In the past I have used Cloudmark anti-spam, I think it was with 2003, and it did a good job - so I checked the Cloudmark site and they have a beta anti-spam program for Outlook 2010.  I've installed this and it seems to be doing a very good job.  The beta is free, I think until September - I've lost track of what their annual fee is but as I recall it was reasonable.  If you want something to block spam this may be an alternative.

    Saturday, June 26, 2010 1:42 AM
  • I couldn't duplicate this problem. As I said before, you can try to create a new outlook profile. Always it is the simplest way.

    Jennifer,

    Just to be sure, I once again created yet another new profile.  This time, I used the .PST that new profile created as my default location.  Going the opposite way from what I documented above (i.e., this time I opened my old .PST file while I was using the new .PST as the default location), I copied my old emails, contacts, and tasks to that new .PST.  Then I imported my old rules.  IT STILL DOES NOT WORK.  The Blocked Senders list doesn't populate.  Thankfully, unlike Charles Hull's problem, the automatic spam filter using Microsoft's OUTLFLTR.DAT works on my system.  But, I have no way to manually block senders.  I need a solution to this.

    Saturday, June 26, 2010 12:28 PM
  • Since I upgraded from Office 2007 to 2010 I have had the same problem. In addition, my HTC phone no longer syncs with my Outlook data.

    To correct the sync problem I installed Office 2010 on a Vista Business machine, clean install, never had Office before. This immediately fixed the sync problem but left me with this inability to add people to the junk email list. My OUTLFLTR.DAT is about 3800 bytes, there is no registry entry as purported earlier in this thread to adjust size and I have not found an answer for this "glitch" anywhere.

    HELP.

    Saturday, June 26, 2010 2:09 PM
  • Is anyone with this problem having multiple e-mail accounts delivered to the same PST file by any chance?

    This type of setup is seriously broken in Outlook 2010 (duplicates mail). I also found it displays the WRONG junk filter dialog box. The safe/block list is stored per account so next time you visit the Junk Options dialog, take a look at the title bar of the dialog - is the account name correct?

    It adds the blocked sender to the correct list but displays details for the wrong account when you go to check your settings. This only happens if you have multiple accounts setup for the same PST.

    Sunday, June 27, 2010 8:24 AM
  • Is anyone with this problem having multiple e-mail accounts delivered to the same PST file by any chance?

    This type of setup is seriously broken in Outlook 2010 (duplicates mail). I also found it displays the WRONG junk filter dialog box. The safe/block list is stored per account so next time you visit the Junk Options dialog, take a look at the title bar of the dialog - is the account name correct?

    It adds the blocked sender to the correct list but displays details for the wrong account when you go to check your settings. This only happens if you have multiple accounts setup for the same PST.


    MikeMcr,

    It's very possible you just solved my problem.  I have two email accounts being delivered to the same Inbox in the same .PST.  When I look at the title bar of the Junk Options filter, I see what you're talking about.  More specifically, I see the name of the Default email account in the title bar.  If I switch my Default email account under File | Account Settings | Account Settings | E-mail, that name changes to the new Default and, lo and behold, those Blocked Senders (and all the rest) appear.  I was seeing the same junk mail because it was coming in through different accounts and each account has its own set of lists.  I'll have to watch this for a while to make sure, but, again, I think you've solved my problem.

    Now, as for Microsoft, I disagree with their new treatment of email accounts.  Personally, I don't care which email account a message comes in from (though I can see that others might care).  I think it's silly to have the default profile creation process create a separate .PST for each email account.  I was miffed while trying to trouble-shoot this problem when I had to manually switch the destination for those email accounts back to the same Inbox of the .PST I wanted to use each time I created a new profile.  I'd much rather it worked the way it used to (i.e., email came in and I could apply rules to dump it into the folder I wanted).  But, this bit with each email account having its own set of lists, WITHOUT TELLING US AND WITH NO WAY TO SWITCH LISTS WITHOUT SWITCHING THE DEFAULT EMAIL ACCOUNT, takes the cake.  But, even forgetting the lack of notification or ability to switch lists, what's the logic of having separate lists?  If I want to block a sender (or allow one), why would I care which email account it came from?  Spam is spam.  Non-spam is non-spam.  It doesn't matter if a Viking gives it to me or a waitress does.  I either like it or I don't.  No matter who serves it up, I'm either going to eat it or toss it on the floor.  This should be a global filter.

    Anyway, thanks to MikeMcr.

    EDIT:  Another problem with treating these lists as local to the specific email account is that the Options tab of the Junk E-mail Options dialog is also treated as a local setting.  Specifically, each email account defaults to Low (I believe) junk email protection (this could very well be the problem that Charles Hull is seeing with the automatic spam filter using Microsoft's OUTLFLTR.DAT -- it's set to a low level of protection on his problem account).  Once again, I have to ask Microsoft, what logic they used to come up with this?  Did they think that the user would say:  "Gee, I don't want any virus and trojan filled phishing garbage coming into my system from Account A.  But, if it comes in via Account B, that's OK?"

    Sunday, June 27, 2010 12:03 PM
  • I have gone through and set each of my accounts as the default and then checked the Junk Email Options. In each case the option is safe senders only.  However, all the junk email that should show up in my junk folder is showing in my inbox.  I migrated from Outlook 2007 (Windows 64 bit Professional for 2007 and 2010). I have multiple email accounts, but I do not have separate .pst for each account, only one .pst which is the file from my Outlook 2007 setup.

    When I manually block a sender it is showing up in the blocked sender list for each account, but this whole process is very cumbersome. I much prefer the way Outlook 2007 operated with regard to junk email and multiple email accounts.

    Wednesday, June 30, 2010 3:58 PM
  • So, no solution to this yet? Thread has gone very quiet, has everyone solved their problem or just given up?

    • Proposed as answer by ilinderoth Wednesday, February 19, 2014 10:44 PM
    Friday, October 15, 2010 7:31 AM
  • I have the same exact problem also.  Worked fine in 2010 beta, doesn't filter junk mail in purchased 2010 Office.  They all show up on the block sender list, but do not get blocked

     

    Tuesday, October 19, 2010 1:43 PM
  • I have a very similar problem, though not identical.

    I have an exchange account and several POP3 accounts. All the POP3 accounts go into the same PST which works perfectly.

    A few days ago though, my safe-senders list stopped working but it seems to only affect my exchange account (which of course doesn't use the PST file). If I add something to it, it doesn't remember it. Not only that, addresses which were in my safe-sender list are no longer recognised and so every email I receive I am having to click to view images etc.

    This is possibly the same 'bug' - has anyone had any joy in solving this yet?

    • Proposed as answer by BigDave76 Monday, March 7, 2011 9:01 PM
    • Unproposed as answer by BigDave76 Monday, March 7, 2011 9:01 PM
    Tuesday, December 7, 2010 2:06 PM
  • Wow, that solved my problem...  Thanks!
    Saturday, February 19, 2011 10:58 AM
  • I have a very similar problem, though not identical.

    I have an exchange account and several POP3 accounts. All the POP3 accounts go into the same PST which works perfectly.

    A few days ago though, my safe-senders list stopped working but it seems to only affect my exchange account (which of course doesn't use the PST file). If I add something to it, it doesn't remember it. Not only that, addresses which were in my safe-sender list are no longer recognised and so every email I receive I am having to click to view images etc.

    This is possibly the same 'bug' - has anyone had any joy in solving this yet?


    I was having similar difficulties with this type of issue being multiple POP accounts and a main defaulted exchange account being setup into the same PST file. I had inadvertantly added one of my own pop account addresses in the SAFE RECIPIENTS area that basically allowed ALL email to that account to be pushed into my inbox unabstructed. I tried switching that pop account to be the default account in order to go into the Account settings and adjust the listings - but that didn't work. In order to correct my problem I needed to recognize that each account had to be accessed in the junk properties by going into an email sent to that particular pop account and choose the Junk email properties from within the email while viewing the email. That way is the only way I could find that I could adjust each individual pop account junk email properties and it worked wonderfully.

    I hope that helps some of you.

     

    Monday, March 7, 2011 9:05 PM
  • OK, I have gone through this forum and am still confused.

    I upgraded to 2010 and am still using my 07 .pst file.

    I now understand that each e-mail account has now got it's own junk e-mail options.  That would be fine if I wanted to configure each one separately.

    Like many others here, I don't want them configured separately.  I want them to add/block all the same senders that I have tagged.

    Is there any way to make this happen?  Configuring them to respond to the same junk e-mail setup is the easiest and best way for folks like myself.

    Granted, this gives some users the capability to handle each account differently, but from  what I'm reading,this isn't the way a lot of people want to go.

    Is there a setting that can be changed to allow the junk e-mail to manage all accounts?

    Thanks


    Wednesday, March 16, 2011 1:24 AM
  • Is there anyone monitoring this site anymore.

    Not trying to be rude, just looking to see if anyone is around or if someone has an answer.

    Thanks

    Monday, March 21, 2011 10:53 PM
  • Is there anyone monitoring this site anymore.

    Not trying to be rude, just looking to see if anyone is around or if someone has an answer.

    Thanks


    i have been monitoring this question for awhile, hoping someone would provide an answer.  like others, i have outlook 2010 (fresh install) on win 7 32bit.  exchange environment, no pst.  email addresses i block whether full address or domain - continue to show up in my inbox.  it is like the junk settings just dont work at all in 2010.  i am current on updates, have tried the rebuild of profile, nothing helps.  nothing on microsoft site comes close to addressing this issue.  hope someone finds a fix soon.
    Friday, April 15, 2011 2:53 PM
  • Hi!

    Yes, I keep monitoring it as well hoping there will eventually be a solution, but sad there is none! :( I even tried a brand new profile last week to see if starting afresh would work, but, nope, no joy... do Microsoft even ADMIT to this being a bug??

    Keep smiling....  :)

    Friday, April 15, 2011 6:52 PM
  • Hi all,

    I ran across this thread while researching the same issue. I found the "official" answer here: http://support.microsoft.com/kb/2447034.

    Tom

    Friday, April 29, 2011 5:00 AM
  • Hi Tom. Thanks for the link, however, as I am sure most people would agree, hardly a good "solution" from Microsoft. A workaround that will take forever to do every time, what a joke! Why can't Microsoft just FIX this?!!!
    Friday, April 29, 2011 10:16 AM
  • Do they even listen to what they are proposing as a work-a-round.

    I have several accounts and to do this is too time consuming.

    Since they added this "feature", maybe they ought to give us the option to disable it.

    I figured out how to do this a couple of months ago once I realized what they had done.

    It easier to just kill the e-mail.

    One thing I do once in a while is update a master list and import it to each account.

    Still too much work for something that shouldn't have been broken to start with.

    Fred

    Monday, May 2, 2011 4:14 AM
  • Hi "Fred",

    Yes I do the same, just delete the mail now, but SO irritating as spam just keeps coming through. Show's what happens when someone gets so big they can just ignore their customers (who are the people who PUT them there) and walk all over them. I agree, a "feature", what a laugh!! GET RID OF THAT STUPID SO CALLED "FEATURE" NOW PLEASE MICROSOFT.

    Opps, forgot they don't read this stuff or listen to their customers.

    Oh well

    Have a GREAT day everyone!!

    :)

    • Proposed as answer by jfresh38 Monday, July 11, 2011 10:10 PM
    • Unproposed as answer by jfresh38 Monday, July 11, 2011 10:10 PM
    Monday, May 2, 2011 5:55 AM
  • Same (or very similar) problem here. Fresh install, only one IMAP account. Blocked senders not showing up on list, nor puts the letter to the trash.
    Monday, May 16, 2011 7:54 AM
  • Hi Tom. Thanks for the link, however, as I am sure most people would agree, hardly a good "solution" from Microsoft. A workaround that will take forever to do every time, what a joke! Why can't Microsoft just FIX this?!!!

    I have the same problem--blocked senders never appear on the blocked list-- and I never had 2007--just the install of 2010.  I do have 2 accounts on the same pst.

    I used the article from Tom to do a workaround...Except instead of inputting each address to the list, I exported from one account and imported into the other and then did it the other way around...took about 20 seconds all in all. Pain in the butt and it should "just work" without doing that, but I'll have to do this for now as I have WAY too much spam coming in.

    Jimmy

    Monday, July 11, 2011 6:57 PM
  • If if mark it as junk BEFORE I open the email....it works fine.
    Thursday, August 11, 2011 9:38 PM
  • Just found this thread.  Two years on from the issue being identified, Outlook 2010 STILL doesn't handle junk properly.  I have two accounts, each of which brings up the correct junk email options dialogue.  But "block sender" doesn't populate either of the blocked senders lists as it should.  I seem to be able manually to add the name of the offending sender, but surely this should all be fixed by now.

    BTW, I didn't upgrade from 2007 - clean install.

    Friday, February 24, 2012 8:53 AM
  • I have the same problem with outlook 2003, the only way I have worked arround it is to copy and paste the junk sender address to the blocked sender list and it stays there . I dont want to mess with new profiles and screw it all up.  The crazy thing is that outlook express works fine and is easier.
    Tuesday, March 6, 2012 3:27 PM
  • I am having the Identical problem as David.  He is not the only one that is missing something. Who do you contact to resolve the issue?
    Friday, March 9, 2012 6:41 PM