none
Cannot get Outlook 2016 to log into fresh Exchange 2016 environment RRS feed

  • Question

  • Hello,

    I am building up a fresh offline network that includes Exchange 2016 CU12.  It is residing on Server 2016. The client is Windows 10 with Office 2016 ProPlus. The client/Servers are patched to Janurary 2019 updates with the latest update for Outlook. The network is a flat network. I have tried exchange on both a VM(ESXI 6.7) as well as a physical box and get the same results.

    After building and configuring Exchange 2016 I can't get Outlook on my clients to connect. It runs through the wizard process and it I get all 3 green check marks. When outlook attempts to launch I get the message saying "Cannot start Microsoft Outlook. Cannot open the Outlook window. The set of folders cannot be opened. The file "blah.ost is not an Outlook Data File (.ost)". If I go into the mail control Panel setting and disable exchange cached mode I get the following message "Cannot start Microsoft Outlook. Cannot open the Outlook window. The set of folders cannot be opened. The attempt to log on to Microsoft Exchange has failed".

    I have a DNS CNAME for autodiscover that resolves properly. I have scoured the internet looking for solutions and have come up with a blank so far.

    Here is my troubleshooting steps up to this point:

    -It is not the 3 standard responses you see when you google this issue(I.e corrupt .ost file, reset nave pane or bad plugins.)

    -It happens to all users in the environment

    -I have verified all my virtual directories are pointing to the correct server name and as far as I can tell have the correct permissions.

    -When navigating to the autodiscover URL I do received the 600 error response

    -When launching outlook without an email account and testing email autoconfiguraton settings it successfully completes.

    -I have tried the registry key that disables MAPI and that did not help

    -I grabbed the Microsoft Connectivity Analyzer tool and copied it to my environment. Is also successfully ran and said it was able to connect.

    -I've tried different versions of Office(I.E 2013 with SP1 and 2016 32bit and 64 bit)

    -I've unchecked the proxy box in IE

    -Uninstalled and reinstalled exchange multiple times.  Both keeping the same server name and trying a different name.

    There is more that has been done, I am just trying to eliminate all the typical responses I have seen on all the other forums in regards to the topic. Any help would be greatly appreciated!

    Thanks!


    • Edited by jdycus002 Monday, March 4, 2019 6:01 PM
    Monday, March 4, 2019 3:42 PM

Answers

  • So after working with Microsoft yesterday we finally figured out what was going on.  Exchange 2016 now uses MAPI as the primary communication method between client and server which is well documented.  What is not well documented is the fact that on your client if you have an error on your network adapter MAPI will not attempt to connect. In my case where the network is offline there will always be an warning on the network adapter because of the no internet access.  You have to trick the machine into thinking it is connected to the internet or MAPI will never connect.  Below are the steps that are needed to accomplish this

    1. Create a text file:
      1. If your environment is Windows 10 only create a text file call “connecttest.txt”. Edit the text file and add the following text “Microsoft Connect Test” all on one line.  Do not add a line break after the text. Save the text file.
      2. If your environment will consist of both Windows 7 and Windows 10 follow step a first.  After step a is complete.  Create another text file called “ncsi.txt” Edit the text file and add the following text “Microsoft NCSI” all on one line.  Do not add a line break after the text. Save the text file.
    2. Configure a website that will host the .txt file(s) on port 80: Please note: According to Microsoft there is no way on the client side to tell the client to connect to another port other than 80. There are 3 options Microsoft gave to accomplish this task.
      1. If you already have an IIS server in your environment that is not utilizing port 80 this will work fine.
        1. Depending on your environment copy the text file(s) to the websites root directory. If using the default website site this would be  “%SystemDrive%\interpub\wwwroot”
      2. If you do not yet have an IIS server that is not utilizing port 80, pick a server in your environment and install the IIS role.  Just select the defaults when prompted. So special options needed.
        1. Depending on your environment copy the text file(s) to the default websites root directory “%SystemDrive%\interpub\wwwroot”
      3. If you have an IIS server that already has something being hosted on port 80 and you are comfortable adding another layer of complexity to your IIS environment, you can follow the steps in the link(s) below to allow multiple websites to share port 80.
        1. IIS 6 - https://support.microsoft.com/en-us/help/324287/how-to-use-host-header-names-to-configure-multiple-web-sites-in-intern
        2. IIS 7+ https://docs.microsoft.com/en-us/previous-versions/windows/it-pro/windows-server-2008-R2-and-2008/cc753195(v=ws.10)
        3. For both links if your environment is Windows 10 only the Website hostname will be www.msftconnecttest.com
        4. For both links if your environment is mixed then you will add 2 entries with the following hostnames:  www.msftconnecttest.com  and www.msftncsi.com
    3. Enable Directory Browsing on the website hosting your .txt file(s)
      1. Open IIS Manager
      2. Expand the tree until you find your website and then click on it
      3. In the middle pane double click on Directory Browsing.
      4. In the fa right pane click on “Enable”.  Leave all the check box’s default.
    4. Create a DNS Forward Lookup Zone(s)
      1. If your environment is Windows 10 only create a Forward Lookup Zone called “msftconnecttest.com”
      2. If your environment is a mixed environment, you will create 2 Forward Lookup Zone’s
        1. One called “msftconnecttest.com”
        2. One called “msftncsi.com”
    5. Within your newly created zone(s) you will create two A records:
      1. First A record will be called “www” and the IP will be the IP of your IIS server
      2. Second A record will be called “dns” and the IP will be the broadcast IP of your subnet
    6. Make sure the client can access the new website:
      1. Go to one of you clients and open a web browser.
      2. On a Windows 10 client navigate to http://www.msftconnecttest.com/connecttest.txt. If this resolve’s and shows you the contents of your text file, then you are good. If you can’t access the text file, then re-evaluate the previous steps and try again.
      3. One a Windows 7 client navigate to http://www.msftncsi.com/ncsi.txtIf this resolve’s and shows you the contents of your text file, then you are good. If you can’t access the text file, then re-evaluate the previous steps and try again.
    7. Restart he Network Location Awareness Service
      1. Open up services.msc and restart the Network Location Awareness Service
    Upon restarting the service the yellow triangle show disappear and if you hover over the icon it should now say “Internet Access”

    • Marked as answer by jdycus002 Wednesday, March 13, 2019 9:12 PM
    Wednesday, March 13, 2019 5:44 PM

All replies

  • Hi,

    Do you login your mailbox on a domain-joined computer or on a non-domain computer?

    I would suggest you try to test autodiscover with "Test Email AutoConfiguration" from Outlook client, then post the "Results" and "Log" at there(Remember remove privacy information):

     

    Then have a check in IIS, does the correct certificate is bind on your site:

    Regards,

    Kyle Xu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Tuesday, March 5, 2019 5:30 AM
    Moderator
  • The machine is domain joined.  I have run the "Test Email AutoConfiguration" as part of the troubleshooting I didn't post that step.  It succeeded.  I have opened a ticket with Microsoft and up to this point have confirmed what I have found in my troubleshooting: Autodiscover is working correctly.  After the autodiscover xml file gets passed to the client and the Outlook attempts to log into the mailbox it fails. So far I or they have not been able to figure out why. There doesn't appear to be any traffic on the IIS server that indicates the client is coming back to the server while attempting to log into the mailbox.  

    There is not firewalls, no proxies and no AV software.  I don't know what else would block traffic or stop traffic from getting back to server after Autodiscover succeeds.

    Wednesday, March 6, 2019 1:44 AM
  • If you install Outlook on your Exchange server, could you login mailbox on your Exchange server successfully? If you could login Outlook from your Exchange server, it means there still exist something block traffic between Exchange server and your client.

    Regards,

    Kyle Xu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Monday, March 11, 2019 2:39 AM
    Moderator
  • I installed it on the server and got the same error.  The only update I have from Microsoft at this time is after the client pulls the autodiscover xml file from the server all network communication ceases.  There are no logs that indicate a failure while trying to attempt to the server, just no MAPI communication beyond that point.
    Monday, March 11, 2019 4:10 PM
  • So after working with Microsoft yesterday we finally figured out what was going on.  Exchange 2016 now uses MAPI as the primary communication method between client and server which is well documented.  What is not well documented is the fact that on your client if you have an error on your network adapter MAPI will not attempt to connect. In my case where the network is offline there will always be an warning on the network adapter because of the no internet access.  You have to trick the machine into thinking it is connected to the internet or MAPI will never connect.  Below are the steps that are needed to accomplish this

    1. Create a text file:
      1. If your environment is Windows 10 only create a text file call “connecttest.txt”. Edit the text file and add the following text “Microsoft Connect Test” all on one line.  Do not add a line break after the text. Save the text file.
      2. If your environment will consist of both Windows 7 and Windows 10 follow step a first.  After step a is complete.  Create another text file called “ncsi.txt” Edit the text file and add the following text “Microsoft NCSI” all on one line.  Do not add a line break after the text. Save the text file.
    2. Configure a website that will host the .txt file(s) on port 80: Please note: According to Microsoft there is no way on the client side to tell the client to connect to another port other than 80. There are 3 options Microsoft gave to accomplish this task.
      1. If you already have an IIS server in your environment that is not utilizing port 80 this will work fine.
        1. Depending on your environment copy the text file(s) to the websites root directory. If using the default website site this would be  “%SystemDrive%\interpub\wwwroot”
      2. If you do not yet have an IIS server that is not utilizing port 80, pick a server in your environment and install the IIS role.  Just select the defaults when prompted. So special options needed.
        1. Depending on your environment copy the text file(s) to the default websites root directory “%SystemDrive%\interpub\wwwroot”
      3. If you have an IIS server that already has something being hosted on port 80 and you are comfortable adding another layer of complexity to your IIS environment, you can follow the steps in the link(s) below to allow multiple websites to share port 80.
        1. IIS 6 - https://support.microsoft.com/en-us/help/324287/how-to-use-host-header-names-to-configure-multiple-web-sites-in-intern
        2. IIS 7+ https://docs.microsoft.com/en-us/previous-versions/windows/it-pro/windows-server-2008-R2-and-2008/cc753195(v=ws.10)
        3. For both links if your environment is Windows 10 only the Website hostname will be www.msftconnecttest.com
        4. For both links if your environment is mixed then you will add 2 entries with the following hostnames:  www.msftconnecttest.com  and www.msftncsi.com
    3. Enable Directory Browsing on the website hosting your .txt file(s)
      1. Open IIS Manager
      2. Expand the tree until you find your website and then click on it
      3. In the middle pane double click on Directory Browsing.
      4. In the fa right pane click on “Enable”.  Leave all the check box’s default.
    4. Create a DNS Forward Lookup Zone(s)
      1. If your environment is Windows 10 only create a Forward Lookup Zone called “msftconnecttest.com”
      2. If your environment is a mixed environment, you will create 2 Forward Lookup Zone’s
        1. One called “msftconnecttest.com”
        2. One called “msftncsi.com”
    5. Within your newly created zone(s) you will create two A records:
      1. First A record will be called “www” and the IP will be the IP of your IIS server
      2. Second A record will be called “dns” and the IP will be the broadcast IP of your subnet
    6. Make sure the client can access the new website:
      1. Go to one of you clients and open a web browser.
      2. On a Windows 10 client navigate to http://www.msftconnecttest.com/connecttest.txt. If this resolve’s and shows you the contents of your text file, then you are good. If you can’t access the text file, then re-evaluate the previous steps and try again.
      3. One a Windows 7 client navigate to http://www.msftncsi.com/ncsi.txtIf this resolve’s and shows you the contents of your text file, then you are good. If you can’t access the text file, then re-evaluate the previous steps and try again.
    7. Restart he Network Location Awareness Service
      1. Open up services.msc and restart the Network Location Awareness Service
    Upon restarting the service the yellow triangle show disappear and if you hover over the icon it should now say “Internet Access”

    • Marked as answer by jdycus002 Wednesday, March 13, 2019 9:12 PM
    Wednesday, March 13, 2019 5:44 PM
  • Thanks for your sharing, it will be useful to many people to narrow down the same issue.

    Regards,

    Kyle Xu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Thursday, March 14, 2019 1:37 AM
    Moderator
  • Much appreciate for the detailed explanation and steps.  Most of all it worked and resolved what I have been facing for weeks.  Finally, I can move on!  

    Thank you for sharing and posting the answer.  


    Friday, August 23, 2019 12:21 AM